aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 12:02:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 12:02:27 +0000
commitd2365ade3ed8f5c25fe2597f50cbe80ba50f93e2 (patch)
treeb2ffcee9b3194f59429342c7239733f26fd8580a /textproc/aspell
parent41a994e6893fe352e5ad9817c82ab2e0435334c4 (diff)
downloadports-d2365ade3ed8f5c25fe2597f50cbe80ba50f93e2.tar.gz
ports-d2365ade3ed8f5c25fe2597f50cbe80ba50f93e2.zip
Extract the ispell wrapper out of aspell into a dedicated port
Cleanup up the aspell port Propertly strip aspell libraries Use short form of MASTER_SITES
Notes
Notes: svn path=/head/; revision=341537
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile26
-rw-r--r--textproc/aspell/pkg-plist4
2 files changed, 8 insertions, 22 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 549fdf941d6f..ab3e9a7467c2 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -3,21 +3,18 @@
PORTNAME= aspell
PORTVERSION= 0.60.6.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= aspell
+MASTER_SITES= GNU/aspell
MAINTAINER= office@FreeBSD.org
COMMENT= Spelling checker with better suggestion logic than ispell
LICENSE= LGPL21
-OPTIONS_DEFINE= NLS DOCS ISPELL
+OPTIONS_DEFINE= NLS DOCS
OPTIONS_SUB= yes
-ISPELL_DESC= Install the ispell wrapper
-
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
@@ -28,6 +25,7 @@ USES= gmake iconv perl5 shebangfix
USE_LDCONFIG= yes
SHEBANG_FILES= scripts/aspell-import
+INSTALL_TARGET= install-strip
VERINST= ${PORTVERSION:R:R}
SUB_FILES= aspell.ver
PLIST_SUB= VER=${VERINST}
@@ -35,28 +33,16 @@ SUB_LIST= VERINST=${VERINST}
INFO= aspell-dev aspell
NLS_USES= gettext
-NLS_CONFIGURE_ARGS= --disable-nls
+NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MISPELL}
-CONFLICTS+= ispell* ??-ispell*
-SCRIPTS= ispell spell
-.endif
-
# Does not link without at least -O
.if !defined(CFLAGS) || ${CFLAGS:M-O*} == ""
CFLAGS+= -O
.endif
-post-install: ${DICT_TARGET}
+post-install:
@${INSTALL_DATA} ${WRKDIR}/aspell.ver ${STAGEDIR}${PREFIX}/etc
-.if ${PORT_OPTIONS:MISPELL}
- @${INSTALL_SCRIPT} ${SCRIPTS:S|^|${WRKSRC}/scripts/|} ${STAGEDIR}${PREFIX}/bin
-.endif
- @${ECHO_CMD} "@dirrm share/aspell" >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/aspell-${VERINST}" >> ${TMPPLIST}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaspell.so.16 \
- ${STAGEDIR}${PREFIX}/lib/libpspell.so.16
.include <bsd.port.mk>
diff --git a/textproc/aspell/pkg-plist b/textproc/aspell/pkg-plist
index 61382a76d97c..25af7a89040b 100644
--- a/textproc/aspell/pkg-plist
+++ b/textproc/aspell/pkg-plist
@@ -1,13 +1,11 @@
bin/aspell
bin/aspell-import
-%%ISPELL%%bin/ispell
bin/precat
bin/preunzip
bin/prezip
bin/prezip-bin
bin/pspell-config
bin/run-with-aspell
-%%ISPELL%%bin/spell
bin/word-list-compress
etc/aspell.ver
include/aspell.h
@@ -133,3 +131,5 @@ man/man1/word-list-compress.1.gz
%%NLS%%@dirrmtry share/locale/fi
%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ast
+@dirrmtry %%DATADIR%%
+@dirrm lib/aspell-%%VER%%