aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-04 08:30:37 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-04 08:30:37 +0000
commitf027257d68fb6c9b6fb5faab7248172e59b59c28 (patch)
treed7d176827bf022e64d1e642eb81231d2965d251b /textproc/aspell
parent6ecb39ca33fdf88873edab0e96cb18f680877115 (diff)
downloadports-f027257d68fb6c9b6fb5faab7248172e59b59c28.tar.gz
ports-f027257d68fb6c9b6fb5faab7248172e59b59c28.zip
Stagify
Fix shebang for aspell itself, make perl also a run dependency for aspell (needed for a couple of scripts) Always install manpages for aspell.
Notes
Notes: svn path=/head/; revision=332672
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile39
-rw-r--r--textproc/aspell/Makefile.inc4
-rw-r--r--textproc/aspell/pkg-plist6
3 files changed, 25 insertions, 24 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 3bd5089a36f5..b179ddb527a2 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aspell
PORTVERSION= 0.60.6.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= aspell
@@ -18,24 +18,23 @@ OPTIONS_DEFINE= NLS DOCS ISPELL
ISPELL_DESC= Install the ispell wrapper
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
- --enable-docdir=${DOCSDIR} \
- --enable-curses=ncursesw \
- --enable-static
+CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
+ --enable-docdir=${DOCSDIR} \
+ --enable-curses=ncursesw \
+ --enable-static
-USE_GMAKE= yes
-USES= iconv perl5
-USE_PERL5= build
-USE_LDCONFIG= yes
+USES= gmake iconv perl5 shebangfix
+USE_LDCONFIG= yes
+SHEBANG_FILES= scripts/aspell-import
-MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
-VERINST= ${PORTVERSION:R:R}
-SUB_FILES= aspell.ver
-PLIST_SUB= VER=${VERINST}
-SUB_LIST= VERINST=${VERINST}
+VERINST= ${PORTVERSION:R:R}
+SUB_FILES= aspell.ver
+PLIST_SUB= VER=${VERINST}
+SUB_LIST= VERINST=${VERINST}
+INFO= aspell-dev aspell
-NO_STAGE= yes
.include <bsd.port.options.mk>
+
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
@@ -52,23 +51,19 @@ PLIST_SUB+= SCRIPTS=""
PLIST_SUB+= SCRIPTS="@comment "
.endif
-.if ${PORT_OPTIONS:MDOCS}
-MAN1= aspell-import.1 aspell.1 pspell-config.1 \
- run-with-aspell.1 word-list-compress.1 prezip-bin.1
-INFO= aspell-dev aspell
-.endif
-
# Does not link without at least -O
.if !defined(CFLAGS) || ${CFLAGS:M-O*} == ""
CFLAGS+= -O
.endif
post-install: ${DICT_TARGET}
- @${INSTALL_DATA} ${WRKDIR}/aspell.ver ${PREFIX}/etc
+ @${INSTALL_DATA} ${WRKDIR}/aspell.ver ${STAGEDIR}${PREFIX}/etc
.if ${PORT_OPTIONS:MISPELL}
@${INSTALL_SCRIPT} ${SCRIPTS:S|^|${WRKSRC}/scripts/|} ${PREFIX}/bin
.endif
@${ECHO_CMD} "@dirrm share/aspell" >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm lib/aspell-${VERINST}" >> ${TMPPLIST}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaspell.so.16 \
+ ${STAGEDIR}${PREFIX}/lib/libpspell.so.16
.include <bsd.port.mk>
diff --git a/textproc/aspell/Makefile.inc b/textproc/aspell/Makefile.inc
index ea212f999669..a375bb8d1371 100644
--- a/textproc/aspell/Makefile.inc
+++ b/textproc/aspell/Makefile.inc
@@ -6,10 +6,10 @@ MASTER_SITE_SUBDIR?= aspell/dict/${DICT}
DISTNAME?= aspell${DISTVERSION}
PORTVERSION?= ${DISTVERSION:L:C/cvs/0_/:C/pt_../p/:C/[0-9]?-?[a-z]+-//g:C/([0-9])([a-z])/\1.\2/g:C/:(.)/\1/g:C/[^a-z0-9+]+/./g}
-LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+USES+= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
HAS_CONFIGURE= yes
PLIST_SUB= VER=${VER}
diff --git a/textproc/aspell/pkg-plist b/textproc/aspell/pkg-plist
index 045a4d7e588d..eea606a8fe6a 100644
--- a/textproc/aspell/pkg-plist
+++ b/textproc/aspell/pkg-plist
@@ -77,6 +77,12 @@ lib/libpspell.a
lib/libpspell.la
lib/libpspell.so
lib/libpspell.so.16
+man/man1/aspell-import.1.gz
+man/man1/aspell.1.gz
+man/man1/prezip-bin.1.gz
+man/man1/pspell-config.1.gz
+man/man1/run-with-aspell.1.gz
+man/man1/word-list-compress.1.gz
%%DATADIR%%/ccpp.amf
%%DATADIR%%/comment.amf
%%DATADIR%%/email.amf