aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-08-12 13:37:06 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-08-12 13:37:06 +0000
commitfeb23a742c2325f964ce3a1d0c39f80bded0fc0d (patch)
tree618efe5290dad960996b6bf4628d02ce16db7dca /textproc/aspell
parente5528e29e020fcd7daae6eacd9c544b59ba9b70c (diff)
downloadports-feb23a742c2325f964ce3a1d0c39f80bded0fc0d.tar.gz
ports-feb23a742c2325f964ce3a1d0c39f80bded0fc0d.zip
Don't depend on gettext if WITHOUT_NLS is defined.
Submitted by: dougb
Notes
Notes: svn path=/head/; revision=197524
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index b992de8fc002..5ab6f35af6d6 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -24,14 +24,13 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
--enable-docdir=${DOCSDIR} \
- --enable-static
+ --enable-static
PTHREAD_CFLAGS= # Disable threading
PTHREAD_LIBS= # libaspell may be used by unthreaded apps.
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${LDFLAGS} ${PTHREAD_LIBS}"
USE_GMAKE= yes
USE_ICONV= yes
-USE_GETTEXT= yes
USE_PERL5_BUILD= yes
USE_LDCONFIG= yes
@@ -70,6 +69,7 @@ PLIST_SUB+= SCRIPTS="@comment "
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
+USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.endif