aboutsummaryrefslogtreecommitdiff
path: root/textproc/augeas
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-05-02 00:23:27 +0000
committerSteve Wills <swills@FreeBSD.org>2012-05-02 00:23:27 +0000
commitf17877dea13fb1693cfc0fefcd6b25c84d084f96 (patch)
treef9e49e86d86607fad8d7f2f1f37844f9c04c2696 /textproc/augeas
parentb6539a2ee93964f2c9e1c1f4d2cdce778f93490c (diff)
downloadports-f17877dea13fb1693cfc0fefcd6b25c84d084f96.tar.gz
ports-f17877dea13fb1693cfc0fefcd6b25c84d084f96.zip
- Remove custom rc.conf lens in favor of using of a patch which let's the
built in shellvars lens take care of this file. Upstream has already patched to do this and it should be in the next release. Users should be aware that extra quoting may be necessary.
Notes
Notes: svn path=/head/; revision=295825
Diffstat (limited to 'textproc/augeas')
-rw-r--r--textproc/augeas/Makefile7
-rw-r--r--textproc/augeas/files/patch-lenses__shellvars.aug10
-rw-r--r--textproc/augeas/files/rcconf.aug21
-rw-r--r--textproc/augeas/files/test_rcconf.aug24
-rw-r--r--textproc/augeas/pkg-plist2
5 files changed, 11 insertions, 53 deletions
diff --git a/textproc/augeas/Makefile b/textproc/augeas/Makefile
index 672709a33c34..65acacc9d2f6 100644
--- a/textproc/augeas/Makefile
+++ b/textproc/augeas/Makefile
@@ -8,7 +8,7 @@
PORTNAME= augeas
PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://augeas.net/download/
@@ -36,9 +36,4 @@ post-patch:
@${REINPLACE_CMD} -e 's:/bin/bash:/usr/bin/env bash:' ${WRKSRC}/tests/*.sh
@${REINPLACE_CMD} -e 's:sed:gsed:' ${WRKSRC}/tests/test-augtool.sh
-post-install:
- ${MKDIR} ${LENSESDIR}/tests
- ${INSTALL_DATA} ${FILESDIR}/rcconf.aug ${LENSESDIR}/rcconf.aug
- ${INSTALL_DATA} ${FILESDIR}/test_rcconf.aug ${LENSESDIR}/tests/rcconf.aug
-
.include <bsd.port.mk>
diff --git a/textproc/augeas/files/patch-lenses__shellvars.aug b/textproc/augeas/files/patch-lenses__shellvars.aug
new file mode 100644
index 000000000000..3e185cbc84c2
--- /dev/null
+++ b/textproc/augeas/files/patch-lenses__shellvars.aug
@@ -0,0 +1,10 @@
+--- ./lenses/shellvars.aug.orig 2012-05-01 13:51:21.934163842 -0400
++++ ./lenses/shellvars.aug 2012-05-01 13:52:04.015160071 -0400
+@@ -196,6 +196,7 @@
+ . incl "/etc/cron-apt/config"
+ . incl "/etc/environment"
+ . incl "/etc/blkid.conf"
++ . incl "/etc/rc.conf"
+
+ let filter = filter_sysconfig
+ . filter_ifcfg
diff --git a/textproc/augeas/files/rcconf.aug b/textproc/augeas/files/rcconf.aug
deleted file mode 100644
index b91219f771a2..000000000000
--- a/textproc/augeas/files/rcconf.aug
+++ /dev/null
@@ -1,21 +0,0 @@
-module RcConf =
- autoload xfm
-
- let comment = Util.comment
- let empty = Util.empty
- let eol = Util.eol
- let eq = Util.del_str "="
- let dquot = Util.del_str "\""
- let char = /[^\n]/
- let var_name = /[A-Za-z0-9_.]+/
-
- let value = dquot . store char* . dquot
- let kv_pair = [ key var_name . eq . value . eol ]
-
- let lns = (comment | empty | kv_pair)*
-
- let filter = incl "/etc/rc.conf"
- . incl "/boot/loader.conf"
- . Util.stdexcl
-
- let xfm = transform lns filter
diff --git a/textproc/augeas/files/test_rcconf.aug b/textproc/augeas/files/test_rcconf.aug
deleted file mode 100644
index df46447b45e1..000000000000
--- a/textproc/augeas/files/test_rcconf.aug
+++ /dev/null
@@ -1,24 +0,0 @@
-module Test_RcConf =
- let conf = "# /etc/rc.conf
-
-hostname=\"host.domain\"
-defaultrouter=\"4.3.2.1\"
-ipv4_addrs_em0=\"4.3.2.2/24\"
-
-foo_enable=\"YES\"
-foo_flags=\"-a --foobar\"
-bar_enable=\"NO\"
-bar_flags=\"\"
-"
-
- test RcConf.lns get conf =
- { "#comment" = "/etc/rc.conf" }
- {}
- { "hostname" = "host.domain" }
- { "defaultrouter" = "4.3.2.1" }
- { "ipv4_addrs_em0" = "4.3.2.2/24" }
- {}
- { "foo_enable" = "YES" }
- { "foo_flags" = "-a --foobar" }
- { "bar_enable" = "NO" }
- { "bar_flags" = "" }
diff --git a/textproc/augeas/pkg-plist b/textproc/augeas/pkg-plist
index 183827dc0fae..e1cbc7bcd901 100644
--- a/textproc/augeas/pkg-plist
+++ b/textproc/augeas/pkg-plist
@@ -231,8 +231,6 @@ libdata/pkgconfig/augeas.pc
%%DATADIR%%/lenses/dist/xml.aug
%%DATADIR%%/lenses/dist/xorg.aug
%%DATADIR%%/lenses/dist/yum.aug
-%%DATADIR%%/lenses/rcconf.aug
-%%DATADIR%%/lenses/tests/rcconf.aug
share/vim/vimfiles/ftdetect/augeas.vim
share/vim/vimfiles/syntax/augeas.vim
@dirrm %%DATADIR%%/lenses/dist/tests