aboutsummaryrefslogtreecommitdiff
path: root/textproc/beediff/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-24 12:52:48 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-24 12:52:48 +0000
commita385653e01933b970157da63341fecced813a72a (patch)
tree7b832d27cbc62a51edc092641df8a13c71201732 /textproc/beediff/Makefile
parent263d06b737b767109d4873b2e31d9fb992940a0b (diff)
downloadports-a385653e01933b970157da63341fecced813a72a.tar.gz
ports-a385653e01933b970157da63341fecced813a72a.zip
Notes
Diffstat (limited to 'textproc/beediff/Makefile')
-rw-r--r--textproc/beediff/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/textproc/beediff/Makefile b/textproc/beediff/Makefile
new file mode 100644
index 000000000000..0ba0ad84fabd
--- /dev/null
+++ b/textproc/beediff/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: beediff
+# Date created: 2008-03-23
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= beediff
+PORTVERSION= 1.5
+CATEGORIES= textproc devel
+MASTER_SITES= http://www.beesoft.org/download/
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= QT4 based diff frontend
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc_build rcc_build qmake_build
+HAS_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PLIST_FILES= bin/beediff share/pixmaps/beediff.png
+
+DESKTOP_ENTRIES="BeeDiff" "diff frontend" "beediff.png" \
+ "beediff" "" false
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE}
+
+post-configure:
+ @${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; \
+ s|^CXX .*|CXX=${CXX}|; \
+ s|^LINK .*|LINK=${CXX}|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/beediff ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/img/beediff.png ${PREFIX}/share/pixmaps/
+
+.include <bsd.port.mk>