aboutsummaryrefslogtreecommitdiff
path: root/textproc/belr
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2018-10-18 13:31:00 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2018-10-18 13:31:00 +0000
commit9ff73185e108e00589fe2cecd1410bc0aa342e0c (patch)
treec4d6461e6b7ba3ce0cc3319a892ddb2d78a6030f /textproc/belr
parent0a539a80c5388f1f61b8a2f6048884c97966dcdd (diff)
downloadports-9ff73185e108e00589fe2cecd1410bc0aa342e0c.tar.gz
ports-9ff73185e108e00589fe2cecd1410bc0aa342e0c.zip
Update the Linphone stack and drop maintainership.
Linphone uses Qt5 now instead of GTK2. audio/bcg729: - switch to cmake, required by net/mediastreamer - download distfile instead of using gitlab - fix license: source code allows later GPL version audio/msbcg729: deleted, net/mediastreamer contains a G.729 codec now audio/msilbc: deleted, superseded by multimedia/mswebrtc deskutils/belcard: version 1.0.2 multimedia/bcmatroska2: version 0.23 multimedia/msopenh264: version 1.2.1 multimedia/mswebrtc: version 1.1.1 multimedia/msx264: deleted, superseded by msopenh264 net/bctoolbox: version 0.6.0 net/belle-sip: version 1.6.3 net/liblinphone: version 3.12.0 net/linphone: version 4.1.1 + upstream Qt 5.11 patches net/mediastreamer: version 2.16.1 + upstream libsrtp2 patch net/ortp: version 1.0.2 + bump dependent port devel/libosmo-abis security/bzrtp: version 1.0.6 textproc/belr: version 0.1.3
Notes
Notes: svn path=/head/; revision=482343
Diffstat (limited to 'textproc/belr')
-rw-r--r--textproc/belr/Makefile22
-rw-r--r--textproc/belr/distinfo3
-rw-r--r--textproc/belr/pkg-descr5
-rw-r--r--textproc/belr/pkg-plist11
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/belr/Makefile b/textproc/belr/Makefile
new file mode 100644
index 000000000000..52924a41da62
--- /dev/null
+++ b/textproc/belr/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= belr
+PORTVERSION= 0.1.3
+CATEGORIES= textproc
+MASTER_SITES= https://www.linphone.org/releases/sources/belr/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Language recognition library
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libbctoolbox.so:net/bctoolbox
+
+USES= cmake:outsource
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DENABLE_STATIC=NO -DENABLE_STRICT=NO
+WRKSRC= ${WRKDIR}/${DISTNAME}-0
+
+.include <bsd.port.mk>
diff --git a/textproc/belr/distinfo b/textproc/belr/distinfo
new file mode 100644
index 000000000000..6a1a792b3787
--- /dev/null
+++ b/textproc/belr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539600140
+SHA256 (belr-0.1.3.tar.gz) = 81995491f6049f67cf84339ed69880816186ed518dd5d80e6b3b793c1e139bbb
+SIZE (belr-0.1.3.tar.gz) = 47659
diff --git a/textproc/belr/pkg-descr b/textproc/belr/pkg-descr
new file mode 100644
index 000000000000..6ea247dfa806
--- /dev/null
+++ b/textproc/belr/pkg-descr
@@ -0,0 +1,5 @@
+Belr is Belledonne Communications' language recognition library, written
+in C++11. It aims at parsing any input formatted according to a language
+defined by an ABNF grammar, such as the protocols standardized at IETF.
+
+WWW: https://www.linphone.org/
diff --git a/textproc/belr/pkg-plist b/textproc/belr/pkg-plist
new file mode 100644
index 000000000000..9ccb47ff3201
--- /dev/null
+++ b/textproc/belr/pkg-plist
@@ -0,0 +1,11 @@
+bin/belr-parse
+include/belr/abnf.hh
+include/belr/belr.hh
+include/belr/grammarbuilder.hh
+include/belr/parser-impl.cc
+include/belr/parser.hh
+lib/libbelr.so
+lib/libbelr.so.1
+share/Belr/cmake/BelrConfig.cmake
+share/Belr/cmake/BelrTargets-%%CMAKE_BUILD_TYPE%%.cmake
+share/Belr/cmake/BelrTargets.cmake