aboutsummaryrefslogtreecommitdiff
path: root/textproc/bsdgrep
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2011-09-12 13:12:18 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2011-09-12 13:12:18 +0000
commit7892b43f154e339d2e8dd6dd2dd4995f7034afa6 (patch)
tree08faf9b6ac96181dc25c7384fb737a6073fa6551 /textproc/bsdgrep
parent3d66637d50372bf5c698b6959cdaa541f9d30c2d (diff)
downloadports-7892b43f154e339d2e8dd6dd2dd4995f7034afa6.tar.gz
ports-7892b43f154e339d2e8dd6dd2dd4995f7034afa6.zip
Notes
Diffstat (limited to 'textproc/bsdgrep')
-rw-r--r--textproc/bsdgrep/Makefile31
-rw-r--r--textproc/bsdgrep/distinfo4
-rw-r--r--textproc/bsdgrep/pkg-plist9
3 files changed, 35 insertions, 9 deletions
diff --git a/textproc/bsdgrep/Makefile b/textproc/bsdgrep/Makefile
index f804a6db48cb..7e6248141e35 100644
--- a/textproc/bsdgrep/Makefile
+++ b/textproc/bsdgrep/Makefile
@@ -6,20 +6,28 @@
#
PORTNAME= grep
-PORTVERSION= 20091130
+PORTVERSION= 20110912
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= gabor
PKGNAMEPREFIX= bsd-
MAINTAINER= gabor@FreeBSD.org
-COMMENT= BSD-licensed version of grep from OpenBSD
+COMMENT= BSD-licensed version of grep
-WRKSRC= ${WRKDIR}/${PORTNAME}
MANCOMPRESSED= maybe
MAN1= grep.1
-MLINKS= grep.1 egrep.1 \
+MLINKS= grep.1 bzegrep.1 \
+ grep.1 bzfgrep.1 \
+ grep.1 bzgrep.1 \
+ grep.1 egrep.1 \
grep.1 fgrep.1 \
+ grep.1 lzegrep.1 \
+ grep.1 lzfgrep.1 \
+ grep.1 lzgrep.1 \
+ grep.1 xzegrep.1 \
+ grep.1 xzfgrep.1 \
+ grep.1 xzgrep.1 \
grep.1 zgrep.1 \
grep.1 zegrep.1 \
grep.1 zfgrep.1
@@ -27,15 +35,20 @@ MLINKS= grep.1 egrep.1 \
MAKE_ENV+= BINDIR="${PREFIX}/bin" \
MANDIR="${MANPREFIX}/man/man" \
CATDIR="${MANPREFIX}/man/man" \
- NLSDIR="${PREFIX}/share/nls"
+ NLSDIR="${PREFIX}/share/nls" \
+ MK_BSD_GREP="yes"
-OPTIONS= NLS "Compile with NLS support" on \
+OPTIONS= NLS "Compile with NLS support" on \
GNU_COMPAT "Use GNU regex library (recommended)" on
CONFLICTS= gnugrep-*
.include <bsd.port.pre.mk>
+.if !(${OSVERSION} >= 900012 || (${OSVERSION} < 900000 && ${OSVERSION} >= 800505))
+LIB_DEPENDS+= lzma.5:${PORTSDIR}/archivers/xz
+.endif
+
.if defined(WITHOUT_NLS)
MAKE_ENV+= WITHOUT_NLS=yes
PLIST_SUB+= NLS="@comment "
@@ -47,9 +60,13 @@ PLIST_SUB+= NLS=""
MAKE_ENV+= WITHOUT_GNU_COMPAT=yes
.endif
+# XXX: fix upstream
+post-patch:
+ ${REINPLACE_CMD} 's/xzefgrep/xzegrep/g' ${WRKSRC}/Makefile
+
pre-install:
.if defined(WITH_NLS)
- ${MKDIR} -p ${LOCALBASE}/share/nls/gl_ES.ISO8859-1
+ ${MKDIR} ${LOCALBASE}/share/nls/gl_ES.ISO8859-1
.endif
post-install:
diff --git a/textproc/bsdgrep/distinfo b/textproc/bsdgrep/distinfo
index c890c91f78a7..9c1ae0844479 100644
--- a/textproc/bsdgrep/distinfo
+++ b/textproc/bsdgrep/distinfo
@@ -1,2 +1,2 @@
-SHA256 (grep-20091130.tar.gz) = cbf0613a15ab96b3668aa505c33b5249bb43e3696d34288f7f77e722c96ef404
-SIZE (grep-20091130.tar.gz) = 18368
+SHA256 (grep-20110912.tar.gz) = 0cf57a78925721e720407616b32c7f489aae24e578ea05a336a2b995e3827025
+SIZE (grep-20110912.tar.gz) = 31932
diff --git a/textproc/bsdgrep/pkg-plist b/textproc/bsdgrep/pkg-plist
index f6eae90054b0..26c9aa15ecc0 100644
--- a/textproc/bsdgrep/pkg-plist
+++ b/textproc/bsdgrep/pkg-plist
@@ -1,10 +1,19 @@
@exec /bin/ln -s %%PREFIX%%/bin/grep %%PREFIX%%/bin/bsdgrep
@exec /bin/ln -s /usr/bin/grep %%PREFIX%%/bin/gnugrep
bin/bsdgrep
+bin/bzegrep
+bin/bzfgrep
+bin/bzgrep
bin/egrep
bin/fgrep
bin/gnugrep
bin/grep
+bin/lzegrep
+bin/lzfgrep
+bin/lzgrep
+bin/xzegrep
+bin/xzfgrep
+bin/xzgrep
bin/zgrep
bin/zegrep
bin/zfgrep