aboutsummaryrefslogtreecommitdiff
path: root/textproc/bsdsort
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-15 16:17:20 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-15 16:17:20 +0000
commitdcbefbef1f6715b47634253650ba0a786b06e87c (patch)
tree38ab670b40a3e0c1d662a3436116d765bf0a6ae0 /textproc/bsdsort
parent0714e8944305d529a2a6d847c4c9268287d6277c (diff)
downloadports-dcbefbef1f6715b47634253650ba0a786b06e87c.tar.gz
ports-dcbefbef1f6715b47634253650ba0a786b06e87c.zip
- Fix build with -current's clang by fixing header typo
- Use OPTIONS helpers - Remove pre-install target that checked whether a file exists in ${STAGEDIR}${PREFIX} (it doesn't)
Notes
Notes: svn path=/head/; revision=364990
Diffstat (limited to 'textproc/bsdsort')
-rw-r--r--textproc/bsdsort/Makefile27
-rw-r--r--textproc/bsdsort/files/patch-vsort.h11
2 files changed, 17 insertions, 21 deletions
diff --git a/textproc/bsdsort/Makefile b/textproc/bsdsort/Makefile
index 3ef720e11b23..9dfbe01564b7 100644
--- a/textproc/bsdsort/Makefile
+++ b/textproc/bsdsort/Makefile
@@ -24,37 +24,22 @@ MAKE_ENV+= BINDIR="${PREFIX}/bin" \
CFLAGS+= -std=c99
OPTIONS_DEFINE= THREADS NLS OVERWRITE_BASE
-OVERWRITE_BASE_DESC= Replaces base GNU sort
+OVERWRITE_BASE_DESC= Replace base GNU sort
OPTIONS_DEFAULT= THREADS NLS
+OPTIONS_SUB= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-PLIST_SUB+= NLS=""
-.else
-MAKE_ENV+= WITHOUT_NLS=yes
-PLIST_SUB+= NLS="@comment "
-.endif
+NLS_MAKE_ENV_OFF= WITHOUT_NLS=yes
+THREADS_MAKE_ENV= WITH_THREADS=yes
-.if ${PORT_OPTIONS:MTHREADS}
-MAKE_ENV+= WITH_THREADS=yes
-.endif
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MOVERWRITE_BASE}
PREFIX= /usr
-PLIST_SUB+= OVERWRITE_BASE="" NO_OVERWRITE_BASE="@comment "
-.else
-PLIST_SUB+= OVERWRITE_BASE="@comment " NO_OVERWRITE_BASE=""
-.endif
-
-.if defined(WITH_OVERWRITE_BASE) && exists(${STAGEDIR}${PREFIX}/bin/sort)
-pre-install:
- ${INSTALL_PROGRAM} ${STAGEDIR}${PREFIX}/bin/sort ${STAGEDIR}${PREFIX}/bin/gnusort
.endif
post-install:
${LN} -s ${PREFIX}/bin/sort ${STAGEDIR}${PREFIX}/bin/bsdsort
-.if !defined(WITH_OVERWRITE_BASE)
+.if empty(OVERWRITE_BASE)
${LN} -s /usr/bin/sort ${STAGEDIR}${PREFIX}/bin/gnusort
.endif
diff --git a/textproc/bsdsort/files/patch-vsort.h b/textproc/bsdsort/files/patch-vsort.h
new file mode 100644
index 000000000000..a966e5c111fe
--- /dev/null
+++ b/textproc/bsdsort/files/patch-vsort.h
@@ -0,0 +1,11 @@
+--- vsort.h.orig 2014-08-15 12:06:55.000000000 -0400
++++ vsort.h 2014-08-15 12:07:03.000000000 -0400
+@@ -28,7 +28,7 @@
+ */
+
+ #if !defined(__VSORT_H__)
+-#define _VSORT_H__
++#define __VSORT_H__
+
+ #include "bwstring.h"
+