aboutsummaryrefslogtreecommitdiff
path: root/textproc/cdif
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /textproc/cdif
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'textproc/cdif')
-rw-r--r--textproc/cdif/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/textproc/cdif/Makefile b/textproc/cdif/Makefile
index 309234d95baa..9f72be513618 100644
--- a/textproc/cdif/Makefile
+++ b/textproc/cdif/Makefile
@@ -10,7 +10,8 @@ EXTRACT_SUFX= # empty
MAINTAINER= sanpei@FreeBSD.org
COMMENT= Word context diff
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${DISTNAME}
NO_WRKSUBDIR= yes
NO_BUILD= yes
@@ -18,12 +19,7 @@ NO_BUILD= yes
PLIST_FILES= bin/cdif
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}.dist
-
-do-patch:
- ${SED} -e '1s@/usr/local/bin/perl@${PERL}@' \
- < ${WRKSRC}/${DISTNAME}.dist > ${WRKSRC}/${DISTNAME}
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${STAGEDIR}${PREFIX}/bin/cdif