aboutsummaryrefslogtreecommitdiff
path: root/textproc/chpp
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-02 10:07:53 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-02 10:07:53 +0000
commit6c4236362b5f6002243dd72f3f95030972aeecd4 (patch)
tree25bccafc28c06dc39fa39ddb2e4e2d18610c25da /textproc/chpp
parent67018d7b1be9d960ef033471f7a8364f2de1f778 (diff)
downloadports-6c4236362b5f6002243dd72f3f95030972aeecd4.tar.gz
ports-6c4236362b5f6002243dd72f3f95030972aeecd4.zip
Notes
Diffstat (limited to 'textproc/chpp')
-rw-r--r--textproc/chpp/Makefile15
-rw-r--r--textproc/chpp/files/patch-avl.h15
-rw-r--r--textproc/chpp/pkg-descr2
-rw-r--r--textproc/chpp/pkg-plist210
4 files changed, 129 insertions, 113 deletions
diff --git a/textproc/chpp/Makefile b/textproc/chpp/Makefile
index 8d214d4bc042..b9b10896b3fc 100644
--- a/textproc/chpp/Makefile
+++ b/textproc/chpp/Makefile
@@ -1,6 +1,6 @@
# New ports collection makefile for: chpp
# Date created: 4 May 1999
-# Whom: Andrey Zakhvatov
+# Whom: Andrey Zakhvatov <andy@FreeBSD.org>
#
# $FreeBSD$
#
@@ -16,21 +16,22 @@ COMMENT= Non-intrusive full-featured text preprocessor
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
-EXAMPLES_DIR= ${PREFIX}/share/examples/chpp
INFO= chpp
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
-BROKEN= "Does not compile"
+BROKEN= Does not compile
.endif
post-install:
- @${MKDIR} ${EXAMPLES_DIR}
+ @${MKDIR} ${EXAMPLESDIR}
${TAR} -C ${WRKSRC}/test -cf - . | \
- ${TAR} -C ${EXAMPLES_DIR} --unlink -xf -
- @${FIND} ${EXAMPLES_DIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- @${FIND} ${EXAMPLES_DIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+.if !defined(NOPORTEXAMPLES)
+ @${FIND} ${EXAMPLESDIR} | ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
+ @${FIND} ${EXAMPLESDIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS NEWS README
diff --git a/textproc/chpp/files/patch-avl.h b/textproc/chpp/files/patch-avl.h
new file mode 100644
index 000000000000..f9dbd16110b5
--- /dev/null
+++ b/textproc/chpp/files/patch-avl.h
@@ -0,0 +1,15 @@
+--- avl.h.orig Thu Oct 29 02:25:09 1998
++++ avl.h Mon Jul 2 16:47:44 2007
+@@ -44,7 +44,11 @@
+ } avlTree;
+
+ #define AVL_LINK(a,N) (((a) == -1) ? (N)->left : (N)->right)
+-#define AVL_LINK_SET(s,P,V) ((((s) == -1) ? (P)->left : (P)->right) = (V))
++#define AVL_LINK_SET(s,P,V) \
++ do { \
++ typeof (V) foo = (((s) == -1) ? (P)->left : (P)->right); \
++ foo = (V); \
++ } while (0)
+
+ int avlCompare (avlTree*, void*, unsigned int, avlNode*);
+ int avlBalance (avlNode*, int, avlNode**);
diff --git a/textproc/chpp/pkg-descr b/textproc/chpp/pkg-descr
index 4932c0c9efd2..7217798564dc 100644
--- a/textproc/chpp/pkg-descr
+++ b/textproc/chpp/pkg-descr
@@ -5,7 +5,7 @@ What distinguishes `chpp' from other textprocessors are mainly two
features:
* `chpp' is non-intrusive. This means that you can take your
- favourite text and it is very unlikely that it will be changed when
+ favorite text and it is very unlikely that it will be changed when
piped through `chpp'. Due to this feature it is pretty easy to
start using `chpp' since you can just start writing your text and
need not concern yourself with `chpp' sitting in the background
diff --git a/textproc/chpp/pkg-plist b/textproc/chpp/pkg-plist
index 60ca158e2d1c..95a18c40a394 100644
--- a/textproc/chpp/pkg-plist
+++ b/textproc/chpp/pkg-plist
@@ -1,106 +1,106 @@
bin/chpp
-share/chpp/include/cgi.chh
-share/chpp/include/files.chh
-share/chpp/include/list.chh
-share/chpp/include/sql.chh
-share/chpp/include/strings.chh
-share/chpp/include/time.chh
-share/chpp/include/w3lib.chh
-%%PORTDOCS%%share/doc/chpp/AUTHORS
-%%PORTDOCS%%share/doc/chpp/NEWS
-%%PORTDOCS%%share/doc/chpp/README
-share/examples/chpp/regress/dotest
-share/examples/chpp/regress/tests
-share/examples/chpp/regress/arith/arith.txt
-share/examples/chpp/regress/arith/expected.err
-share/examples/chpp/regress/arith/expected.out
-share/examples/chpp/regress/array/array.txt
-share/examples/chpp/regress/array/expected.err
-share/examples/chpp/regress/array/expected.out
-share/examples/chpp/regress/assoc/assoc.txt
-share/examples/chpp/regress/assoc/expected.err
-share/examples/chpp/regress/assoc/expected.out
-share/examples/chpp/regress/define/define.txt
-share/examples/chpp/regress/define/expected.err
-share/examples/chpp/regress/define/expected.out
-share/examples/chpp/regress/error/error.txt
-share/examples/chpp/regress/error/error2.txt
-share/examples/chpp/regress/error/error3.txt
-share/examples/chpp/regress/fileops/expected.err
-share/examples/chpp/regress/fileops/expected.out
-share/examples/chpp/regress/fileops/fileops.txt
-share/examples/chpp/regress/fileops/test.data
-share/examples/chpp/regress/hanoi/expected.err
-share/examples/chpp/regress/hanoi/expected.out
-share/examples/chpp/regress/hanoi/hanoi.txt
-share/examples/chpp/regress/include/incdir/incdir2/recinc3.txt
-share/examples/chpp/regress/include/incdir/recinc1.txt
-share/examples/chpp/regress/include/incdir/recinc2.txt
-share/examples/chpp/regress/include/expected.err
-share/examples/chpp/regress/include/expected.out
-share/examples/chpp/regress/include/include.txt
-share/examples/chpp/regress/include/include2.txt
-share/examples/chpp/regress/include/include3.txt
-share/examples/chpp/regress/include/include4.txt
-share/examples/chpp/regress/loops/expected.err
-share/examples/chpp/regress/loops/expected.out
-share/examples/chpp/regress/loops/loops.txt
-share/examples/chpp/regress/metachar/expected.err
-share/examples/chpp/regress/metachar/expected.out
-share/examples/chpp/regress/metachar/metachar.txt
-share/examples/chpp/regress/regex/expected.err
-share/examples/chpp/regress/regex/expected.out
-share/examples/chpp/regress/regex/regex.txt
-share/examples/chpp/regress/stringops/expected.err
-share/examples/chpp/regress/stringops/expected.out
-share/examples/chpp/regress/stringops/stringops.txt
-share/examples/chpp/tautogen/data.cslab
-share/examples/chpp/tautogen/data.new
-share/examples/chpp/tautogen/grammar
-share/examples/chpp/tautogen/tautogen.csml
-share/examples/chpp/website/Makefile
-share/examples/chpp/website/choicebar.chml
-share/examples/chpp/website/choicestrip.chml
-share/examples/chpp/website/footer.chml
-share/examples/chpp/website/header.chml
-share/examples/chpp/website/menu.chml
-share/examples/chpp/website/news.csml
-share/examples/chpp/website/news_a.html
-share/examples/chpp/website/news_l.jpg
-share/examples/chpp/website/news_s.jpg
-share/examples/chpp/website/news_s_g.jpg
-share/examples/chpp/website/news_t.chml
-share/examples/chpp/website/template.chml
-share/examples/chpp/website/tips.csml
-share/examples/chpp/website/tips_a.html
-share/examples/chpp/website/tips_l.jpg
-share/examples/chpp/website/tips_s.jpg
-share/examples/chpp/website/tips_s_g.jpg
-share/examples/chpp/website/tips_t.chml
-share/examples/chpp/website/tricks.csml
-share/examples/chpp/website/tricks_a.html
-share/examples/chpp/website/tricks_l.jpg
-share/examples/chpp/website/tricks_s.jpg
-share/examples/chpp/website/tricks_s_g.jpg
-share/examples/chpp/website/tricks_t.chml
-@dirrm share/examples/chpp/website
-@dirrm share/examples/chpp/tautogen
-@dirrm share/examples/chpp/regress/stringops
-@dirrm share/examples/chpp/regress/regex
-@dirrm share/examples/chpp/regress/metachar
-@dirrm share/examples/chpp/regress/loops
-@dirrm share/examples/chpp/regress/include/incdir/incdir2
-@dirrm share/examples/chpp/regress/include/incdir
-@dirrm share/examples/chpp/regress/include
-@dirrm share/examples/chpp/regress/hanoi
-@dirrm share/examples/chpp/regress/fileops
-@dirrm share/examples/chpp/regress/error
-@dirrm share/examples/chpp/regress/define
-@dirrm share/examples/chpp/regress/assoc
-@dirrm share/examples/chpp/regress/array
-@dirrm share/examples/chpp/regress/arith
-@dirrm share/examples/chpp/regress
-@dirrm share/examples/chpp
-%%PORTDOCS%%@dirrm share/doc/chpp
-@dirrm share/chpp/include
-@dirrm share/chpp
+%%DATADIR%%/include/cgi.chh
+%%DATADIR%%/include/files.chh
+%%DATADIR%%/include/list.chh
+%%DATADIR%%/include/sql.chh
+%%DATADIR%%/include/strings.chh
+%%DATADIR%%/include/time.chh
+%%DATADIR%%/include/w3lib.chh
+@dirrm %%DATADIR%%/include
+@dirrm %%DATADIR%%
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/dotest
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/tests
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/arith/arith.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/arith/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/arith/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/array/array.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/array/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/array/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/assoc/assoc.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/assoc/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/assoc/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/define/define.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/define/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/define/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/error/error.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/error/error2.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/error/error3.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/fileops/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/fileops/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/fileops/fileops.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/fileops/test.data
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/hanoi/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/hanoi/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/hanoi/hanoi.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/incdir/incdir2/recinc3.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/incdir/recinc1.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/incdir/recinc2.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/include.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/include2.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/include3.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/include/include4.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/loops/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/loops/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/loops/loops.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/metachar/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/metachar/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/metachar/metachar.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/regex/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/regex/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/regex/regex.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/stringops/expected.err
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/stringops/expected.out
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regress/stringops/stringops.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tautogen/data.cslab
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tautogen/data.new
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tautogen/grammar
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tautogen/tautogen.csml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/choicebar.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/choicestrip.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/footer.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/header.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/menu.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/news.csml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/news_a.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/news_l.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/news_s.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/news_s_g.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/news_t.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/template.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tips.csml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tips_a.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tips_l.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tips_s.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tips_s_g.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tips_t.chml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tricks.csml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tricks_a.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tricks_l.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tricks_s.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tricks_s_g.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website/tricks_t.chml
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/website
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tautogen
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/stringops
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/regex
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/metachar
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/loops
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/include/incdir/incdir2
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/include/incdir
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/include
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/hanoi
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/fileops
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/error
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/define
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/assoc
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/array
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress/arith
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/regress
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%