aboutsummaryrefslogtreecommitdiff
path: root/textproc/clucene
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 16:28:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-03 16:28:17 +0000
commit8cd2fbd90c5b1a2d42976b142d8f0824b6e3ad58 (patch)
tree3d0ffd9f758ad98cd356fc0aa12425fd5eb0d9fc /textproc/clucene
parentbf675dbc54f3bdaad6ab14c4ec019858956998ce (diff)
downloadports-8cd2fbd90c5b1a2d42976b142d8f0824b6e3ad58.tar.gz
ports-8cd2fbd90c5b1a2d42976b142d8f0824b6e3ad58.zip
Allow to build with clang and libc++
Notes
Notes: svn path=/head/; revision=326170
Diffstat (limited to 'textproc/clucene')
-rw-r--r--textproc/clucene/Makefile2
-rw-r--r--textproc/clucene/files/patch-libc++12
2 files changed, 13 insertions, 1 deletions
diff --git a/textproc/clucene/Makefile b/textproc/clucene/Makefile
index d0963db7fadd..af43b0474b19 100644
--- a/textproc/clucene/Makefile
+++ b/textproc/clucene/Makefile
@@ -20,7 +20,7 @@ USES= cmake iconv
USE_LDCONFIG= yes
CMAKE_ARGS= -DBUILD_CONTRIBS_LIB=ON
-CXXFLAGS+= -D__LONG_LONG_SUPPORTED
+CXXFLAGS+= -D__LONG_LONG_SUPPORTED -D_WCHAR_H_CPLUSPLUS_98_CONFIRMANCE_
post-patch:
@${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR_REL}|' \
diff --git a/textproc/clucene/files/patch-libc++ b/textproc/clucene/files/patch-libc++
new file mode 100644
index 000000000000..9ed4ac44f033
--- /dev/null
+++ b/textproc/clucene/files/patch-libc++
@@ -0,0 +1,12 @@
+--- src/shared/CLucene/LuceneThreads.h.orig 2011-03-17 01:21:07.000000000 +0100
++++ src/shared/CLucene/LuceneThreads.h 2013-09-03 18:25:01.380067076 +0200
+@@ -7,6 +7,9 @@
+ #ifndef _LuceneThreads_h
+ #define _LuceneThreads_h
+
++#if defined(_CL_HAVE_PTHREAD)
++#include <pthread.h>
++#endif
+
+ CL_NS_DEF(util)
+ class CLuceneThreadIdCompare;