aboutsummaryrefslogtreecommitdiff
path: root/textproc/coccigrep
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-04-14 23:00:32 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-04-14 23:00:32 +0000
commit25619370c19350982a957c909c9b55c1a2eec5d9 (patch)
treede291a2b079fa8da2b16b8c7b3b7d1156b63c232 /textproc/coccigrep
parent6613d4c6129f622163a96eea544b48021256c745 (diff)
downloadports-25619370c19350982a957c909c9b55c1a2eec5d9.tar.gz
ports-25619370c19350982a957c909c9b55c1a2eec5d9.zip
coccigrep is a semantic grep for the C language based on coccinelle. It can
be used to find where a given structure is used in code files. coccigrep depends on the spatch program which comes with coccinelle. WWW: https://home.regit.org/software/coccigrep/
Notes
Notes: svn path=/head/; revision=294834
Diffstat (limited to 'textproc/coccigrep')
-rw-r--r--textproc/coccigrep/Makefile38
-rw-r--r--textproc/coccigrep/distinfo2
-rw-r--r--textproc/coccigrep/pkg-descr5
-rw-r--r--textproc/coccigrep/pkg-plist30
4 files changed, 75 insertions, 0 deletions
diff --git a/textproc/coccigrep/Makefile b/textproc/coccigrep/Makefile
new file mode 100644
index 000000000000..7a28272b56a2
--- /dev/null
+++ b/textproc/coccigrep/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: coccigrep
+# Date created: 2012-04-14
+# Whom: Pawel Pekala <pawel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= coccigrep
+PORTVERSION= 1.8
+CATEGORIES= textproc
+MASTER_SITES= http://home.regit.org/wp-content/uploads/2011/08/
+
+MAINTAINER= pawel@FreeBSD.org
+COMMENT= Semantic grep for the C language
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${LOCALBASE}/bin/spatch:${PORTSDIR}/devel/coccinelle
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+MANCOMPRESSED= no
+
+MAN1= coccigrep.1
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/coccigrep.1 ${MANPREFIX}/man/man1
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/editors/cocci-grep.el ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/editors/cocci-grep.vim ${DATADIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.rst ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/coccigrep/distinfo b/textproc/coccigrep/distinfo
new file mode 100644
index 000000000000..20eaab3cd771
--- /dev/null
+++ b/textproc/coccigrep/distinfo
@@ -0,0 +1,2 @@
+SHA256 (coccigrep-1.8.tar.gz) = 91283cbfd141bb93ca6377301caf67463f4d5b48f683c791dd9f653863620c9f
+SIZE (coccigrep-1.8.tar.gz) = 32174
diff --git a/textproc/coccigrep/pkg-descr b/textproc/coccigrep/pkg-descr
new file mode 100644
index 000000000000..9e1ed7bc477a
--- /dev/null
+++ b/textproc/coccigrep/pkg-descr
@@ -0,0 +1,5 @@
+coccigrep is a semantic grep for the C language based on coccinelle. It can
+be used to find where a given structure is used in code files. coccigrep
+depends on the spatch program which comes with coccinelle.
+
+WWW: https://home.regit.org/software/coccigrep/
diff --git a/textproc/coccigrep/pkg-plist b/textproc/coccigrep/pkg-plist
new file mode 100644
index 000000000000..6754e0109582
--- /dev/null
+++ b/textproc/coccigrep/pkg-plist
@@ -0,0 +1,30 @@
+bin/coccigrep
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/coccigrep.py
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/__init__.py
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/coccigrep.cfg
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/coccigrep.pyc
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/__init__.pyc
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/data/set.cocci
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/data/deref.cocci
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/data/test.cocci
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/data/used.cocci
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/data/func.cocci
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/coccigrep.pyo
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/__init__.pyo
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/scripts/coccigrep
+%%DATADIR%%/cocci-grep.el
+%%DATADIR%%/cocci-grep.vim
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README.rst
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep/data
+@dirrm %%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/coccigrep
+@dirrm %%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO/scripts
+@dirrm %%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/coccigrep-1.8-py2.7.egg