aboutsummaryrefslogtreecommitdiff
path: root/textproc/coco
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2001-08-27 01:20:24 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2001-08-27 01:20:24 +0000
commit7b117d21671d6f9038809eb4a27e9f198fb9bbf6 (patch)
tree66c5fec50129c6628a27c1324ece64daf50596c9 /textproc/coco
parenta16fefc81e5449a692a199a5d460b746bbb7d930 (diff)
downloadports-7b117d21671d6f9038809eb4a27e9f198fb9bbf6.tar.gz
ports-7b117d21671d6f9038809eb4a27e9f198fb9bbf6.zip
Notes
Diffstat (limited to 'textproc/coco')
-rw-r--r--textproc/coco/Makefile1
-rw-r--r--textproc/coco/files/patch-mm14
-rw-r--r--textproc/coco/files/patch-oa117
-rw-r--r--textproc/coco/files/patch-ob12
4 files changed, 139 insertions, 5 deletions
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
index 02b1b1583db1..a7918e74d257 100644
--- a/textproc/coco/Makefile
+++ b/textproc/coco/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mule-common
PORTVERSION= ${MULE_VERSION}
+PORTREVISION= 1
CATEGORIES= editors japanese
MASTER_SITES= ftp://etlport.etl.go.jp/pub/mule/ \
ftp://ftp.mei.co.jp/archive/free/gnu/emacs/Mule/ \
diff --git a/textproc/coco/files/patch-mm b/textproc/coco/files/patch-mm
index f0b930462208..9a61745a872b 100644
--- a/textproc/coco/files/patch-mm
+++ b/textproc/coco/files/patch-mm
@@ -1,5 +1,5 @@
---- configure.orig Fri Sep 8 14:13:47 2000
-+++ configure Fri Sep 8 14:15:09 2000
+--- configure.orig Wed Jul 18 16:03:57 2001
++++ configure Wed Jul 18 16:37:11 2001
@@ -38,6 +38,10 @@
ac_help="$ac_help
--with-wnn6 Use Wnn6 library to input Japanese or Chinese"
@@ -33,7 +33,7 @@
archlibdir='${libexecdir}/${emacs_prefix}/${version}/${configuration}'
docdir='${datadir}/${emacs_prefix}/${version}/etc'
-@@ -671,9 +676,16 @@
+@@ -671,9 +676,20 @@
fi
@@ -46,11 +46,15 @@
# Check whether --with-wnn6 or --without-wnn6 was given.
if test "${with_wnn6+set}" = set; then
withval="$with_wnn6"
-+ wnnlib=-lwnn6
++if test "${with_wnn6}" = yes; then
++ wnnlib=-lwnn6
++else
++ wnnlib=$with_wnn6
++fi
with_wnn=${withval}; cat >> confdefs.h <<\EOF
#define WNN6 1
EOF
-@@ -3104,12 +3116,12 @@
+@@ -3104,12 +3120,12 @@
if test -n "${with_wnn_libraries}" ; then
if test -d ${with_wnn_libraries} ; then
LD_SWITCH_WNN="-L${with_wnn_libraries}"
diff --git a/textproc/coco/files/patch-oa b/textproc/coco/files/patch-oa
new file mode 100644
index 000000000000..dfcc9c9d2630
--- /dev/null
+++ b/textproc/coco/files/patch-oa
@@ -0,0 +1,117 @@
+--- lisp/eggrc-wnn.orig Mon Jul 16 04:31:14 2001
++++ lisp/eggrc-wnn Mon Jul 16 04:33:22 2001
+@@ -86,6 +86,99 @@
+
+ )
+
++(defun wnn7-jserver-setup ()
++ (set-wnn-reverse nil)
++ (set-wnn-fuzokugo "system/kougo.fzk")
++ (add-wnn-fisys-dict "system/fisd"
++ (concat wnn-usr-dic-dir "/fisd.h") t)
++ (add-wnn-fiusr-dict (concat wnn-usr-dic-dir "/fiud") "" t nil)
++ (add-wnn-dict "system/kihon.dic"
++ (concat wnn-usr-dic-dir "/kihon.h") 6 nil t)
++ (add-wnn-dict "system/symbol.dic"
++ (concat wnn-usr-dic-dir "/symbol.h") 1 nil t)
++;; (add-wnn-dict "system/symbol_noat.dic"
++;; (concat wnn-usr-dic-dir "/symbol_noat.h") 1 nil t)
++ (add-wnn-dict "system/tel.dic"
++ (concat wnn-usr-dic-dir "/tel.h") 1 nil t)
++ (add-wnn-dict "system/zip.dic"
++ (concat wnn-usr-dic-dir "/zip.h") 1 nil t)
++ (add-wnn-dict "system/tankan.dic" "" 1 nil nil)
++ (add-wnn-dict "system/tankan2.dic" "" 1 nil nil)
++ (add-wnn-dict "system/ikeiji.dic" "" 1 nil nil)
++ (add-wnn-dict "system/rensou.dic" "" 1 nil nil)
++ (add-wnn-dict (concat wnn-usr-dic-dir "/ud") "" 15 t t)
++
++; (add-wnn-dict "option/jinmei.dic"
++; (concat wnn-usr-dic-dir "/jinmei.h") 1 nil t)
++; (add-wnn-dict "option/chimei.dic"
++; (concat wnn-usr-dic-dir "/chimei.h") 1 nil t)
++; (add-wnn-dict "option/address.dic"
++; (concat wnn-usr-dic-dir "/address.h") 1 nil t)
++; (add-wnn-dict "option/station.dic"
++; (concat wnn-usr-dic-dir "/station.h") 1 nil t)
++; (add-wnn-dict "option/kana_english.dic"
++; (concat wnn-usr-dic-dir "/kana_english.h") 1 nil t)
++; (add-wnn-dict "option/enterprise.dic"
++; (concat wnn-usr-dic-dir "/enterprise.h") 1 nil t)
++; (add-wnn-dict "option/airport.dic"
++; (concat wnn-usr-dic-dir "/airport.h") 1 nil t)
++; (add-wnn-dict "option/university.dic"
++; (concat wnn-usr-dic-dir "/university.h") 1 nil t)
++; (add-wnn-dict "option/zoo.dic"
++; (concat wnn-usr-dic-dir "/zoo.h") 1 nil t)
++; (add-wnn-dict "option/botanical_garden.dic"
++; (concat wnn-usr-dic-dir "/botanical_garden.h") 1 nil t)
++; (add-wnn-dict "option/aquarium.dic"
++; (concat wnn-usr-dic-dir "/aquarium.h") 1 nil t)
++; (add-wnn-dict "option/conveni.dic"
++; (concat wnn-usr-dic-dir "/conveni.h") 1 nil t)
++; (add-wnn-dict "option/amusement.dic"
++; (concat wnn-usr-dic-dir "/amusement.h") 1 nil t)
++
++ (set-wnn-param 5 10 2 45 0 80 5 1 20 0 400 -100 400 80 200 2 200)
++
++ (add-wnn-notrans-dict (concat wnn-usr-dic-dir "/katakana") 15 t)
++ (add-wnn-bmodify-dict (concat wnn-usr-dic-dir "/bunsetsu") 15 t)
++
++ (set-last-is-first-mode t)
++ (set-complex-conv-mode nil)
++; (set-okuri-flag -1)
++ (set-prefix-flag 0)
++
++ (set-okuri-learn-mode t)
++ (set-prefix-learn-mode t)
++ (set-suffix-learn-mode t)
++ (set-common-learn-mode t)
++ (set-yuragi-mode nil)
++
++ (set-freq-func-mode 4)
++
++; (set-numeric-mode -12)
++; (set-alphabet-mode -30)
++; (set-symbol-mode -40)
++
++ (set-wnn-reverse t)
++ (set-wnn-fuzokugo "system/kougo.fzk")
++ (add-wnn-dict "system/kihonR.dic" "" 1 nil nil)
++ (add-wnn-dict "system/telR.dic" "" 1 nil nil)
++ (add-wnn-dict "system/zipR.dic" "" 1 nil nil)
++ (add-wnn-dict "system/tankanR.dic" "" 1 nil nil)
++ (add-wnn-dict "system/tankan2R.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/stationR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/kana_englishR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/enterpriseR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/airportR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/universityR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/zooR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/botanical_gardenR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/aquariumR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/conveniR.dic" "" 1 nil nil)
++ ;;(add-wnn-dict "option/amusementR.dic" "" 1 nil nil)
++
++ (add-wnn-dict (concat wnn-usr-dic-dir "/ud") "" 15 t t)
++ (set-wnn-param 2 10 2 45 1 80 5 1 50 -20 400 -10 100 -100 200 0 200)
++ )
++
+
+ (defun wnn4-jserver-setup ()
+ (set-wnn-reverse nil)
+@@ -126,9 +219,11 @@
+ )
+
+ (cond ((eq wnn-server-type 'jserver)
+- (if (is-wnn6-server)
+- (wnn6-jserver-setup)
+- (wnn4-jserver-setup)))
++ (if (is-wnn7-server)
++ (wnn7-jserver-setup)
++ (if (is-wnn6-server)
++ (wnn6-jserver-setup)
++ (wnn4-jserver-setup))))
+ ((eq wnn-server-type 'cserver)
+ (set-wnn-reverse nil)
+ (set-wnn-fuzokugo "sys/full.con")
diff --git a/textproc/coco/files/patch-ob b/textproc/coco/files/patch-ob
new file mode 100644
index 000000000000..9d512f97cc25
--- /dev/null
+++ b/textproc/coco/files/patch-ob
@@ -0,0 +1,12 @@
+--- lisp/wnn-egg.el.bak Mon Jul 16 04:37:50 2001
++++ lisp/wnn-egg.el Mon Jul 16 04:42:05 2001
+@@ -606,6 +606,9 @@
+ (defun is-wnn6-server ()
+ (= (wnn-server-version) 61697))
+
++(defun is-wnn7-server ()
++ (= (wnn-server-version) 61698))
++
+ (defun add-wnn-dict (dfile hfile priority dmode hmode &optional dpaswd hpaswd)
+ ; (open-wnn-if-disconnected)
+ (if (null (wnn-server-dict-add