aboutsummaryrefslogtreecommitdiff
path: root/textproc/codesearch
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2020-01-17 19:00:02 +0000
committerDmitri Goutnik <dmgk@FreeBSD.org>2020-01-17 19:00:02 +0000
commit2e05b40e9f3bcd46fc586ce003956175602e12e6 (patch)
treeaa54b5fe8af7f742ad57253677797c09e462e3fe /textproc/codesearch
parent6c010e0fb38927590e0ee154875172213600c942 (diff)
downloadports-2e05b40e9f3bcd46fc586ce003956175602e12e6.tar.gz
ports-2e05b40e9f3bcd46fc586ce003956175602e12e6.zip
New port: textproc/codesearch
Code Search is a tool for indexing and then performing regular expression searches over large bodies of source code. It is a set of command-line programs written in Go. WWW: https://github.com/google/codesearch PR: 243273 Submitted by: eborisch+FreeBSD@gmail.com
Notes
Notes: svn path=/head/; revision=523350
Diffstat (limited to 'textproc/codesearch')
-rw-r--r--textproc/codesearch/Makefile28
-rw-r--r--textproc/codesearch/distinfo3
-rw-r--r--textproc/codesearch/pkg-descr5
3 files changed, 36 insertions, 0 deletions
diff --git a/textproc/codesearch/Makefile b/textproc/codesearch/Makefile
new file mode 100644
index 000000000000..b9c64a9bebfe
--- /dev/null
+++ b/textproc/codesearch/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= codesearch
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= textproc
+
+MAINTAINER= eborisch@gmail.com
+COMMENT= Fast (indexed) text search tool from Google
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+
+GO_PKGNAME= github.com/google/codesearch
+GO_TARGET= ./cmd/cgrep \
+ ./cmd/cindex \
+ ./cmd/csearch
+
+CONFLICTS_INSTALL= hs-cgrep
+
+PLIST_FILES= ${GO_TARGET:C/.\/cmd/bin/}
+
+.include <bsd.port.mk>
diff --git a/textproc/codesearch/distinfo b/textproc/codesearch/distinfo
new file mode 100644
index 000000000000..a1639aa72c77
--- /dev/null
+++ b/textproc/codesearch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578920429
+SHA256 (google-codesearch-v1.1.0_GH0.tar.gz) = b177021d1da1ddfc333fcbfc679eadd62c8677a6ae6119f25c4ad6b912bcdd7e
+SIZE (google-codesearch-v1.1.0_GH0.tar.gz) = 34076
diff --git a/textproc/codesearch/pkg-descr b/textproc/codesearch/pkg-descr
new file mode 100644
index 000000000000..988a9b7997f3
--- /dev/null
+++ b/textproc/codesearch/pkg-descr
@@ -0,0 +1,5 @@
+Code Search is a tool for indexing and then performing regular expression
+searches over large bodies of source code. It is a set of command-line programs
+written in Go.
+
+WWW: https://github.com/google/codesearch