aboutsummaryrefslogtreecommitdiff
path: root/textproc/colordiff/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-01-09 12:24:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-01-09 12:24:28 +0000
commitf533f226e5276f8f6689cee15312e1c78821ae09 (patch)
tree0b1a6aa3c2f66e9d34f7822a61b9e41348cad39e /textproc/colordiff/Makefile
parente11514bf08ae67497028a3576a7dde578725c0ad (diff)
downloadports-f533f226e5276f8f6689cee15312e1c78821ae09.tar.gz
ports-f533f226e5276f8f6689cee15312e1c78821ae09.zip
Notes
Diffstat (limited to 'textproc/colordiff/Makefile')
-rw-r--r--textproc/colordiff/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/textproc/colordiff/Makefile b/textproc/colordiff/Makefile
index 084364a06f5a..bbcf8245bb75 100644
--- a/textproc/colordiff/Makefile
+++ b/textproc/colordiff/Makefile
@@ -7,6 +7,7 @@
PORTNAME= colordiff
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,8 +19,6 @@ USE_PERL5= yes
USE_REINPLACE= yes
NO_BUILD= yes
-PLIST_DIRS= %%EXAMPLESDIR%%
-PLIST_FILES= bin/colordiff %%EXAMPLESDIR%%/colordiffrc
MAN1= colordiff.1
.include <bsd.port.pre.mk>
@@ -30,13 +29,17 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME}.pl
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local/bin/perl|${PERL}|; s|/etc|${PREFIX}/etc|' \
+ ${WRKSRC}/${PORTNAME}.pl \
+ ${WRKSRC}/${MAN1}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${PREFIX}/etc/colordiffrc.default
+.if !exists(${PREFIX}/etc/colordiffrc)
+ ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${PREFIX}/etc
+.endif
.include <bsd.port.post.mk>