aboutsummaryrefslogtreecommitdiff
path: root/textproc/colordiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 08:57:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 08:57:37 +0000
commit61ebd1776e3aee5a447d2d50b615c992349d1d6f (patch)
tree5a642a5ba2fc1ad06490c6b27a9c4b611eb25492 /textproc/colordiff
parenta5862b83094e3fa745bae0c83861afc4a3090436 (diff)
downloadports-61ebd1776e3aee5a447d2d50b615c992349d1d6f.tar.gz
ports-61ebd1776e3aee5a447d2d50b615c992349d1d6f.zip
Convert to use shebangfix USES flag.
Notes
Notes: svn path=/head/; revision=317591
Diffstat (limited to 'textproc/colordiff')
-rw-r--r--textproc/colordiff/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/textproc/colordiff/Makefile b/textproc/colordiff/Makefile
index fca1f4a8e872..4dac6b2d861c 100644
--- a/textproc/colordiff/Makefile
+++ b/textproc/colordiff/Makefile
@@ -11,16 +11,16 @@ COMMENT= Tool to colorize diff output
LICENSE= GPLv2
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= colordiff.pl
+
MAN1= colordiff.1
post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/local/bin/perl|${PERL}|; s|/etc|${PREFIX}/etc|' \
- ${WRKSRC}/${PORTNAME}.pl \
- ${WRKSRC}/${MAN1}
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${MAN1}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}