aboutsummaryrefslogtreecommitdiff
path: root/textproc/colordiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-07-06 18:06:20 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-07-06 18:06:20 +0000
commit7ae67a1ab62fbd26722c9ff20e77aeb27a48b207 (patch)
tree0514abfb04dbd3a2431f77d4941c9f71e50f73b1 /textproc/colordiff
parent1e2792154b9ca07a0f6d30a2dc27c095eeef4c06 (diff)
downloadports-7ae67a1ab62fbd26722c9ff20e77aeb27a48b207.tar.gz
ports-7ae67a1ab62fbd26722c9ff20e77aeb27a48b207.zip
Add colordiff 1.0.5, a tool to colorize diff output.
Colordiff is a wrapper for diff and produces the same output as diff but with coloured syntax highlighting at the command line to improve readability. The output is similar to how a diff-generated patch might appear in Vim or Emacs with the appropriate syntax highlighting options enabled. PR: ports/83062 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=138616
Diffstat (limited to 'textproc/colordiff')
-rw-r--r--textproc/colordiff/Makefile41
-rw-r--r--textproc/colordiff/distinfo2
-rw-r--r--textproc/colordiff/pkg-descr10
3 files changed, 53 insertions, 0 deletions
diff --git a/textproc/colordiff/Makefile b/textproc/colordiff/Makefile
new file mode 100644
index 000000000000..07ece3e68dc4
--- /dev/null
+++ b/textproc/colordiff/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: colordiff
+# Date created: 6 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= colordiff
+PORTVERSION= 1.0.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A tool to colorize diff output
+
+USE_PERL5= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+PLIST_DIRS= %%EXAMPLESDIR%%
+PLIST_FILES= bin/colordiff %%EXAMPLESDIR%%/colordiffrc
+MAN1= colordiff.1
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/bin/perl|${PERL}|' \
+ ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${PREFIX}/man/man1
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/colordiffrc ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>
diff --git a/textproc/colordiff/distinfo b/textproc/colordiff/distinfo
new file mode 100644
index 000000000000..de50e488e3c0
--- /dev/null
+++ b/textproc/colordiff/distinfo
@@ -0,0 +1,2 @@
+MD5 (colordiff-1.0.5.tar.gz) = b8ef81a80dfa8a4c001915d03a73f7d1
+SIZE (colordiff-1.0.5.tar.gz) = 14243
diff --git a/textproc/colordiff/pkg-descr b/textproc/colordiff/pkg-descr
new file mode 100644
index 000000000000..a05a770bdc10
--- /dev/null
+++ b/textproc/colordiff/pkg-descr
@@ -0,0 +1,10 @@
+Colordiff is a wrapper for diff and produces the same output as diff but with
+coloured syntax highlighting at the command line to improve readability.
+
+The output is similar to how a diff-generated patch might appear in Vim or Emacs
+with the appropriate syntax highlighting options enabled.
+
+WWW: http://colordiff.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch