aboutsummaryrefslogtreecommitdiff
path: root/textproc/confget
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-23 05:20:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-23 05:20:21 +0000
commit19d4cf4565566adefc569444fa119bf2a9e950d0 (patch)
tree73ceba0c36e1a3ebf0fec78b3c2ebc77b114af49 /textproc/confget
parent1ee826a33e1d32d4e16a2df38d86a346029c76d4 (diff)
downloadports-19d4cf4565566adefc569444fa119bf2a9e950d0.tar.gz
ports-19d4cf4565566adefc569444fa119bf2a9e950d0.zip
- Convert to new options framework
Notes
Notes: svn path=/head/; revision=299805
Diffstat (limited to 'textproc/confget')
-rw-r--r--textproc/confget/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/textproc/confget/Makefile b/textproc/confget/Makefile
index ed1d0a672472..017810fb8eed 100644
--- a/textproc/confget/Makefile
+++ b/textproc/confget/Makefile
@@ -14,7 +14,8 @@ MASTER_SITES= http://devel.ringlet.net/textproc/confget/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Read variables from INI-style configuration files
-OPTIONS= PCRE "Regular expression support" on
+OPTIONS_DEFINE= EXAMPLES PCRE
+OPTIONS_DEFAULT=PCRE
MAKE_ENV= CFLAGS_CONF=-DHAVE_FGETLN
USE_GMAKE= yes
@@ -24,24 +25,24 @@ MANCOMPRESSED= yes
PLIST_FILES= bin/confget
PORTEXAMPLES= t1.ini t2.ini
-.if !defined(NOPORTEXAMPLES)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXAMPLES}
MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
.endif
-.include <bsd.port.options.mk>
-
-.if !defined(WITHOUT_PCRE)
+.if ${PORT_OPTIONS:MPCRE}
LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
.else
MAKE_ENV+= PCRE_CFLAGS="" PCRE_LIBS=""
.endif
post-patch:
-.if defined(NOPORTEXAMPLES)
+.if empty(${PORT_OPTIONS:MEXAMPLES})
@${REINPLACE_CMD} -e '/^install:/ s| install-examples||' ${WRKSRC}/Makefile
.endif
regression-test test: build
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
+ cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
.include <bsd.port.mk>