aboutsummaryrefslogtreecommitdiff
path: root/textproc/cpp-peglib
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-12 04:42:43 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-12 04:44:44 +0000
commitaa7a94ee922ab4165f0f128d2e3d0a25e3d8c469 (patch)
tree654a2572013bb95204e5f5e284d78fb01b65353c /textproc/cpp-peglib
parentd82e9b7e7b21ff9caa50690017e70fe2e8442131 (diff)
downloadports-aa7a94ee922ab4165f0f128d2e3d0a25e3d8c469.tar.gz
ports-aa7a94ee922ab4165f0f128d2e3d0a25e3d8c469.zip
textproc/cpp-peglib: Update 1.5.0 -> 1.6.0
Reported by: portscout
Diffstat (limited to 'textproc/cpp-peglib')
-rw-r--r--textproc/cpp-peglib/Makefile5
-rw-r--r--textproc/cpp-peglib/distinfo6
-rw-r--r--textproc/cpp-peglib/files/patch-CMakeLists.txt19
3 files changed, 12 insertions, 18 deletions
diff --git a/textproc/cpp-peglib/Makefile b/textproc/cpp-peglib/Makefile
index e23ea2f6c0f4..bd0fb7858fa1 100644
--- a/textproc/cpp-peglib/Makefile
+++ b/textproc/cpp-peglib/Makefile
@@ -1,6 +1,6 @@
PORTNAME= cpp-peglib
DISTVERSIONPREFIX= v
-DISTVERSION= 1.5.0
+DISTVERSION= 1.6.0
CATEGORIES= textproc devel
MAINTAINER= yuri@FreeBSD.org
@@ -14,7 +14,8 @@ USES= cmake:testing compiler:c++17-lang
USE_GITHUB= yes
GH_ACCOUNT= yhirose
-CMAKE_TESTING_ON= FREEBSD_BUILD_TESTS
+CMAKE_OFF= PEGLIB_BUILD_TESTS
+CMAKE_TESTING_ON= PEGLIB_BUILD_TESTS
NO_ARCH= yes
diff --git a/textproc/cpp-peglib/distinfo b/textproc/cpp-peglib/distinfo
index 02b32ebb04ef..85adb9570bf1 100644
--- a/textproc/cpp-peglib/distinfo
+++ b/textproc/cpp-peglib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1655480833
-SHA256 (yhirose-cpp-peglib-v1.5.0_GH0.tar.gz) = 45a02b749556af6ab0abf78c4c1d1afe02f17705b1c51f5820e957616f453b33
-SIZE (yhirose-cpp-peglib-v1.5.0_GH0.tar.gz) = 206343
+TIMESTAMP = 1657599663
+SHA256 (yhirose-cpp-peglib-v1.6.0_GH0.tar.gz) = 2b09d711fd02bad24089bc5a6f51ef4c307d86e0adb6f9938e0549a12c102ac4
+SIZE (yhirose-cpp-peglib-v1.6.0_GH0.tar.gz) = 214273
diff --git a/textproc/cpp-peglib/files/patch-CMakeLists.txt b/textproc/cpp-peglib/files/patch-CMakeLists.txt
index c7814b494b41..dcc97fc9d238 100644
--- a/textproc/cpp-peglib/files/patch-CMakeLists.txt
+++ b/textproc/cpp-peglib/files/patch-CMakeLists.txt
@@ -1,19 +1,12 @@
---- CMakeLists.txt.orig 2022-01-03 16:23:41 UTC
+--- CMakeLists.txt.orig 2022-07-09 00:35:05 UTC
+++ CMakeLists.txt
-@@ -17,10 +17,16 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
- set(add_link_deps Threads::Threads)
- endif()
+@@ -21,7 +21,9 @@ endif()
-+if (FREEBSD_BUILD_EXAMPLES)
- add_subdirectory(example)
-+endif()
-+if (FREEBSD_BUILD_LINT)
add_subdirectory(lint)
-+endif()
-+if (FREEBSD_BUILD_TESTS)
- add_subdirectory(test)
- enable_testing()
++if (FREEBSD_BUILD_EXAMPLES)
+ add_subdirectory(example)
+endif()
+ # add_subdirectory(cymbol)
- install(FILES peglib.h DESTINATION include)
+ if (${PEGLIB_BUILD_TESTS})