aboutsummaryrefslogtreecommitdiff
path: root/textproc/crunch
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-22 10:54:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-22 10:54:59 +0000
commitf0b39e9e4f0dab3f050f5ee2018c84fa0749aaaa (patch)
treebe76196dc29edee96920b341469a1d59f2b612bf /textproc/crunch
parentc4fc609c5dbd33996d5dd0e4e4f41d622de209c5 (diff)
downloadports-f0b39e9e4f0dab3f050f5ee2018c84fa0749aaaa.tar.gz
ports-f0b39e9e4f0dab3f050f5ee2018c84fa0749aaaa.zip
Crunch is a wordlist generator where you can specify a standard character
set or a character set you specify. crunch can generate all possible combinations and permutations. Features: - crunch generates wordlists in both combination and permutation ways - it can breakup output by number of lines or file size - now has resume support - pattern now supports number and symbols - pattern now supports upper and lower case characters separately - adds a status report when generating multiple files - new -l option for literal support of @,%^ - new -d option to limit duplicate characters see man file for details - now has unicode support WWW: https://crunch-wordlist.sourceforge.io/ PR: 217036 Submitted by: vidar@karlsen.tech
Notes
Notes: svn path=/head/; revision=434576
Diffstat (limited to 'textproc/crunch')
-rw-r--r--textproc/crunch/Makefile25
-rw-r--r--textproc/crunch/distinfo3
-rw-r--r--textproc/crunch/files/patch-Makefile24
-rw-r--r--textproc/crunch/pkg-descr17
4 files changed, 69 insertions, 0 deletions
diff --git a/textproc/crunch/Makefile b/textproc/crunch/Makefile
new file mode 100644
index 000000000000..2eaefabf7ee3
--- /dev/null
+++ b/textproc/crunch/Makefile
@@ -0,0 +1,25 @@
+# Created by: Vidar Karlsen <vidar@karlsen.tech>
+# $FreeBSD$
+
+PORTNAME= crunch
+PORTVERSION= 3.6
+CATEGORIES= textproc
+MASTER_SITES= SF/${PORTNAME}-wordlist/${PORTNAME}-wordlist
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= Charset-based wordlist generator
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= gmake tar:tgz
+
+PLIST_FILES= bin/crunch man/man1/crunch.1.gz %%DATADIR%%/charset.lst
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/charset.lst ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/crunch/distinfo b/textproc/crunch/distinfo
new file mode 100644
index 000000000000..87b2e6ce02a2
--- /dev/null
+++ b/textproc/crunch/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486909070
+SHA256 (crunch-3.6.tgz) = 6a8f6c3c7410cc1930e6854d1dadc6691bfef138760509b33722ff2de133fe55
+SIZE (crunch-3.6.tgz) = 38635
diff --git a/textproc/crunch/files/patch-Makefile b/textproc/crunch/files/patch-Makefile
new file mode 100644
index 000000000000..54a2f5a78334
--- /dev/null
+++ b/textproc/crunch/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.orig 2014-05-03 17:04:11 UTC
++++ Makefile
+@@ -38,15 +38,18 @@ DOCDIR = $(PREFIX)/share/doc/$(PACKA
+ MANDIR = $(PREFIX)/share/man/man1
+
+ INSTALL = sudo $(shell which install)
+-CC = $(shell which gcc)
++CC ?= $(shell which gcc)
+ LIBFLAGS = -lm
+ THREADFLAGS = -pthread
+ OPTFLAGS = -g -o0
+ LINTFLAGS = -Wall -pedantic
+ CFLAGS_STD = $(THREADFLAGS) $(LINTFLAGS) -std=c99
+ VCFLAGS = $(CFLAGS_STD) $(OPTFLAGS)
+-LFS = $(shell getconf POSIX_V6_ILP32_OFFBIG_CFLAGS)
+-
++ifeq ($(UNAME_LOOKUP),!FreeBSD)
++ LFS = $(shell getconf POSIX_V6_ILP32_OFFBIG_CFLAGS)
++else
++ INSTALL_OPTIONS = -g wheel -o root
++endif
+ ifeq ($(UNAME_LOOKUP),Darwin)
+ #Darwin = OS X, and os x does not use root root as stated in email
+ INSTALL_OPTIONS = -g wheel -o root
diff --git a/textproc/crunch/pkg-descr b/textproc/crunch/pkg-descr
new file mode 100644
index 000000000000..a813532b0300
--- /dev/null
+++ b/textproc/crunch/pkg-descr
@@ -0,0 +1,17 @@
+Crunch is a wordlist generator where you can specify a standard character
+set or a character set you specify. crunch can generate all possible
+combinations and permutations.
+
+Features:
+
+- crunch generates wordlists in both combination and permutation ways
+- it can breakup output by number of lines or file size
+- now has resume support
+- pattern now supports number and symbols
+- pattern now supports upper and lower case characters separately
+- adds a status report when generating multiple files
+- new -l option for literal support of @,%^
+- new -d option to limit duplicate characters see man file for details
+- now has unicode support
+
+WWW: https://crunch-wordlist.sourceforge.io/