aboutsummaryrefslogtreecommitdiff
path: root/textproc/csvdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-12 05:53:15 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-12 05:53:15 +0000
commit15312842613052038be8e4f7b02080a3e329f22e (patch)
tree52ccbfc1b3e49c227aa4f4f9bc4ccf7c7b886e25 /textproc/csvdiff
parent07ac479bee5dfe11dd294776f02855fecbb6b485 (diff)
downloadports-15312842613052038be8e4f7b02080a3e329f22e.tar.gz
ports-15312842613052038be8e4f7b02080a3e329f22e.zip
Add csvdiff 1.3, compare/diff two (comma) seperated files with each
other. PR: ports/100097 Submitted by: chinsan <chinsan.tw at gmail.com>
Notes
Notes: svn path=/head/; revision=167569
Diffstat (limited to 'textproc/csvdiff')
-rw-r--r--textproc/csvdiff/Makefile36
-rw-r--r--textproc/csvdiff/distinfo3
-rw-r--r--textproc/csvdiff/pkg-descr9
3 files changed, 48 insertions, 0 deletions
diff --git a/textproc/csvdiff/Makefile b/textproc/csvdiff/Makefile
new file mode 100644
index 000000000000..7c393c08f770
--- /dev/null
+++ b/textproc/csvdiff/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: csvdiff
+# Date created: 2006/07/12
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= csvdiff
+PORTVERSION= 1.3
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S,.,-,g}
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Compare/diff two (comma) seperated files with each other
+
+NO_BUILD= yes
+USE_PERL5= yes
+PLIST_FILES= bin/csvdiff
+WRKSRC= ${WRKDIR}
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGES README TODO
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/csvdiff/distinfo b/textproc/csvdiff/distinfo
new file mode 100644
index 000000000000..6d5dd89bcff6
--- /dev/null
+++ b/textproc/csvdiff/distinfo
@@ -0,0 +1,3 @@
+MD5 (csvdiff_1-3.tar.gz) = ffcafdf67c0526fe56fe1c2aa96475c8
+SHA256 (csvdiff_1-3.tar.gz) = 60b2680c748763ea19f5b0ab710d86cb44a33433be5fe0b117c3a15a0962ac91
+SIZE (csvdiff_1-3.tar.gz) = 14739
diff --git a/textproc/csvdiff/pkg-descr b/textproc/csvdiff/pkg-descr
new file mode 100644
index 000000000000..9f9ba51174f5
--- /dev/null
+++ b/textproc/csvdiff/pkg-descr
@@ -0,0 +1,9 @@
+csvdiff is a Perl script to diff/compare two csv files with the possibility
+to select the separator.
+
+Differences will be shown like:
+"Column XYZ in record 999" is different.
+After this, the actual and the expected result for this
+column will be shown.
+
+WWW: http://csvdiff.sourceforge.net/