aboutsummaryrefslogtreecommitdiff
path: root/textproc/diffmark
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-19 16:06:34 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-19 16:06:34 +0000
commite55a37ca1d08b34ee75f72a776788d0fc8732b85 (patch)
tree2192fa71ae2a12451629f30e1411061b4cdf0734 /textproc/diffmark
parent90e7b3e6e0f8f582e6258e8a0f025583645982b0 (diff)
downloadports-e55a37ca1d08b34ee75f72a776788d0fc8732b85.tar.gz
ports-e55a37ca1d08b34ee75f72a776788d0fc8732b85.zip
- Fix build with clang
- Update MASTER_SITES - Support staging PR: ports/184819 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=336933
Diffstat (limited to 'textproc/diffmark')
-rw-r--r--textproc/diffmark/Makefile21
-rw-r--r--textproc/diffmark/files/patch-lib__diff.hh11
2 files changed, 24 insertions, 8 deletions
diff --git a/textproc/diffmark/Makefile b/textproc/diffmark/Makefile
index 35a9232b8fe9..9cb3fd76c0d4 100644
--- a/textproc/diffmark/Makefile
+++ b/textproc/diffmark/Makefile
@@ -4,20 +4,25 @@
PORTNAME= diffmark
PORTVERSION= 0.10
CATEGORIES= textproc
-MASTER_SITES= http://www.mangrove.cz/diffmark/
+MASTER_SITES= http://www.mangrove.cz/diffmark/ \
+ http://penguin.cz/~vbarta/diffmark/
MAINTAINER= ports@FreeBSD.org
COMMENT= XML diff and merge package
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-
USES= pkgconfig
-USE_LDCONFIG= YES
-GNU_CONFIGURE= YES
-CONFIGURE_ARGS= --with-libxml2-incldir=${LOCALBASE}/include/libxml2
+USE_GNOME= libxml2
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lstdc++||' ${WRKSRC}/lib/Makefile.in
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libdiffmark.so.2
+
.include <bsd.port.mk>
diff --git a/textproc/diffmark/files/patch-lib__diff.hh b/textproc/diffmark/files/patch-lib__diff.hh
new file mode 100644
index 000000000000..f9816aea47e9
--- /dev/null
+++ b/textproc/diffmark/files/patch-lib__diff.hh
@@ -0,0 +1,11 @@
+--- lib/diff.hh.orig 2013-12-07 05:09:56.000000000 +0900
++++ lib/diff.hh 2013-12-07 05:10:09.000000000 +0900
+@@ -13,7 +13,7 @@
+ template<>
+ struct less<xmlNodePtr>
+ {
+- bool operator()(xmlNodePtr m, xmlNodePtr n)
++ bool operator()(xmlNodePtr m, xmlNodePtr n) const
+ {
+ return compare(m, n, true) < 0;
+ }