aboutsummaryrefslogtreecommitdiff
path: root/textproc/discount
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-03 18:07:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-03 18:07:43 +0000
commit05282b3844d465b32f5513525278f24eb13b5293 (patch)
tree4e06ebc902447ed557605f3821b9aa95036ba8ed /textproc/discount
parent5c8214fbf271b3c47982fb61322e00905aad6cdf (diff)
downloadports-05282b3844d465b32f5513525278f24eb13b5293.tar.gz
ports-05282b3844d465b32f5513525278f24eb13b5293.zip
Update to 2.2.7
- Fix LICENSE - Take maintainership Changes: https://github.com/Orc/discount/commits/main
Notes
Notes: svn path=/head/; revision=567122
Diffstat (limited to 'textproc/discount')
-rw-r--r--textproc/discount/Makefile44
-rw-r--r--textproc/discount/distinfo6
-rw-r--r--textproc/discount/files/patch-Makefile.in12
-rw-r--r--textproc/discount/pkg-plist6
4 files changed, 33 insertions, 35 deletions
diff --git a/textproc/discount/Makefile b/textproc/discount/Makefile
index dfbc85399d41..befe33b4a599 100644
--- a/textproc/discount/Makefile
+++ b/textproc/discount/Makefile
@@ -2,48 +2,40 @@
# $FreeBSD$
PORTNAME= discount
+PORTVERSION= 2.2.7
DISTVERSIONPREFIX= v
-DISTVERSION= 2.2.6
CATEGORIES= textproc devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C implementation of the Markdown markup language
-LICENSE= BSD2CLAUSE
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USES= pkgconfig
+
USE_GITHUB= yes
GH_ACCOUNT= Orc
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= configure.sh
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --mandir=${MANPREFIX}/man
-
-INSTALL_TARGET= install install.man
-
CFLAGS+= -fPIC
-
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MANPREFIX}/man
+CONFIGURE_SCRIPT= configure.sh
+HAS_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes # libmarkdown is used before it is built
+INSTALL_TARGET= install install.man
+TEST_TARGET= test
-OPTIONS_DEFINE= EXTRA TAB8 SAMPLES
-OPTIONS_DEFAULT= EXTRA TAB8
-
-EXTRA_DESC= Enable all extra features
-TAB8_DESC= Use a tabstop of 8 (default is 4)
-SAMPLES_DESC= Install sample programs
-
-EXTRA_CONFIGURE_ON= --with-dl=both --with-fenced-code --with-github-tags \
- --with-id-anchor
+CONFLICTS_INSTALL= markdown
-TAB8_CONFIGURE_ON= --with-tabstops=8
+OPTIONS_DEFINE= EXTRA SAMPLES TAB8
+OPTIONS_DEFAULT=EXTRA TAB8
+OPTIONS_SUB= yes
+EXTRA_DESC= Enable all extra features
+SAMPLES_DESC= Install sample programs
+TAB8_DESC= Use a tabstop of 8 (default is 4)
+EXTRA_CONFIGURE_ON= --with-dl=both --with-fenced-code --with-github-tags --with-id-anchor
SAMPLES_INSTALL_TARGET= install install.samples
-SAMPLES_PLIST_FILES= bin/makepage bin/mkd2html bin/theme \
- man/man1/makepage.1.gz man/man1/mkd2html.1.gz \
- man/man1/theme.1.gz
-
-CONFLICTS_INSTALL= markdown
+TAB8_CONFIGURE_ON= --with-tabstops=8
.include <bsd.port.mk>
diff --git a/textproc/discount/distinfo b/textproc/discount/distinfo
index 63644d140d99..a3f34521b99a 100644
--- a/textproc/discount/distinfo
+++ b/textproc/discount/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584899335
-SHA256 (Orc-discount-v2.2.6_GH0.tar.gz) = 0beb98a66a6e38ed125e2d0a161ff6b461f6a38538bb72498766f376c94a0ad3
-SIZE (Orc-discount-v2.2.6_GH0.tar.gz) = 128790
+TIMESTAMP = 1613738747
+SHA256 (Orc-discount-v2.2.7_GH0.tar.gz) = 72c1325ddfc40871d6810f1e272cf2d45b361f26357eb38f170fd04d737bb9f2
+SIZE (Orc-discount-v2.2.7_GH0.tar.gz) = 128805
diff --git a/textproc/discount/files/patch-Makefile.in b/textproc/discount/files/patch-Makefile.in
index 1715e084ec16..5e16e6db4d3b 100644
--- a/textproc/discount/files/patch-Makefile.in
+++ b/textproc/discount/files/patch-Makefile.in
@@ -1,8 +1,8 @@
---- Makefile.in.orig 2015-01-18 16:49:13 UTC
+--- Makefile.in.orig 2020-08-24 05:45:49 UTC
+++ Makefile.in
-@@ -39,13 +39,13 @@ install.man:
- @INSTALL_DIR@ $(DESTDIR)$(MANDIR)/man3
- @INSTALL_DATA@ $(MAN3PAGES) $(DESTDIR)$(MANDIR)/man3
+@@ -57,13 +57,13 @@ install.man:
+ $(INSTALL_DIR) $(DESTDIR)$(MANDIR)/man3
+ $(INSTALL_DATA) $(MAN3PAGES) $(DESTDIR)$(MANDIR)/man3
for x in mkd_line mkd_generateline; do \
- ( echo '.\"' ; echo ".so man3/mkd-line.3" ) > $(DESTDIR)$(MANDIR)/man3/$$x.3;\
+ ln -sf mkd-line.3 $(DESTDIR)$(MANDIR)/man3/$$x.3; \
@@ -15,5 +15,5 @@
- ( echo '.\"' ; echo ".so man3/mkd-functions.3" ) > $(DESTDIR)$(MANDIR)/man3/$$x.3; \
+ ln -sf mkd-functions.3 $(DESTDIR)$(MANDIR)/man3/$$x.3; \
done
- @INSTALL_DIR@ $(DESTDIR)$(MANDIR)/man7
- @INSTALL_DATA@ markdown.7 mkd-extensions.7 $(DESTDIR)$(MANDIR)/man7
+ $(INSTALL_DIR) $(DESTDIR)$(MANDIR)/man7
+ $(INSTALL_DATA) markdown.7 mkd-extensions.7 $(DESTDIR)$(MANDIR)/man7
diff --git a/textproc/discount/pkg-plist b/textproc/discount/pkg-plist
index ff05a45ec209..ba54b6ef278a 100644
--- a/textproc/discount/pkg-plist
+++ b/textproc/discount/pkg-plist
@@ -1,8 +1,14 @@
+%%SAMPLES%%bin/makepage
bin/markdown
+%%SAMPLES%%bin/mkd2html
+%%SAMPLES%%bin/theme
include/mkdio.h
lib/libmarkdown.a
libdata/pkgconfig/libmarkdown.pc
+%%SAMPLES%%man/man1/makepage.1.gz
man/man1/markdown.1.gz
+%%SAMPLES%%man/man1/mkd2html.1.gz
+%%SAMPLES%%man/man1/theme.1.gz
man/man3/markdown.3.gz
man/man3/mkd-callbacks.3.gz
man/man3/mkd-functions.3.gz