aboutsummaryrefslogtreecommitdiff
path: root/textproc/discount
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-26 23:46:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-26 23:46:43 +0000
commita26041c27f016aca36ee9b0551c2170f92ef9285 (patch)
treeb918d576fa13a57cc8bd1a85c8422180211a1fcd /textproc/discount
parentd84a5e942fb0cf96c5985e691f086e32ed10aeb3 (diff)
downloadports-a26041c27f016aca36ee9b0551c2170f92ef9285.tar.gz
ports-a26041c27f016aca36ee9b0551c2170f92ef9285.zip
This is an implementation of John Gruber's Markdown text to html language.
There's not much here that differentiates it from any of the existing Markdown implementations except that it's written in C instead of one of the vast flock of scripting languages that are fighting it out for the Perl crown. Markdown provides a library that gives you formatting functions suitable for marking down entire documents or lines of text, a command-line program that you can use to mark down documents interactively or from a script, and a tiny (1 program so far) suite of example programs that show how to fully utilize the markdown library. WWW: http://www.pell.portland.or.us/~orc/Code/markdown/ PR: ports/134004 Submitted by: Julien Laffaye <kimelto at gmail.com>
Notes
Notes: svn path=/head/; revision=232811
Diffstat (limited to 'textproc/discount')
-rw-r--r--textproc/discount/Makefile57
-rw-r--r--textproc/discount/distinfo3
-rw-r--r--textproc/discount/pkg-descr15
3 files changed, 75 insertions, 0 deletions
diff --git a/textproc/discount/Makefile b/textproc/discount/Makefile
new file mode 100644
index 000000000000..3acd57378be7
--- /dev/null
+++ b/textproc/discount/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: discount
+# Date created: 2009-04-22
+# Whom: Julien Laffaye <kimelto@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= discount
+PORTVERSION= 1.3.5
+CATEGORIES= textproc devel
+MASTER_SITES= http://www.pell.portland.or.us/~orc/Code/markdown/
+
+MAINTAINER= kimelto@gmail.com
+COMMENT= A C implementation of the Markdown markup language
+
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT=configure.sh
+CONFIGURE_ARGS= --prefix=${PREFIX}
+INSTALL_TARGET= install install.man
+
+MAN1= markdown.1
+MAN3= mkd-functions.3 \
+ markdown.3 \
+ mkd_text.3 \
+ mkd_in.3 \
+ mkd_string.3 \
+ mkd_compile.3 \
+ mkd_style.3 \
+ mkd_generatehtml.3 \
+ mkd_cleanup.3 \
+ mkd_doc_title.3 \
+ mkd_doc_author.3 \
+ mkd_doc_date.3
+MAN7= markdown.7 \
+ mkd-extensions.7
+PLIST_FILES= bin/markdown \
+ lib/libmarkdown.a \
+ include/mkdio.h
+
+OPTIONS= EXTRA "Enable all extra features" on \
+ TAB8 "Use a tabstop of 8 (default is 4)" on
+.include <bsd.port.pre.mk>
+
+.ifdef (WITH_EXTRA)
+CONFIGURE_ARGS+=--enable-dl-tag \
+ --enable-pandoc-header \
+ --enable-superscript \
+ --relaxed-emphasis \
+ --enable-div \
+ --enable-alpha-list
+.endif
+
+.ifdef (WITH_TAB8)
+CONFIGURE_ARGS+=--with-tabstops=8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/discount/distinfo b/textproc/discount/distinfo
new file mode 100644
index 000000000000..5be08ed79a4b
--- /dev/null
+++ b/textproc/discount/distinfo
@@ -0,0 +1,3 @@
+MD5 (discount-1.3.5.tar.gz) = 2036c43368e3c5114206102b9ec91c50
+SHA256 (discount-1.3.5.tar.gz) = 3bac9a19ce8126b72407e34b428a6b9ee94019076dd6db03940a2c5745550656
+SIZE (discount-1.3.5.tar.gz) = 70287
diff --git a/textproc/discount/pkg-descr b/textproc/discount/pkg-descr
new file mode 100644
index 000000000000..c7193a5c2727
--- /dev/null
+++ b/textproc/discount/pkg-descr
@@ -0,0 +1,15 @@
+This is an implementation of John Gruber's Markdown text to html language.
+There's not much here that differentiates it from any of the existing Markdown
+implementations except that it's written in C instead of one of the vast flock
+of scripting languages that are fighting it out for the Perl crown.
+
+Markdown provides a library that gives you formatting functions suitable for
+marking down entire documents or lines of text, a command-line program that you
+can use to mark down documents interactively or from a script,
+and a tiny (1 program so far) suite of example programs that show how to fully
+utilize the markdown library.
+
+It also does, by default, various smartypants-style substitutions.
+
+WWW: http://www.pell.portland.or.us/~orc/Code/markdown/
+LICENSE: BSDL