aboutsummaryrefslogtreecommitdiff
path: root/textproc/docproj
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-12-31 12:54:55 +0000
committerRene Ladan <rene@FreeBSD.org>2020-12-31 12:54:55 +0000
commitddede36f714bbd3c6e00561fee40b575d95b01b5 (patch)
tree459e28b77194c7610416cc1a68474149d98b6d1b /textproc/docproj
parent45e5de12ae2201d7e2d92a4bdb4009cee80273d4 (diff)
downloadports-ddede36f714bbd3c6e00561fee40b575d95b01b5.tar.gz
ports-ddede36f714bbd3c6e00561fee40b575d95b01b5.zip
Revert accidental unrelated patch from previous commit.
More pointy hats for me :(
Notes
Notes: svn path=/head/; revision=559733
Diffstat (limited to 'textproc/docproj')
-rw-r--r--textproc/docproj/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 1f7ca0a4c94e..3a853a232be9 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= docproj
-PORTVERSION= 2.1
+PORTVERSION= 2.0
+PORTREVISION= 14
CATEGORIES= textproc
MAINTAINER= doceng@FreeBSD.org
@@ -25,16 +26,19 @@ RUN_DEPENDS= ${LOCALBASE}/share/xml/dtd/xhtml/xhtml.soc:textproc/xhtml \
USES= ghostscript:run metaport perl5
USE_PERL5= run
-OPTIONS_DEFINE= CJK DBLATEX FOP GIT GROFF IGOR JING TRANSLATOR
-OPTIONS_DEFAULT= CJK GIT GROFF IGOR TRANSLATOR
+OPTIONS_DEFINE= CJK DBLATEX FOP GROFF IGOR JING SVN TRANSLATOR
+OPTIONS_DEFAULT= CJK GROFF IGOR TRANSLATOR
+.if !exists(/usr/bin/svnlite) && !exists(/usr/bin/svn)
+OPTIONS_DEFAULT+= SVN
+.endif
CJK_DESC= CJK support
DBLATEX_DESC= dblatex PDF renderer (experimental, requires TeXLive)
FOP_DESC= FOP PDF renderer (requires Java)
-GIT_DESC= Git support from ports
GROFF_DESC= Groff support from ports
IGOR_DESC= Igor automated proofreader for documentation
JING_DESC= Jing for advanced RELAX NG validation
+SVN_DESC= Subversion support from ports
TRANSLATOR_DESC= Tools for translators
CJK_RUN_DEPENDS= html2text:textproc/html2text
@@ -42,10 +46,10 @@ DBLATEX_RUN_DEPENDS= dblatex:textproc/dblatex
DBLATEX_USE= TEX=xetex
FOP_RUN_DEPENDS= ${_FONTS} \
fop:textproc/fop
-GIT_RUN_DEPENDS= git:devel/git
GROFF_USES= groff:run
IGOR_RUN_DEPENDS= igor:textproc/igor
JING_RUN_DEPENDS= jing:textproc/jing
+SVN_RUN_DEPENDS= ${LOCALBASE}/bin/svn:devel/subversion
TRANSLATOR_RUN_DEPENDS= itstool:textproc/itstool \
msgcat:devel/gettext-tools
@@ -61,7 +65,7 @@ _FONTS_CJK= ${LOCALBASE}/share/fonts/ipa/ipam.otf:japanese/font-ipa \
.if ${PORT_OPTIONS:MFOP} || ${PORT_OPTIONS:MDBLATEX}
ONLY_FOR_ARCHS= amd64 i386
-CJK_RUN_DEPENDS+= ${_FONTS_CJK}
+CJK_RUN_DEPENDS= ${_FONTS_CJK}
.endif
# generate MINIMALDOCPORTS for src/release/Makefile.inc.docports.