aboutsummaryrefslogtreecommitdiff
path: root/textproc/dsssl-docbook-modular/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-21 01:49:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-21 01:49:52 +0000
commit9a89b072ebf04cbb7dbac45f15ce22b8b82bc674 (patch)
tree1c089a5ab06c61242f30a9cb70c920ebf731303c /textproc/dsssl-docbook-modular/Makefile
parent9f8c68916cfd0cb46e2c5362d2f3fadaac82c197 (diff)
downloadports-9a89b072ebf04cbb7dbac45f15ce22b8b82bc674.tar.gz
ports-9a89b072ebf04cbb7dbac45f15ce22b8b82bc674.zip
Notes
Diffstat (limited to 'textproc/dsssl-docbook-modular/Makefile')
-rw-r--r--textproc/dsssl-docbook-modular/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/textproc/dsssl-docbook-modular/Makefile b/textproc/dsssl-docbook-modular/Makefile
index bfd04ba8b8d7..6e5b1336c490 100644
--- a/textproc/dsssl-docbook-modular/Makefile
+++ b/textproc/dsssl-docbook-modular/Makefile
@@ -29,20 +29,16 @@ CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
PLIST_SUB= XMLCATMGR=${XMLCATMGR} DTDDIR=${RELDIR} \
CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
-NO_STAGE= yes
do-build:
${RM} -Rf ${WRKSRC}/docsrc
pre-su-install:
- ${MKDIR} ${INSTDIR}
+ ${MKDIR} ${STAGEDIR}${INSTDIR}
${FIND} ${WRKDIR} -name '*.orig' -exec ${RM} {} \;
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${WRKSRC}
do-install:
- @cd ${WRKSRC} && ${TAR} cpf - . | (cd ${INSTDIR} && ${TAR} xpf -)
+ @cd ${WRKSRC} && ${TAR} cpf - . | (cd ${STAGEDIR}${INSTDIR} && ${TAR} xpf -)
-post-install:
- -${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} add CATALOG ${RELDIR}/catalog
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>