aboutsummaryrefslogtreecommitdiff
path: root/textproc/dtdparse
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2002-02-06 07:37:00 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2002-02-06 07:37:00 +0000
commita327f891f881c8beb77f18947175871a06f7543f (patch)
tree44082181e31eed947e0f2cfc746ee1880816fe68 /textproc/dtdparse
parent23102c9438ed1d0ca3e8a1013e60ee22081cbccc (diff)
downloadports-a327f891f881c8beb77f18947175871a06f7543f.tar.gz
ports-a327f891f881c8beb77f18947175871a06f7543f.zip
Add dtdparse 2.0.b6,
parse a DTD and produce an XML document that represents it. PR: ports/34400 Submitted by: Kimura Fuyuki <fuyuki@mj.0038.net>
Notes
Notes: svn path=/head/; revision=54254
Diffstat (limited to 'textproc/dtdparse')
-rw-r--r--textproc/dtdparse/Makefile60
-rw-r--r--textproc/dtdparse/distinfo1
-rw-r--r--textproc/dtdparse/files/patch-aa20
-rw-r--r--textproc/dtdparse/pkg-comment1
-rw-r--r--textproc/dtdparse/pkg-descr8
-rw-r--r--textproc/dtdparse/pkg-plist30
6 files changed, 120 insertions, 0 deletions
diff --git a/textproc/dtdparse/Makefile b/textproc/dtdparse/Makefile
new file mode 100644
index 000000000000..5afc80539a7d
--- /dev/null
+++ b/textproc/dtdparse/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: dtdparse
+# Date created: 29 January 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtdparse
+PORTVERSION= 2.0.b6
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dtdparse
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/beta/}
+
+MAINTAINER= fuyuki@mj.0038.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/DelimMatch.pm:${PORTSDIR}/textproc/p5-DelimMatch \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
+ ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+
+USE_PERL5= yes
+
+NO_BUILD= yes
+
+SITE_PERL= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
+XMLDIR= ${PREFIX}/share/xml/${PORTNAME}
+
+SCRIPTS= dtdflatten dtdformat dtdparse \
+ tools/contentmodel tools/dtdstats tools/elements
+
+MKCATALOG= ${LOCALBASE}/sbin/mkcatalog
+PLIST_SUB= MKCATALOG=${MKCATALOG}
+
+post-patch:
+ cd ${WRKSRC}; \
+ ${PERL} -pi -e 's,/usr/local/bin/perl5,${PERL},' ${SCRIPTS}
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin
+ ${MKDIR} ${SITE_PERL}/XML/DTDParse
+ ${INSTALL_DATA} ${WRKSRC}/XML/DTDParse/*.pm ${SITE_PERL}/XML/DTDParse
+ ${MKDIR} ${SITE_PERL}/modules
+ ${INSTALL_DATA} ${WRKSRC}/modules/*.pl ${SITE_PERL}/modules
+ ${MKDIR} ${XMLDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dtd.dtd ${XMLDIR}
+ ${ECHO_CMD} \
+ 'PUBLIC "-//Norman Walsh//DTD DTDParse V2.0//EN" "dtd.dtd"' \
+ >${XMLDIR}/catalog
+
+post-install:
+ ${MKCATALOG} -c ${PREFIX}/share/xml/catalog -q install dtdparse
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/sample; \
+ ${INSTALL_DATA} sample* simple* ${EXAMPLESDIR}
+# README is not 'additional' documentation because it's the only file
+# that contains copyright notice
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} README WhatsNew ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/dtdparse/distinfo b/textproc/dtdparse/distinfo
new file mode 100644
index 000000000000..a4ef1b7a2402
--- /dev/null
+++ b/textproc/dtdparse/distinfo
@@ -0,0 +1 @@
+MD5 (dtdparse-2.0beta6.tar.gz) = 905b08b8e814585cf8f49461521dee6c
diff --git a/textproc/dtdparse/files/patch-aa b/textproc/dtdparse/files/patch-aa
new file mode 100644
index 000000000000..ebc0c7331257
--- /dev/null
+++ b/textproc/dtdparse/files/patch-aa
@@ -0,0 +1,20 @@
+--- dtdformat.orig Wed Aug 1 23:54:27 2001
++++ dtdformat Tue Jan 29 14:38:09 2002
+@@ -122,16 +122,8 @@
+ require $userlib;
+ }
+ } else {
+- my $plain = $0;
+- $plain =~ s/\\/\//g;
+- if ($plain =~ /\//) {
+- $plain =~ s/^(.*)\/[^\/]+$/$1\/modules\/plain.pl/;
+- } else {
+- $plain = "modules/plain.pl";
+- }
+-
+ &status("Using plain library.",1);
+- require $plain;
++ require 'modules/plain.pl';
+ }
+
+ foreach my $key (keys %option) {
diff --git a/textproc/dtdparse/pkg-comment b/textproc/dtdparse/pkg-comment
new file mode 100644
index 000000000000..05fe23380a39
--- /dev/null
+++ b/textproc/dtdparse/pkg-comment
@@ -0,0 +1 @@
+Parse a DTD and produce an XML document that represents it
diff --git a/textproc/dtdparse/pkg-descr b/textproc/dtdparse/pkg-descr
new file mode 100644
index 000000000000..9b079e8083dc
--- /dev/null
+++ b/textproc/dtdparse/pkg-descr
@@ -0,0 +1,8 @@
+DTDParse is a tool for manipulating XML and SGML Document Type
+Definitions (DTDs). DTDParse is designed primarily to aid in the
+understanding and documentation of DTDs.
+
+WWW: http://sourceforge.net/projects/dtdparse/
+
+- Kimura Fuyuki
+fuyuki@mj.0038.net
diff --git a/textproc/dtdparse/pkg-plist b/textproc/dtdparse/pkg-plist
new file mode 100644
index 000000000000..82368efed77c
--- /dev/null
+++ b/textproc/dtdparse/pkg-plist
@@ -0,0 +1,30 @@
+bin/contentmodel
+bin/dtdflatten
+bin/dtdformat
+bin/dtdparse
+bin/dtdstats
+bin/elements
+lib/perl5/site_perl/%%PERL_VER%%/XML/DTDParse/Catalog.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/DTDParse/ContentModel.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/DTDParse/DTD.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/DTDParse/Tokenizer.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XML/DTDParse
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+lib/perl5/site_perl/%%PERL_VER%%/modules/html.pl
+lib/perl5/site_perl/%%PERL_VER%%/modules/plain.pl
+lib/perl5/site_perl/%%PERL_VER%%/modules/refentry.pl
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/modules
+@unexec %%MKCATALOG%% -c %D/share/xml/catalog -q deinstall dtdparse
+share/xml/dtdparse/catalog
+@exec %%MKCATALOG%% -c %D/share/xml/catalog -q install dtdparse
+share/xml/dtdparse/dtd.dtd
+@dirrm share/xml/dtdparse
+@unexec rmdir %D/share/xml 2>/dev/null || true
+share/examples/dtdparse/sample.dtd
+share/examples/dtdparse/sample.mod
+share/examples/dtdparse/simple-inline.mod
+share/examples/dtdparse/simple.dtd
+@dirrm share/examples/dtdparse
+share/doc/dtdparse/README
+share/doc/dtdparse/WhatsNew
+@dirrm share/doc/dtdparse