aboutsummaryrefslogtreecommitdiff
path: root/textproc/ekhtml/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:35:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-12 16:35:08 +0000
commit5bfa981946113519a3ed0c118a2d5b7edde0ac06 (patch)
tree45b69c2d1ee7205a3991d63981a10a2027766763 /textproc/ekhtml/Makefile
parentb541c75aaabc03ca634839601dccb5c02c3f8348 (diff)
downloadports-5bfa981946113519a3ed0c118a2d5b7edde0ac06.tar.gz
ports-5bfa981946113519a3ed0c118a2d5b7edde0ac06.zip
El-Kabong is a high-speed, forgiving, sax-style HTML parser.
Its aim is to provide consumers with a very fast, clean, lightweight library which parses HTML quickly, while forgiving syntactically incorrect tags. WWW: http://ekhtml.sourceforge.net/ PR: ports/118917 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
Notes
Notes: svn path=/head/; revision=205547
Diffstat (limited to 'textproc/ekhtml/Makefile')
-rw-r--r--textproc/ekhtml/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/ekhtml/Makefile b/textproc/ekhtml/Makefile
new file mode 100644
index 000000000000..cc1fa13e4de9
--- /dev/null
+++ b/textproc/ekhtml/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ekhtml
+# Date created: 21 December 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ekhtml
+PORTVERSION= 0.3.2
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= El-Kabong is a speedy, yet forgiving, SAX-style HTML parser
+
+USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/ekhtml.h lib/libekhtml.a \
+ lib/libekhtml.la lib/libekhtml.so \
+ lib/libekhtml.so.0
+
+.include <bsd.port.mk>