aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch6
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-10-05 00:09:16 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-10-05 00:09:16 +0000
commit3bae17d80b874b08b822cc8ad61807fe3b58f044 (patch)
treed9b847729f5f8d3d5b38cd40f753a3d71ceb6ad7 /textproc/elasticsearch6
parent1633253e05040b18c4cf1ac883a3ff4b4795eece (diff)
downloadports-3bae17d80b874b08b822cc8ad61807fe3b58f044.tar.gz
ports-3bae17d80b874b08b822cc8ad61807fe3b58f044.zip
Update to 6.8.3
* Update to 6.8.3, which allows the use of newer versions of Java (e.g. 11) * Modify the rc file to allow the version of Java to be used to be configured * Pull in changes to jvm.options that allow for newer versions of Java * Fix a type in pkg-message PR: 239972 Approved by: maintainer timeout Sponsored by: The FreeBSD Foundation
Notes
Notes: svn path=/head/; revision=513796
Diffstat (limited to 'textproc/elasticsearch6')
-rw-r--r--textproc/elasticsearch6/Makefile47
-rw-r--r--textproc/elasticsearch6/distinfo6
-rw-r--r--textproc/elasticsearch6/files/elasticsearch.in6
-rw-r--r--textproc/elasticsearch6/files/patch-config_jvm.options13
-rw-r--r--textproc/elasticsearch6/files/pkg-message.in2
5 files changed, 60 insertions, 14 deletions
diff --git a/textproc/elasticsearch6/Makefile b/textproc/elasticsearch6/Makefile
index 529f9a619758..824a9b0ab63f 100644
--- a/textproc/elasticsearch6/Makefile
+++ b/textproc/elasticsearch6/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 6.5.4
+PORTVERSION= 6.8.3
PORTREVISION= 0
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
@@ -24,22 +24,57 @@ USES= cpe shebangfix
NO_ARCH= yes
USE_JAVA= yes
NO_BUILD= yes
-JAVA_VERSION= 1.8+
+JAVA_VERSION= 8+
USE_RC_SUBR= ${PORTNAME}
SHEBANG_FILES= bin/elasticsearch \
+ bin/elasticsearch-certgen \
+ bin/elasticsearch-certutil \
bin/elasticsearch-cli \
+ bin/elasticsearch-croneval \
bin/elasticsearch-env \
- bin/elasticsearch-plugin
+ bin/elasticsearch-keystore \
+ bin/elasticsearch-migrate \
+ bin/elasticsearch-plugin \
+ bin/elasticsearch-saml-metadata \
+ bin/elasticsearch-setup-passwords \
+ bin/elasticsearch-shard \
+ bin/elasticsearch-sql-cli \
+ bin/elasticsearch-syskeygen \
+ bin/elasticsearch-translog \
+ bin/elasticsearch-users \
+ bin/x-pack-env \
+ bin/x-pack-security-env \
+ bin/x-pack-watcher-env
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-CONFIG_FILES= elasticsearch.yml log4j2.properties jvm.options
+CONFIG_FILES= elasticsearch.yml \
+ log4j2.properties \
+ jvm.options \
+ role_mapping.yml \
+ roles.yml
BINS= elasticsearch \
+ elasticsearch-certgen \
+ elasticsearch-certutil \
elasticsearch-cli \
+ elasticsearch-croneval \
elasticsearch-env \
- elasticsearch-plugin
+ elasticsearch-keystore \
+ elasticsearch-migrate \
+ elasticsearch-plugin \
+ elasticsearch-saml-metadata \
+ elasticsearch-setup-passwords \
+ elasticsearch-shard \
+ elasticsearch-sql-cli \
+ elasticsearch-sql-cli-${PORTVERSION}.jar \
+ elasticsearch-syskeygen \
+ elasticsearch-translog \
+ elasticsearch-users \
+ x-pack-env \
+ x-pack-security-env \
+ x-pack-watcher-env
PORTDOCS= LICENSE.txt \
NOTICE.txt \
@@ -51,7 +86,7 @@ SEARCHGROUP?= ${SEARCHUSER}
USERS= ${SEARCHUSER}
GROUPS= ${SEARCHGROUP}
-SUB_LIST= ETCDIR=${ETCDIR} JAVA=${JAVA}
+SUB_LIST= ETCDIR=${ETCDIR} JAVA_HOME=${JAVA_HOME}
SUB_FILES= pkg-message
post-patch:
diff --git a/textproc/elasticsearch6/distinfo b/textproc/elasticsearch6/distinfo
index d304b574e97e..9a234eff7994 100644
--- a/textproc/elasticsearch6/distinfo
+++ b/textproc/elasticsearch6/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548195078
-SHA256 (elasticsearch-6.5.4.tar.gz) = 762e25c036fa2e882cb7e91d83868fa15a1cad8549d279a8c5826a005bb31877
-SIZE (elasticsearch-6.5.4.tar.gz) = 113322649
+TIMESTAMP = 1568794150
+SHA256 (elasticsearch-6.8.3.tar.gz) = 824078e421c9f7e5ab9c875e4019d9ebfe3ada99db286b54dec090f97d1cbe25
+SIZE (elasticsearch-6.8.3.tar.gz) = 148609846
diff --git a/textproc/elasticsearch6/files/elasticsearch.in b/textproc/elasticsearch6/files/elasticsearch.in
index 3345f1795750..00779163c412 100644
--- a/textproc/elasticsearch6/files/elasticsearch.in
+++ b/textproc/elasticsearch6/files/elasticsearch.in
@@ -17,6 +17,8 @@
# Set it to required group.
# elasticsearch_config (path): Set to %%PREFIX%%/etc/elasticsearch/elasticsearch.yml by default.
# Set it to the config file location.
+# elasticsearch_java_home (path): Set to %%JAVA_HOME%% by default.
+# Set it to the root of the JDK to use.
#
. /etc/rc.subr
@@ -30,11 +32,12 @@ load_rc_config ${name}
: ${elasticsearch_group=elasticsearch}
: ${elasticsearch_config=%%PREFIX%%/etc/elasticsearch}
: ${elasticsearch_login_class=root}
+: ${elasticsearch_java_home="%%JAVA_HOME%%"}
required_files="${elasticsearch_config}/elasticsearch.yml"
_pidprefix=/var/run/elasticsearch/elasticsearch
pidfile=${_pidprefix}.pid
-procname=%%JAVA%%
+procname=${elasticsearch_java_home}/bin/java
extra_commands="console status"
console_cmd=elasticsearch_console
@@ -43,6 +46,7 @@ command=%%PREFIX%%/lib/elasticsearch/bin/elasticsearch
command_args="-d --pidfile=${pidfile}"
export ES_PATH_CONF=${elasticsearch_config}
+export JAVA_HOME=${elasticsearch_java_home}
elasticsearch_precmd()
{
diff --git a/textproc/elasticsearch6/files/patch-config_jvm.options b/textproc/elasticsearch6/files/patch-config_jvm.options
index 3e259c0b1315..925b45f3b73b 100644
--- a/textproc/elasticsearch6/files/patch-config_jvm.options
+++ b/textproc/elasticsearch6/files/patch-config_jvm.options
@@ -1,6 +1,6 @@
---- config/jvm.options.orig 2018-03-01 23:04:45 UTC
-+++ config/jvm.options
-@@ -87,7 +87,7 @@
+--- config/jvm.options.orig 2019-07-24 08:21:42.000000000 -0700
++++ config/jvm.options 2019-08-16 13:41:33.818798000 -0700
+@@ -107,13 +107,13 @@
8:-XX:+PrintGCDateStamps
8:-XX:+PrintTenuringDistribution
8:-XX:+PrintGCApplicationStoppedTime
@@ -9,3 +9,10 @@
8:-XX:+UseGCLogFileRotation
8:-XX:NumberOfGCLogFiles=32
8:-XX:GCLogFileSize=64m
+
+ # JDK 9+ GC logging
+-9-:-Xlog:gc*,gc+age=trace,safepoint:file=logs/gc.log:utctime,pid,tags:filecount=32,filesize=64m
++9-:-Xlog:gc*,gc+age=trace,safepoint:file=${ES_TMPDIR}/gc.log:utctime,pid,tags:filecount=32,filesize=64m
+ # due to internationalization enhancements in JDK 9 Elasticsearch need to set the provider to COMPAT otherwise
+ # time/date parsing will break in an incompatible way for some date patterns and locals
+ 9-:-Djava.locale.providers=COMPAT
diff --git a/textproc/elasticsearch6/files/pkg-message.in b/textproc/elasticsearch6/files/pkg-message.in
index e62bba0a7faf..f664cda07807 100644
--- a/textproc/elasticsearch6/files/pkg-message.in
+++ b/textproc/elasticsearch6/files/pkg-message.in
@@ -14,7 +14,7 @@ sysctl security.bsd.unprivileged_mlock=1
ElasticSearch plugins should only be installed via the elasticsearch-plugin
included with this software. As we strive to provide a minimum semblance
of security, the files installed by the package are owned by root:wheel.
-This is different than upstream hich expects all of the files to be
+This is different than upstream which expects all of the files to be
owned by the user and for you to execute the elasticsearch-plugin script
as said user.