aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch6
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-02-26 23:11:53 +0000
committerMark Felder <feld@FreeBSD.org>2018-02-26 23:11:53 +0000
commit796b2dbac7a6a389f2ffe9c13373f580aa7d2a79 (patch)
tree1b162fe4a6c342dc6912d8c992fdb15bfa0c6a6a /textproc/elasticsearch6
parent1c80decfca184fe25b62779f3b6d0301b7378b4d (diff)
downloadports-796b2dbac7a6a389f2ffe9c13373f580aa7d2a79.tar.gz
ports-796b2dbac7a6a389f2ffe9c13373f580aa7d2a79.zip
textproc/elasticsearch6: Fix JNA support
JNA (Java Native Access) provides access to OS-native facilities in pure Java code. The JNA shipped with Elastic is meant for Linux so it does not function correctly. We will ship one built for FreeBSD instead. PR: 222261
Notes
Notes: svn path=/head/; revision=463098
Diffstat (limited to 'textproc/elasticsearch6')
-rw-r--r--textproc/elasticsearch6/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/textproc/elasticsearch6/Makefile b/textproc/elasticsearch6/Makefile
index 6adcbf6e367c..388651b365dd 100644
--- a/textproc/elasticsearch6/Makefile
+++ b/textproc/elasticsearch6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 6.2.2
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -15,6 +15,7 @@ COMMENT= Full-text search engine for Java
LICENSE= APACHE20
RUN_DEPENDS= bash>0:shells/bash
+BUILD_DEPENDS= jna>0:devel/jna
CONFLICTS= elasticsearch-[0-9]* elasticsearch2-[0-9]* elasticsearch5-[0-9]*
@@ -51,6 +52,7 @@ SUB_FILES= pkg-message
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch
+ ${RM} ${WRKSRC}/lib/jna-*.jar
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
@@ -69,6 +71,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
${INSTALL} -lrs ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
+ ${INSTALL} -lrs ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}