aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch6
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-03-02 13:06:24 +0000
committerMark Felder <feld@FreeBSD.org>2018-03-02 13:06:24 +0000
commitab76b33c87933694950146723ffe9bfe31c19186 (patch)
tree3f322b8304184dea464af082ec324219d83671fd /textproc/elasticsearch6
parent44516d399da5f37705a2a2315fb2b8be21914c11 (diff)
downloadports-ab76b33c87933694950146723ffe9bfe31c19186.tar.gz
ports-ab76b33c87933694950146723ffe9bfe31c19186.zip
textproc/elasticsearch{5,6}: Fix symlink
Relative symlinks should only be used when both files are in the STAGEDIR. In this situation poudriere was producing usable packages because of the unique location of WRKSRC (/wrksrc/...) which caused the relative symlink to be deep enough "../../../../../" to hit the root of the filesystem and then point to the location of the file. However, users who were building the port directory with "make" or "portmaster" were getting symlinks that did not point to the right location. PR: 226234 226265 222261
Notes
Notes: svn path=/head/; revision=463392
Diffstat (limited to 'textproc/elasticsearch6')
-rw-r--r--textproc/elasticsearch6/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/elasticsearch6/Makefile b/textproc/elasticsearch6/Makefile
index 298aa59914e5..7b88fc0a8462 100644
--- a/textproc/elasticsearch6/Makefile
+++ b/textproc/elasticsearch6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 6.2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -74,7 +74,7 @@ do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
${INSTALL} -lrs ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin ${STAGEDIR}${PREFIX}/bin/elasticsearch-plugin
- ${INSTALL} -lrs ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
+ ${LN} -s ${JAVASHAREDIR}/classes/jna.jar ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/jna.jar
do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}