aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch7
diff options
context:
space:
mode:
authorJuraj Lutter <otis@FreeBSD.org>2020-12-30 13:23:30 +0000
committerJuraj Lutter <otis@FreeBSD.org>2020-12-30 13:23:30 +0000
commit0922fc81d7bfc4ea9ccb6c9eecbb59fc4dec9254 (patch)
treec9e85db80d7a4e2d7850a42a2f95b09c657d2eca /textproc/elasticsearch7
parent8d4dba011a582f35192863decb340a493fb85f4e (diff)
downloadports-0922fc81d7bfc4ea9ccb6c9eecbb59fc4dec9254.tar.gz
ports-0922fc81d7bfc4ea9ccb6c9eecbb59fc4dec9254.zip
textproc/elasticsearch7: Update to 7.10.1
Changelog at: https://www.elastic.co/guide/en/elasticsearch/reference/current/release-notes-7.10.1.html And while here, also reformat Makefile according to portfmt and portclippy Reviewed by: osa (mentor) Approved by: osa (mentor) Differential Revision: https://reviews.freebsd.org/D27820
Notes
Notes: svn path=/head/; revision=559659
Diffstat (limited to 'textproc/elasticsearch7')
-rw-r--r--textproc/elasticsearch7/Makefile85
-rw-r--r--textproc/elasticsearch7/distinfo6
2 files changed, 33 insertions, 58 deletions
diff --git a/textproc/elasticsearch7/Makefile b/textproc/elasticsearch7/Makefile
index 7362e2987661..1b39090e307b 100644
--- a/textproc/elasticsearch7/Makefile
+++ b/textproc/elasticsearch7/Makefile
@@ -2,11 +2,11 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 7.10.0
+PORTVERSION= 7.10.1
CATEGORIES= textproc java devel
MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/
PKGNAMESUFFIX= 7
-DISTNAME= ${PORTNAME}-${PORTVERSION}-no-jdk-linux-x86_64
+DISTNAME= ${PORTNAME}-${PORTVERSION}-no-jdk-darwin-x86_64
MAINTAINER= elastic@FreeBSD.org
COMMENT= Full-text search engine for Java
@@ -18,70 +18,44 @@ RUN_DEPENDS= bash>0:shells/bash \
jna>0:devel/jna
USES= cpe shebangfix
+USE_JAVA= yes
+JAVA_VERSION= 8+
+USE_RC_SUBR= ${PORTNAME}
+
+SHEBANG_FILES= bin/elasticsearch bin/elasticsearch-certgen \
+ bin/elasticsearch-certutil bin/elasticsearch-cli \
+ bin/elasticsearch-croneval bin/elasticsearch-env \
+ bin/elasticsearch-env-from-file bin/elasticsearch-keystore \
+ bin/elasticsearch-migrate bin/elasticsearch-node \
+ bin/elasticsearch-plugin bin/elasticsearch-saml-metadata \
+ bin/elasticsearch-setup-passwords bin/elasticsearch-shard \
+ bin/elasticsearch-sql-cli bin/elasticsearch-syskeygen \
+ bin/elasticsearch-users bin/x-pack-env bin/x-pack-security-env \
+ bin/x-pack-watcher-env
CONFLICTS= elasticsearch[56]-[0-9]*
NO_ARCH= yes
-USE_JAVA= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-JAVA_VERSION= 8+
-USE_RC_SUBR= ${PORTNAME}
-SHEBANG_FILES= bin/elasticsearch \
- bin/elasticsearch-certgen \
- bin/elasticsearch-certutil \
- bin/elasticsearch-cli \
- bin/elasticsearch-croneval \
- bin/elasticsearch-env \
- bin/elasticsearch-env-from-file \
- bin/elasticsearch-keystore \
- bin/elasticsearch-migrate \
- bin/elasticsearch-node \
- bin/elasticsearch-plugin \
- bin/elasticsearch-saml-metadata \
- bin/elasticsearch-setup-passwords \
- bin/elasticsearch-shard \
- bin/elasticsearch-sql-cli \
- bin/elasticsearch-syskeygen \
- bin/elasticsearch-users \
- bin/x-pack-env \
- bin/x-pack-security-env \
- bin/x-pack-watcher-env
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-CONFIG_FILES= elasticsearch.yml \
- jvm.options \
- log4j2.properties \
- role_mapping.yml \
- roles.yml
-BINS= elasticsearch \
- elasticsearch-certgen \
- elasticsearch-certutil \
- elasticsearch-cli \
- elasticsearch-croneval \
- elasticsearch-env \
- elasticsearch-env-from-file \
- elasticsearch-keystore \
- elasticsearch-migrate \
- elasticsearch-node \
- elasticsearch-plugin \
- elasticsearch-saml-metadata \
- elasticsearch-setup-passwords \
- elasticsearch-shard \
- elasticsearch-sql-cli \
+CONFIG_FILES= elasticsearch.yml jvm.options log4j2.properties \
+ role_mapping.yml roles.yml
+BINS= elasticsearch elasticsearch-certgen elasticsearch-certutil \
+ elasticsearch-cli elasticsearch-croneval elasticsearch-env \
+ elasticsearch-env-from-file elasticsearch-keystore \
+ elasticsearch-migrate elasticsearch-node elasticsearch-plugin \
+ elasticsearch-saml-metadata elasticsearch-setup-passwords \
+ elasticsearch-shard elasticsearch-sql-cli \
elasticsearch-sql-cli-${PORTVERSION}.jar \
- elasticsearch-syskeygen \
- elasticsearch-users \
- x-pack-env \
- x-pack-security-env \
- x-pack-watcher-env
+ elasticsearch-syskeygen elasticsearch-users x-pack-env \
+ x-pack-security-env x-pack-watcher-env
-PORTDOCS= LICENSE.txt \
- NOTICE.txt \
- README.asciidoc
+PORTDOCS= LICENSE.txt NOTICE.txt README.asciidoc
SIGAR_ARCH= ${ARCH:S|i386|x86|}
SEARCHUSER?= elasticsearch
@@ -89,12 +63,13 @@ SEARCHGROUP?= ${SEARCHUSER}
USERS= ${SEARCHUSER}
GROUPS= ${SEARCHGROUP}
-SUB_LIST= ETCDIR=${ETCDIR} JAVA_HOME=${JAVA_HOME}
SUB_FILES= pkg-message
+SUB_LIST= ETCDIR=${ETCDIR} \
+ JAVA_HOME=${JAVA_HOME}
post-patch:
${RM} ${WRKSRC}/lib/jna-*.jar
- # ML plugin not supported on FreeBSD
+# ML plugin not supported on FreeBSD
${RM} -rf ${WRKSRC}/modules/x-pack/x-pack-ml
do-install:
diff --git a/textproc/elasticsearch7/distinfo b/textproc/elasticsearch7/distinfo
index 6ba48bf1da19..cc3c7c31c7b4 100644
--- a/textproc/elasticsearch7/distinfo
+++ b/textproc/elasticsearch7/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1605452048
-SHA256 (elasticsearch-7.10.0-no-jdk-linux-x86_64.tar.gz) = 446e810113f51c048212b9b89b1e7f35ea37ce6292312d60f678266fdd43409a
-SIZE (elasticsearch-7.10.0-no-jdk-linux-x86_64.tar.gz) = 164353416
+TIMESTAMP = 1609277185
+SHA256 (elasticsearch-7.10.1-no-jdk-darwin-x86_64.tar.gz) = 269189ce606b071a30724fa678cca42dcbdea88134770070d043927b2a748dac
+SIZE (elasticsearch-7.10.1-no-jdk-darwin-x86_64.tar.gz) = 162046388