aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch
diff options
context:
space:
mode:
authorJason Unovitch <junovitch@FreeBSD.org>2015-08-05 22:18:29 +0000
committerJason Unovitch <junovitch@FreeBSD.org>2015-08-05 22:18:29 +0000
commit6d52df00f4d54eb87f17a0e8b3eace7f558b1394 (patch)
tree47e63a6bb01374b74b847f095f26e18c68bcac18 /textproc/elasticsearch
parent1af58f4e7c38029f48bb6e6f94a70444469a504a (diff)
downloadports-6d52df00f4d54eb87f17a0e8b3eace7f558b1394.tar.gz
ports-6d52df00f4d54eb87f17a0e8b3eace7f558b1394.zip
Notes
Diffstat (limited to 'textproc/elasticsearch')
-rw-r--r--textproc/elasticsearch/Makefile5
-rw-r--r--textproc/elasticsearch/distinfo4
-rw-r--r--textproc/elasticsearch/files/elasticsearch-plugin.in3
-rw-r--r--textproc/elasticsearch/files/elasticsearch.in21
-rw-r--r--textproc/elasticsearch/pkg-plist2
5 files changed, 21 insertions, 14 deletions
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
index 67955f646849..a40080f20fb4 100644
--- a/textproc/elasticsearch/Makefile
+++ b/textproc/elasticsearch/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= elasticsearch
-PORTVERSION= 1.6.0
+PORTVERSION= 1.7.0
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -15,6 +15,7 @@ LICENSE= APACHE20
RUN_DEPENDS= java-sigar>=0:${PORTSDIR}/java/sigar
USES= cpe
+NO_ARCH= yes
USE_JAVA= yes
NO_BUILD= yes
JAVA_VERSION= 1.7+
@@ -32,7 +33,7 @@ JARS= elasticsearch-${PORTVERSION}.jar \
asm-commons-4.1.jar \
apache-log4j-extras-1.2.17.jar \
antlr-runtime-3.5.jar \
- groovy-all-2.4.0.jar \
+ groovy-all-2.4.4.jar \
jna-4.1.0.jar \
jts-1.13.jar \
log4j-1.2.17.jar \
diff --git a/textproc/elasticsearch/distinfo b/textproc/elasticsearch/distinfo
index dc374160bb96..4328588420d8 100644
--- a/textproc/elasticsearch/distinfo
+++ b/textproc/elasticsearch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (elasticsearch-1.6.0.tar.gz) = dc336c83394b2f2f72f362e0f959a4cfdec2109aa3de15668401afeab0b02d2e
-SIZE (elasticsearch-1.6.0.tar.gz) = 28401477
+SHA256 (elasticsearch-1.7.0.tar.gz) = 6fabed2db09e1b88587df15269df328ecef33e155b3c675a2a6d2299bda09c95
+SIZE (elasticsearch-1.7.0.tar.gz) = 28501532
diff --git a/textproc/elasticsearch/files/elasticsearch-plugin.in b/textproc/elasticsearch/files/elasticsearch-plugin.in
index 95873d95d2be..7b9757571ec8 100644
--- a/textproc/elasticsearch/files/elasticsearch-plugin.in
+++ b/textproc/elasticsearch/files/elasticsearch-plugin.in
@@ -5,7 +5,8 @@
name=elasticsearch
rcvar=elasticsearch_enable
-load_rc_config $name
+
+load_rc_config ${name}
: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch/elasticsearch.yml"}
diff --git a/textproc/elasticsearch/files/elasticsearch.in b/textproc/elasticsearch/files/elasticsearch.in
index f6e53ff60f52..8c646f3b1a6f 100644
--- a/textproc/elasticsearch/files/elasticsearch.in
+++ b/textproc/elasticsearch/files/elasticsearch.in
@@ -27,7 +27,8 @@
name=elasticsearch
rcvar=elasticsearch_enable
-load_rc_config $name
+
+load_rc_config ${name}
: ${elasticsearch_enable:="NO"}
: ${elasticsearch_user:=%%SEARCHUSER%%}
@@ -47,7 +48,6 @@ pidfile="/var/run/${name}.pid"
ES_LIB="%%PREFIX%%/lib/elasticsearch"
ES_CLASSPATH=$ES_LIB/elasticsearch-%%PORTVERSION%%.jar:$ES_LIB/*:$ES_LIB/sigar/*
-
java_options=" -server \
-Xms${elasticsearch_min_mem} \
-Xmx${elasticsearch_max_mem} \
@@ -71,7 +71,8 @@ stop_cmd="elasticsearch_stop"
command="/usr/sbin/daemon"
command_args="-f %%LOCALBASE%%/bin/java -Des.pidfile=${pidfile} ${elasticsearch_props} ${java_options} org.elasticsearch.bootstrap.Elasticsearch"
-elasticsearch_precmd() {
+elasticsearch_precmd()
+{
touch ${pidfile}
chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
@@ -79,12 +80,14 @@ elasticsearch_precmd() {
/usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/log/elasticsearch
}
-elasticsearch_console () {
+elasticsearch_console()
+{
%%LOCALBASE%%/bin/java -Des.foreground=yes ${elasticsearch_props} ${java_options} org.elasticsearch.bootstrap.Elasticsearch
}
-elasticsearch_stop() {
+elasticsearch_stop()
+{
rc_pid=$(elasticsearch_check_pidfile $pidfile)
if [ -z "$rc_pid" ]; then
@@ -97,7 +100,8 @@ elasticsearch_stop() {
kill ${rc_pid} 2> /dev/null
}
-elasticsearch_status() {
+elasticsearch_status()
+{
rc_pid=$(elasticsearch_check_pidfile $pidfile)
if [ -z "$rc_pid" ]; then
@@ -108,7 +112,8 @@ elasticsearch_status() {
echo "${name} is running as pid ${rc_pid}."
}
-elasticsearch_check_pidfile() {
+elasticsearch_check_pidfile()
+{
_pidfile=$1
if [ -z "$_pidfile" ]; then
err 3 'USAGE: elasticsearch_check_pidfile pidfile'
@@ -126,5 +131,5 @@ elasticsearch_check_pidfile() {
echo -n $_pid
fi
}
-load_rc_config ${name}
+
run_rc_command "$1"
diff --git a/textproc/elasticsearch/pkg-plist b/textproc/elasticsearch/pkg-plist
index 8cc6abd81f5d..fd9b8cd90ad4 100644
--- a/textproc/elasticsearch/pkg-plist
+++ b/textproc/elasticsearch/pkg-plist
@@ -8,7 +8,7 @@ lib/elasticsearch/apache-log4j-extras-1.2.17.jar
lib/elasticsearch/asm-4.1.jar
lib/elasticsearch/asm-commons-4.1.jar
lib/elasticsearch/elasticsearch-%%PORTVERSION%%.jar
-lib/elasticsearch/groovy-all-2.4.0.jar
+lib/elasticsearch/groovy-all-2.4.4.jar
lib/elasticsearch/jna-4.1.0.jar
lib/elasticsearch/jts-1.13.jar
lib/elasticsearch/log4j-1.2.17.jar