aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2013-03-11 14:14:30 +0000
committerTom Judge <tj@FreeBSD.org>2013-03-11 14:14:30 +0000
commitbc80e31fbbdc37e6c3151cf7d3f91feaf6aad838 (patch)
tree57e50a327c7b8a895465ea741cc7e80ea9a72d0b /textproc/elasticsearch
parentb4d1f35918b10abe275906db59ed93915dae1014 (diff)
downloadports-bc80e31fbbdc37e6c3151cf7d3f91feaf6aad838.tar.gz
ports-bc80e31fbbdc37e6c3151cf7d3f91feaf6aad838.zip
Notes
Diffstat (limited to 'textproc/elasticsearch')
-rw-r--r--textproc/elasticsearch/Makefile5
-rw-r--r--textproc/elasticsearch/files/elasticsearch-plugin.in2
-rw-r--r--textproc/elasticsearch/files/elasticsearch.in2
3 files changed, 6 insertions, 3 deletions
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
index 51b8585a2739..95bea585f69e 100644
--- a/textproc/elasticsearch/Makefile
+++ b/textproc/elasticsearch/Makefile
@@ -3,6 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 0.20.5
+PORTREVISION= 1
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -45,7 +46,9 @@ GROUPS= ${SEARCHGROUP}
ELASTIC_DBDIR= /var/db/elasticsearch
ELASTIC_LOGDIR= /var/log/elasticsearch
-SUB_LIST= SEARCHUSER=${SEARCHUSER} SEARCHGROUP=${SEARCHGROUP}
+SUB_LIST= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ PORTVERSION=${PORTVERSION}
SUB_FILES= elasticsearch-plugin
PLIST_SUB= SIGAR_ARCH=${SIGAR_ARCH} \
SEARCHUSER=${SEARCHUSER} \
diff --git a/textproc/elasticsearch/files/elasticsearch-plugin.in b/textproc/elasticsearch/files/elasticsearch-plugin.in
index 5f076c49f349..95873d95d2be 100644
--- a/textproc/elasticsearch/files/elasticsearch-plugin.in
+++ b/textproc/elasticsearch/files/elasticsearch-plugin.in
@@ -10,7 +10,7 @@ load_rc_config $name
: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch/elasticsearch.yml"}
ES_LIB="%%PREFIX%%/lib/elasticsearch"
-ES_CLASSPATH=$ES_LIB/elasticsearch-0.19.9.jar:$ES_LIB/*:$ES_LIB/sigar/*
+ES_CLASSPATH=$ES_LIB/elasticsearch-%%PORTVERSION%%.jar:$ES_LIB/*:$ES_LIB/sigar/*
JAVA=%%LOCALBASE%%/bin/java
diff --git a/textproc/elasticsearch/files/elasticsearch.in b/textproc/elasticsearch/files/elasticsearch.in
index 97a9a50e0c5f..c86df05081e9 100644
--- a/textproc/elasticsearch/files/elasticsearch.in
+++ b/textproc/elasticsearch/files/elasticsearch.in
@@ -45,7 +45,7 @@ required_files="${elasticsearch_config}"
pidfile="/var/run/${name}.pid"
ES_LIB="%%PREFIX%%/lib/elasticsearch"
-ES_CLASSPATH=$ES_LIB/elasticsearch-0.19.9.jar:$ES_LIB/*:$ES_LIB/sigar/*
+ES_CLASSPATH=$ES_LIB/elasticsearch-%%PORTVERSION%%.jar:$ES_LIB/*:$ES_LIB/sigar/*
java_options=" -server \