aboutsummaryrefslogtreecommitdiff
path: root/textproc/en-hunspell
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2016-02-19 05:14:17 +0000
committerMikhail Teterin <mi@FreeBSD.org>2016-02-19 05:14:17 +0000
commit2bc57294ea2b95925f1b4952eb27fbf869b47d22 (patch)
tree394f967814267168df94a510600223d780681b94 /textproc/en-hunspell
parent613442dcfef574a24e5cc0ad451a22a27f9f0e03 (diff)
downloadports-2bc57294ea2b95925f1b4952eb27fbf869b47d22.tar.gz
ports-2bc57294ea2b95925f1b4952eb27fbf869b47d22.zip
Make fetchable by upgrading. Add options for vocabularies and provide
help-file for the user. PR: 202685 Submitted by: Joseph Mingrone Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=409151
Diffstat (limited to 'textproc/en-hunspell')
-rw-r--r--textproc/en-hunspell/Makefile74
-rw-r--r--textproc/en-hunspell/distinfo20
-rw-r--r--textproc/en-hunspell/pkg-descr7
-rw-r--r--textproc/en-hunspell/pkg-help31
4 files changed, 107 insertions, 25 deletions
diff --git a/textproc/en-hunspell/Makefile b/textproc/en-hunspell/Makefile
index bf5a3801076b..d487d0733079 100644
--- a/textproc/en-hunspell/Makefile
+++ b/textproc/en-hunspell/Makefile
@@ -1,37 +1,68 @@
# $FreeBSD$
PORTNAME= hunspell
-PORTVERSION= 7.1
-PORTREVISION= 1
+PORTVERSION= 2016.01.19
CATEGORIES= textproc
-MASTER_SITES= SF/wordlist/Hunspell%20en_US/${PORTVERSION}-0/ \
- SF/wordlist/Hunspell%20en_CA/${PORTVERSION}-0/:CA \
- LOCAL/sunpoet/${PORTNAME}/:GB
+MASTER_SITES= SF/wordlist/speller/${PORTVERSION}/
PKGNAMEPREFIX= en-
-DISTFILES= hunspell-en_US-${PORTVERSION}-0${EXTRACT_SUFX} \
- hunspell-en_CA-${PORTVERSION}-0${EXTRACT_SUFX}:CA \
- en_GB-1.20.zip:GB
+DISTFILES= hunspell-en_US${US_VARIANT}-${PORTVERSION}${EXTRACT_SUFX} \
+ hunspell-en_CA${CA_VARIANT}-${PORTVERSION}${EXTRACT_SUFX} \
+ hunspell-en_GB${GB_VARIANT}-${PORTVERSION}${EXTRACT_SUFX}
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= office@FreeBSD.org
COMMENT= English hunspell dictionaries
-# en_CA and en_US are licensed under BSD
-# en_GB is licensed under LGPL3
-LICENSE= BSD3CLAUSE LGPL3
-LICENSE_COMB= multi
+LICENSE= BSD3CLAUSE
USES= zip
NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/en_CA.aff \
- %%DATADIR%%/en_CA.dic \
+OPTIONS_DEFAULT= GB_ISE US_STANDARD CA_STANDARD
+OPTIONS_RADIO= American British Canadian
+OPTIONS_RADIO_Canadian= CA_STANDARD CA_LARGE
+OPTIONS_RADIO_American= US_STANDARD US_LARGE
+OPTIONS_RADIO_British= GB_IZE GB_ISE GB_LARGE
+GB_IZE_DESC= en_GB dictionary with -ize spelling
+GB_ISE_DESC= en_GB dictionary with -ise spelling
+CA_STANDARD_DESC= Canadian dictionary considered standard by maintainers
+US_STANDARD_DESC= American dictionary considered standard by maintainers
+GB_LARGE_DESC= Dictionary with more words and multiple variants per word
+CA_LARGE_DESC= ${GB_LARGE_DESC}
+US_LARGE_DESC= ${GB_LARGE_DESC}
+
+PLIST_FILES= %%DATADIR%%/en_CA${CA_VARIANT}.aff \
+ %%DATADIR%%/en_CA${CA_VARIANT}.dic \
+ %%DATADIR%%/README_en_CA${CA_VARIANT}.txt \
+ %%DATADIR%%/en_GB${GB_VARIANT}.dic \
+ %%DATADIR%%/en_GB${GB_VARIANT}.aff \
+ %%DATADIR%%/README_en_GB${GB_VARIANT}.txt \
+ %%DATADIR%%/en_US${US_VARIANT}.aff \
+ %%DATADIR%%/en_US${US_VARIANT}.dic \
+ %%DATADIR%%/README_en_US${US_VARIANT}.txt \
%%DATADIR%%/en_GB.dic \
%%DATADIR%%/en_GB.aff \
- %%DATADIR%%/en_US.aff \
- %%DATADIR%%/en_US.dic
+
+COPY= -lh # Use hardlinks rather than copies under stage/
+
+.include <bsd.port.options.mk>
+
+.for c in CA GB US
+. for v in STANDARD ISE IZE LARGE
+. if ${PORT_OPTIONS:M${c}_${v}}
+${c}_VARIANT= ${v:S/STANDARD//:tl:C/^.+$/-&/}
+. endif
+. endfor
+.endfor
+
+.if ${PORT_OPTIONS:MUS_LARGE}
+PLIST_FILES+= %%DATADIR%%/en_US.aff %%DATADIR%%/en_US.dic
+.endif
+.if ${PORT_OPTIONS:MCA_LARGE}
+PLIST_FILES+= %%DATADIR%%/en_CA.aff %%DATADIR%%/en_CA.dic
+.endif
GBALIASES= en_AG en_AU en_BS en_BW en_BZ en_DK en_GH en_HK en_IE en_IN \
en_JM en_NA en_NG en_NZ en_SG en_TT en_ZA en_ZW
@@ -44,6 +75,17 @@ PLIST_FILES+= %%DATADIR%%/${ALIAS}.aff \
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
${INSTALL_DATA} ${WRKSRC}/*.aff ${WRKSRC}/*.dic ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/README_*.txt ${STAGEDIR}${DATADIR}/
+ ${LN} -s en_GB${GB_VARIANT}.aff ${STAGEDIR}${DATADIR}/en_GB.aff
+ ${LN} -s en_GB${GB_VARIANT}.dic ${STAGEDIR}${DATADIR}/en_GB.dic
+.if ${PORT_OPTIONS:MUS_LARGE}
+ ${LN} -s en_US-large.aff ${STAGEDIR}${DATADIR}/en_US.aff
+ ${LN} -s en_US-large.dic ${STAGEDIR}${DATADIR}/en_US.dic
+.endif
+.if ${PORT_OPTIONS:MCA_LARGE}
+ ${LN} -s en_CA-large.aff ${STAGEDIR}${DATADIR}/en_CA.aff
+ ${LN} -s en_CA-large.dic ${STAGEDIR}${DATADIR}/en_CA.dic
+.endif
.for ALIAS in ${GBALIASES}
${LN} -s en_GB.aff ${STAGEDIR}${DATADIR}/${ALIAS}.aff
${LN} -s en_GB.dic ${STAGEDIR}${DATADIR}/${ALIAS}.dic
diff --git a/textproc/en-hunspell/distinfo b/textproc/en-hunspell/distinfo
index 58c74b4525a8..60cddd90afff 100644
--- a/textproc/en-hunspell/distinfo
+++ b/textproc/en-hunspell/distinfo
@@ -1,6 +1,14 @@
-SHA256 (hunspell/hunspell-en_US-7.1-0.zip) = e1f341803f0aedb1a0d00ca1db988506fd6fe216758367e4bed66e2f2d22a198
-SIZE (hunspell/hunspell-en_US-7.1-0.zip) = 192842
-SHA256 (hunspell/hunspell-en_CA-7.1-0.zip) = 9229ffb96f6cdfd72dd03db4477c7416e9b90166498be2a5f487cc42e23f3223
-SIZE (hunspell/hunspell-en_CA-7.1-0.zip) = 193289
-SHA256 (hunspell/en_GB-1.20.zip) = 5869d8bd80eb2eb328ebe36b356348de4ae2acb1db6df39d1717d33f89f63728
-SIZE (hunspell/en_GB-1.20.zip) = 250182
+SHA256 (hunspell/hunspell-en_CA-2016.01.19.zip) = 00aea3cc360f6922b7b3978095cb963ca9c9fb76e7c0aa401da86f3a57e48920
+SHA256 (hunspell/hunspell-en_CA-large-2016.01.19.zip) = 04fd5dcfdca048e18640a1d420077473ab105431fc14ebe307bda452732abf6c
+SHA256 (hunspell/hunspell-en_GB-ise-2016.01.19.zip) = d17486b550fa22e2da31f647daceec84ab6354289b99d5088e12f63d88a9a027
+SHA256 (hunspell/hunspell-en_GB-ize-2016.01.19.zip) = 52804f35c1dc44adabaf86fc0316181c2bed28c857880fa624aea248a23d677f
+SHA256 (hunspell/hunspell-en_GB-large-2016.01.19.zip) = edcca9b78ae8923e6209db523355b4a91ac6d9daad94df12413498b4e5069719
+SHA256 (hunspell/hunspell-en_US-2016.01.19.zip) = fe0c48084bfd534f244ecd12836ae5e0b27fc10dab28879fdafece892267a674
+SHA256 (hunspell/hunspell-en_US-large-2016.01.19.zip) = 1c8a7a5a993313620a7d96e74e5c45f4df7ab9ad0141764ffeea66db9bfc089f
+SIZE (hunspell/hunspell-en_CA-2016.01.19.zip) = 76872
+SIZE (hunspell/hunspell-en_CA-large-2016.01.19.zip) = 312039
+SIZE (hunspell/hunspell-en_GB-ise-2016.01.19.zip) = 196436
+SIZE (hunspell/hunspell-en_GB-ize-2016.01.19.zip) = 196388
+SIZE (hunspell/hunspell-en_GB-large-2016.01.19.zip) = 314577
+SIZE (hunspell/hunspell-en_US-2016.01.19.zip) = 195799
+SIZE (hunspell/hunspell-en_US-large-2016.01.19.zip) = 310556
diff --git a/textproc/en-hunspell/pkg-descr b/textproc/en-hunspell/pkg-descr
index 021c773f811c..a329ae4955ee 100644
--- a/textproc/en-hunspell/pkg-descr
+++ b/textproc/en-hunspell/pkg-descr
@@ -1,4 +1,5 @@
-English hunspell dictionaries
+This port installs English dictionaries for US, British, and Canadian
+variants of the language. Although use of the "standard" ones is
+encouraged, multiple spelling options are available for all three.
-WWW: http://wordlist.sourceforge.net/
-WWW: http://en-gb.pyxidium.co.uk/dictionary/
+WWW: http://wordlist.aspell.net/
diff --git a/textproc/en-hunspell/pkg-help b/textproc/en-hunspell/pkg-help
new file mode 100644
index 000000000000..05b25f410ea2
--- /dev/null
+++ b/textproc/en-hunspell/pkg-help
@@ -0,0 +1,31 @@
+README file for English Hunspell dictionaries derived from SCOWL.
+
+The following dictionaries are available:
+
+ en_US (American)
+ en_CA (Canadian)
+ en_GB-ise (British with "ise" spelling)
+ en_GB-ize (British with "ize" spelling)
+
+ en_US-large
+ en_CA-large
+ en_GB-large (with both "ise" and "ize" spelling)
+
+The normal (non-large) dictionaries correspond to SCOWL size 60 and,
+to encourage consistent spelling, generally only include one spelling
+variant for a word. The large dictionaries correspond to SCOWL size
+70 and may include multiple spelling for a word when both variants are
+considered almost equal. The larger dictionaries however (1) have not
+been as carefully checked for errors as the normal dictionaries and
+thus may contain misspelled or invalid words; and (2) contain
+uncommon, yet valid, words that might cause problems as they are
+likely to be misspellings of more common words (for example, "ort" and
+"calender").
+
+To get an idea of the difference in size, here are 25 random words
+only found in the large dictionary for American English:
+
+ Bermejo Freyr's Guenevere Hatshepsut Nottinghamshire arrestment
+ crassitudes crural dogwatches errorless fetial flaxseeds godroon
+ incretion jalape~no's kelpie kishkes neuroglias pietisms pullulation
+ stemwinder stenoses syce thalassic zees