aboutsummaryrefslogtreecommitdiff
path: root/textproc/eqe
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-02-18 14:03:32 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-02-18 14:03:32 +0000
commit6cc83f14683048478be1ee4c12de3e41339fe110 (patch)
treed5939c6c4f3ae396a7919da0d0e9a86da3b5c036 /textproc/eqe
parent6c0f5d0b8296a3f52b7ef7b52d807dfcdac1b65e (diff)
downloadports-6cc83f14683048478be1ee4c12de3e41339fe110.tar.gz
ports-6cc83f14683048478be1ee4c12de3e41339fe110.zip
Notes
Diffstat (limited to 'textproc/eqe')
-rw-r--r--textproc/eqe/Makefile49
-rw-r--r--textproc/eqe/distinfo3
-rw-r--r--textproc/eqe/files/patch-src-eqedit25
-rw-r--r--textproc/eqe/pkg-descr12
-rw-r--r--textproc/eqe/pkg-plist6
5 files changed, 95 insertions, 0 deletions
diff --git a/textproc/eqe/Makefile b/textproc/eqe/Makefile
new file mode 100644
index 000000000000..8a226962c267
--- /dev/null
+++ b/textproc/eqe/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: eqe
+# Date created: 2007/02/13
+# Whom: chinsan
+#
+# $FreeBSD$
+
+PORTNAME= eqe
+PORTVERSION= 1.3.0
+CATEGORIES= textproc
+MASTER_SITES= http://rlehy.free.fr/
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= LaTeX equation editor
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Gtk2.pm:${PORTSDIR}/x11-toolkits/p5-Gtk2 \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit \
+ Magick++-config:${PORTSDIR}/graphics/ImageMagick \
+ tex:${PORTSDIR}/print/teTeX-base
+RUN_DEPENDS= tex:${PORTSDIR}/print/teTeX-base
+
+USE_BZIP2= yes
+USE_PERL5= yes
+
+MAKE_ARGS= PREFIX=${PREFIX}
+
+MAN1= eqe.1 eqedit.1
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= TODO changelog README FAQ copyright
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^\(install:\) install-doc,\1,' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ @pod2man ${WRKSRC}/doc/eqe.pod ${WRKSRC}/doc/eqe.1
+ @pod2man ${WRKSRC}/doc/eqedit.pod ${WRKSRC}/doc/eqedit.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/eqe.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/eqedit.1 ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/eqe/distinfo b/textproc/eqe/distinfo
new file mode 100644
index 000000000000..3babb50aafdd
--- /dev/null
+++ b/textproc/eqe/distinfo
@@ -0,0 +1,3 @@
+MD5 (eqe-1.3.0.tar.bz2) = 74b27a201302ea33033d9ccb496e1e34
+SHA256 (eqe-1.3.0.tar.bz2) = 8dd320985ebb7763295bf04b3664e0fb8094e3c398e468fddf225b13ee77f4e5
+SIZE (eqe-1.3.0.tar.bz2) = 98707
diff --git a/textproc/eqe/files/patch-src-eqedit b/textproc/eqe/files/patch-src-eqedit
new file mode 100644
index 000000000000..2d1b2b782924
--- /dev/null
+++ b/textproc/eqe/files/patch-src-eqedit
@@ -0,0 +1,25 @@
+--- src/eqedit.orig Fri Feb 16 21:52:49 2007
++++ src/eqedit Fri Feb 16 23:54:34 2007
+@@ -364,10 +364,10 @@
+
+ sub command
+ {
+- my @com = @_; #(@_, " >> $options->{log} 2>\&1");
++ my @com = (@_, " >> $options->{log} 2>\&1");
+ my $com = join ' ', @com;
+- $options->verbose and mywarn "executing $com\n";
+- redirect_to_log($options->{log}, sub {system @com}) and mydie "command '$com' failed with error code $?";
++ $options->verbose and print "executing $com\n";
++ system $com and mydie "command '$com' failed with error code $?";
+ }
+
+ sub find_template
+@@ -506,7 +506,7 @@
+
+ if (@transparent or @res or not same_ext($in, $out))
+ {
+- command 'convert', '-comment', $comment, @res, @transparent, $in, $out;
++ command 'convert', @res, @transparent, $in, $out;
+ }
+ elsif ($in ne $out)
+ {
diff --git a/textproc/eqe/pkg-descr b/textproc/eqe/pkg-descr
new file mode 100644
index 000000000000..a7d0ca649d7c
--- /dev/null
+++ b/textproc/eqe/pkg-descr
@@ -0,0 +1,12 @@
+Eqe is a simple clone of the excellent LaTeX equation editor you can find on
+MacOS X. There's a zone to type LaTeX input, and it generates an image to
+represent it (color, font, and size are customisable). You can drag the
+image to other applications (like OpenOffice.org Impress, Mozilla, the
+Gimp). It also exports to almost any image format, including PNG, JPEG,
+PDF...). It is free software, released under the GPL.
+
+It is composed of two parts: eqedit, which is a command line tool that
+generates images from LaTeX input, and eqe which wraps eqedit into a
+graphical user interface.
+
+WWW: http://rlehy.free.fr/
diff --git a/textproc/eqe/pkg-plist b/textproc/eqe/pkg-plist
new file mode 100644
index 000000000000..568bc092870a
--- /dev/null
+++ b/textproc/eqe/pkg-plist
@@ -0,0 +1,6 @@
+bin/eqedit
+bin/eqe
+%%DATADIR%%/template.tt.tex
+%%DATADIR%%/error.png
+%%DATADIR%%/initial_image.png
+@dirrmtry %%DATADIR%%