aboutsummaryrefslogtreecommitdiff
path: root/textproc/estraier
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2004-12-08 03:15:26 +0000
committerMichael Johnson <ahze@FreeBSD.org>2004-12-08 03:15:26 +0000
commit2c323ff2f332f476d42f3a0201c0e9ea7b7e2811 (patch)
tree79e7446703ed7e47bbde30346c22ad59217df8b0 /textproc/estraier
parent910274d6549c74642effe374750f0c40174ab785 (diff)
downloadports-2c323ff2f332f476d42f3a0201c0e9ea7b7e2811.tar.gz
ports-2c323ff2f332f476d42f3a0201c0e9ea7b7e2811.zip
- Chase SHLIB in qdbm
- Disable mecab support by default and only use on >5.x
Notes
Notes: svn path=/head/; revision=123432
Diffstat (limited to 'textproc/estraier')
-rw-r--r--textproc/estraier/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index 7ad27203f7b2..f7339966a3af 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -7,6 +7,7 @@
PORTNAME= estraier
PORTVERSION= 1.2.25
+PORTREVISION= 1
CATEGORIES= japanese textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,7 +15,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ahze@FreeBSD.org
COMMENT= A full-text search system for personal use
-LIB_DEPENDS= qdbm.3:${PORTSDIR}/databases/qdbm
+LIB_DEPENDS= qdbm.4:${PORTSDIR}/databases/qdbm
USE_ICONV= yes
@@ -25,11 +26,11 @@ CONFIGURE_ARGS= --with-sysqdbm \
--enable-dlfilter \
--enable-devel
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/include ${PTHREAD_LIBS}"
OPTIONS= CHASEN "Japanese Morphological Analysis Support" On \
- MECAB "Part-of-Speech and Morphological Analyzer" On \
+ MECAB "Part-of-Speech and Morphological Analyzer" Off \
KAKASI "Language processing filter/converter" On
.include <bsd.port.pre.mk>
@@ -40,11 +41,13 @@ LIB_DEPENDS+= chasen.0:${PORTSDIR}/japanese/chasen-base
CONFIGURE_ARGS+= --enable-chasen
.endif
-.if ${ARCH} == i386 && !defined(WITHOUT_MECAB)
+.if ${OSVERSION} > 500000
+.if ${ARCH} == i386 && defined(WITH_MECAB)
LIB_DEPENDS+= mecab.0:${PORTSDIR}/japanese/mecab
CONFIGURE_ARGS+= --enable-mecab
.endif
+.endif
.if !defined(WITHOUT_KAKASI)
LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi