aboutsummaryrefslogtreecommitdiff
path: root/textproc/estraier
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-08-29 13:57:59 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-08-29 13:57:59 +0000
commit55f60f49836c8a9189dea9171d14d908c6662530 (patch)
treee6c591f9c6041ce41c4177179bfffc596bb7f29a /textproc/estraier
parent359767b4a8d64edf21cb0a8175a7e49dbcddd115 (diff)
downloadports-55f60f49836c8a9189dea9171d14d908c6662530.tar.gz
ports-55f60f49836c8a9189dea9171d14d908c6662530.zip
Estraier is a full-text search system for personal use. Full-text search means
functions to search lots of documents for some documents including specified words. The principal purpose of Estraier is to realize a full-text search system of a web site. It functions similarly to Google, but for a personal web site or sites in an intranet. PR: ports/71090 Submitted by: Michael Johnson <ahze@ahze.net>
Notes
Notes: svn path=/head/; revision=117563
Diffstat (limited to 'textproc/estraier')
-rw-r--r--textproc/estraier/Makefile57
-rw-r--r--textproc/estraier/distinfo2
-rw-r--r--textproc/estraier/pkg-descr7
-rw-r--r--textproc/estraier/pkg-plist46
4 files changed, 112 insertions, 0 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
new file mode 100644
index 000000000000..899eff866f9c
--- /dev/null
+++ b/textproc/estraier/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: estraier
+# Date created: 2004-08-28
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= estraier
+PORTVERSION= 1.2.23
+CATEGORIES= japanese textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ahze@ahze.net
+COMMENT= A full-text search system for personal use
+
+LIB_DEPENDS= qdbm.3:${PORTSDIR}/databases/qdbm
+
+USE_ICONV= yes
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_ARGS= --with-sysqdbm \
+ --enable-dlfilter
+
+OPTIONS= CHASEN "Japanese Morphological Analysis Support" On \
+ MECAB "Part-of-Speech and Morphological Analyzer" On \
+ KAKASI "Language processing filter/converter" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_CHASEN)
+LIB_DEPENDS+= chasen.0:${PORTSDIR}/japanese/chasen-base
+
+CONFIGURE_ARGS+= --enable-chasen
+.endif
+
+.if ${ARCH} == i386 && !defined(WITHOUT_MECAB)
+LIB_DEPENDS+= mecab.0:${PORTSDIR}/japanese/mecab
+
+CONFIGURE_ARGS+= --enable-mecab
+.endif
+
+.if !defined(WITHOUT_KAKASI)
+LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi
+
+CONFIGURE_ARGS+= --enable-kakasi
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2|${CFLAGS}|' ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|MYDOCS|#|' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/estraier/distinfo b/textproc/estraier/distinfo
new file mode 100644
index 000000000000..0d22685f1e49
--- /dev/null
+++ b/textproc/estraier/distinfo
@@ -0,0 +1,2 @@
+MD5 (estraier-1.2.23.tar.gz) = 533260da1d7b86b79eb1908af4fc86c7
+SIZE (estraier-1.2.23.tar.gz) = 389430
diff --git a/textproc/estraier/pkg-descr b/textproc/estraier/pkg-descr
new file mode 100644
index 000000000000..7434dac46912
--- /dev/null
+++ b/textproc/estraier/pkg-descr
@@ -0,0 +1,7 @@
+Estraier is a full-text search system for personal use. Full-text search means
+functions to search lots of documents for some documents including specified
+words. The principal purpose of Estraier is to realize a full-text search
+system of a web site. It functions similarly to Google, but for a personal
+web site or sites in an intranet.
+
+WWW: http://estraier.sourceforge.net/
diff --git a/textproc/estraier/pkg-plist b/textproc/estraier/pkg-plist
new file mode 100644
index 000000000000..a5cc5af7358b
--- /dev/null
+++ b/textproc/estraier/pkg-plist
@@ -0,0 +1,46 @@
+bin/estautoreg
+bin/estdochtml
+bin/estgzhtml
+bin/estindex
+bin/estmanhtml
+bin/estmbtomh
+bin/estpdfhtml
+bin/estppthtml
+bin/estserver
+bin/estsiutil
+bin/estwolels
+bin/estxdthtml
+bin/estxdwhtml
+bin/estxlshtml
+bin/estxview
+libexec/estmerge.cgi
+libexec/estsearch.cgi
+%%PORTDOCS%%share/estraier/COPYING
+%%PORTDOCS%%share/estraier/ChangeLog
+share/estraier/estmerge.conf
+share/estraier/estmerge.tmpl
+share/estraier/estmerge.top
+share/estraier/estsearch.conf
+share/estraier/estsearch.tmpl
+share/estraier/estsearch.top
+share/estraier/estxview.css
+share/estraier/estxview.dtd
+share/estraier/estxview.xsl
+share/estraier/locale/ja/estmerge.conf
+share/estraier/locale/ja/estmerge.tmpl
+share/estraier/locale/ja/estmerge.top
+share/estraier/locale/ja/estsearch.conf
+share/estraier/locale/ja/estsearch.tmpl
+share/estraier/locale/ja/estsearch.top
+share/estraier/skins/school/estmerge.tmpl
+share/estraier/skins/school/estsearch.tmpl
+share/estraier/skins/stoic/estmerge.tmpl
+share/estraier/skins/stoic/estsearch.tmpl
+%%PORTDOCS%%share/estraier/spex-ja.html
+%%PORTDOCS%%share/estraier/spex.html
+@dirrm share/estraier/skins/stoic
+@dirrm share/estraier/skins/school
+@dirrm share/estraier/skins
+@dirrm share/estraier/locale/ja
+@dirrm share/estraier/locale
+@dirrm share/estraier