aboutsummaryrefslogtreecommitdiff
path: root/textproc/estraier
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2012-06-11 05:41:08 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2012-06-11 05:41:08 +0000
commita679e70533812906f7095b363ae62bbc92e18c2e (patch)
treee557d89013f67fe65e9274664750dfacb3ec7703 /textproc/estraier
parent7a108ee4565ac41f49e58c2a1d8249d3e51d508b (diff)
downloadports-a679e70533812906f7095b363ae62bbc92e18c2e.tar.gz
ports-a679e70533812906f7095b363ae62bbc92e18c2e.zip
convert to new options framework
Notes
Notes: svn path=/head/; revision=299010
Diffstat (limited to 'textproc/estraier')
-rw-r--r--textproc/estraier/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index e43d6cf3202e..af2227ac8ff9 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -16,9 +16,11 @@ COMMENT= A full-text search system for personal use
LIB_DEPENDS= qdbm.14:${PORTSDIR}/databases/qdbm
-OPTIONS= CHASEN "Japanese Morphological Analysis Support" Off \
- MECAB "Part-of-Speech and Morphological Analyzer" Off \
- KAKASI "Language processing filter/converter" On
+OPTIONS_DEFINE= CHASEN MECAB KAKASI
+OPTIONS_DEFAULT= KAKASI
+CHASEN_DESC= Japanese Morphological Analysis Support
+MECAB_DESC= Part-of-Speech and Morphological Analyzer
+KAKASI_DESC= Language processing filter/converter
USE_ICONV= yes
GNU_CONFIGURE= yes
@@ -30,17 +32,17 @@ LDFLAGS+= -L${LOCALBASE}/include ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
-.if defined(WITH_CHASEN)
+.if ${PORT_OPTIONS:MCHASEN}
LIB_DEPENDS+= chasen.2:${PORTSDIR}/japanese/chasen-base
CONFIGURE_ARGS+= --enable-chasen
.endif
-.if defined(WITH_MECAB) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MMECAB} && ${ARCH} == "i386"
LIB_DEPENDS+= mecab.1:${PORTSDIR}/japanese/mecab
CONFIGURE_ARGS+= --enable-mecab
.endif
-.if !defined(WITHOUT_KAKASI)
+.if ${PORT_OPTIONS:MKAKASI}
LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi
CONFIGURE_ARGS+= --enable-kakasi
.endif