aboutsummaryrefslogtreecommitdiff
path: root/textproc/ezxml
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-07-28 06:51:18 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-07-28 06:51:18 +0000
commitb1b9f1c051d5356c011b0797cd3b63ba3ce15dcc (patch)
tree79d13e716c3dfa35c0e6f24c10ecbec47d6bf172 /textproc/ezxml
parent1ecf5e6d0f421e5fc55d9410557cad94988ab935 (diff)
downloadports-b1b9f1c051d5356c011b0797cd3b63ba3ce15dcc.tar.gz
ports-b1b9f1c051d5356c011b0797cd3b63ba3ce15dcc.zip
Add ezxml - lightweight C library for parsing XML.
PR: ports/84710 Submitted by: Marcin Jessa <yazzy@yazzy.org> Approved by: perky (mentor)
Notes
Notes: svn path=/head/; revision=140287
Diffstat (limited to 'textproc/ezxml')
-rw-r--r--textproc/ezxml/Makefile43
-rw-r--r--textproc/ezxml/distinfo2
-rw-r--r--textproc/ezxml/files/patch-Makefile15
-rw-r--r--textproc/ezxml/pkg-descr9
4 files changed, 69 insertions, 0 deletions
diff --git a/textproc/ezxml/Makefile b/textproc/ezxml/Makefile
new file mode 100644
index 000000000000..d689fdc1d3fe
--- /dev/null
+++ b/textproc/ezxml/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: ezxml
+# Date created: 27th July 2005
+# Whom: Marcin Jessa <yazzy@yazzy.org>
+# $FreeBSD$
+
+PORTNAME= ezxml
+PORTVERSION= 0.8.4
+CATEGORIES= textproc devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.yazzy.org/ports/ezxml/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= yazzy@yazzy.org
+COMMENT= Easy to use C library for parsing XML documents
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LIBFILES= libezxml.a
+HEADERFILES= ezxml.h
+
+PLIST_FILES= include/${HEADERFILES} \
+ lib/${LIBFILES}
+
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%EXAMPLESDIR%%/ezxml.txt
+PLIST_DIRS= %%EXAMPLESDIR%%
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${LIBFILES} ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/${HEADERFILES} ${PREFIX}/include
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ezxml.txt ${EXAMPLESDIR}
+ @${ECHO} "An example of how to use the ezXML library can be found in"
+ @${ECHO} "${EXAMPLESDIR}"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/ezxml/distinfo b/textproc/ezxml/distinfo
new file mode 100644
index 000000000000..19c51a487e85
--- /dev/null
+++ b/textproc/ezxml/distinfo
@@ -0,0 +1,2 @@
+MD5 (ezxml-0.8.4.tar.gz) = d01573d61b12ac6f14a69ba356d10ad4
+SIZE (ezxml-0.8.4.tar.gz) = 16394
diff --git a/textproc/ezxml/files/patch-Makefile b/textproc/ezxml/files/patch-Makefile
new file mode 100644
index 000000000000..725309dd7d7e
--- /dev/null
+++ b/textproc/ezxml/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig Wed Jun 1 10:58:04 2005
++++ Makefile Thu Jul 28 10:13:03 2005
+@@ -21,10 +21,10 @@
+ # TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
+ # SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+-CC = gcc
++CC ?= gcc
+ AR = ar
+ RM = rm -f
+-CFLAGS = -Wall -O2
++CFLAGS ?= -Wall -O2
+ OBJS = ezxml.o
+ LIB = libezxml.a
+ TEST = ezxmltest
diff --git a/textproc/ezxml/pkg-descr b/textproc/ezxml/pkg-descr
new file mode 100644
index 000000000000..cf85dfa786e6
--- /dev/null
+++ b/textproc/ezxml/pkg-descr
@@ -0,0 +1,9 @@
+ezXML is a C library for parsing XML documents inspired by simpleXML for PHP.
+As the name implies, it's easy to use. It's ideal for
+parsing XML configuration files or REST web service responses.
+It's also fast and lightweight (less than 20k compiled).
+
+- Marcin Jessa
+yazzy@yazzy.org
+
+WWW: http://ezxml.sourceforge.net/