aboutsummaryrefslogtreecommitdiff
path: root/textproc/fcitx-qt5
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-30 20:29:57 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-30 20:29:57 +0000
commit7ffffa9b5077803dde243038e6180fea17c5adf6 (patch)
treea130c3ed24412d715a64372fd0c829b62143337a /textproc/fcitx-qt5
parent8910e782de0d389112a6afc8a0511448a9acc2aa (diff)
downloadports-7ffffa9b5077803dde243038e6180fea17c5adf6.tar.gz
ports-7ffffa9b5077803dde243038e6180fea17c5adf6.zip
Fcitx support for Qt5
WWW: https://github.com/fcitx/fcitx-qt5 PR: 211378 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=419330
Diffstat (limited to 'textproc/fcitx-qt5')
-rw-r--r--textproc/fcitx-qt5/Makefile26
-rw-r--r--textproc/fcitx-qt5/distinfo3
-rw-r--r--textproc/fcitx-qt5/files/patch-widgetsaddons_CMakeLists.txt11
-rw-r--r--textproc/fcitx-qt5/pkg-descr3
-rw-r--r--textproc/fcitx-qt5/pkg-plist30
5 files changed, 73 insertions, 0 deletions
diff --git a/textproc/fcitx-qt5/Makefile b/textproc/fcitx-qt5/Makefile
new file mode 100644
index 000000000000..4bf4c3fc0e7c
--- /dev/null
+++ b/textproc/fcitx-qt5/Makefile
@@ -0,0 +1,26 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= fcitx-qt5
+PORTVERSION= 1.0.5
+CATEGORIES= textproc
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Fcitx support for Qt5
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS+= libfcitx-config.so:chinese/fcitx \
+ libQt5DBus.so:devel/dbus-qt5 \
+ libxkbcommon.so:x11/libxkbcommon
+BUILD_DEPENDS= extra-cmake-modules>0:devel/extra-cmake-modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+
+USES= compiler:c++11-lib cmake gettext pkgconfig
+USE_QT5= core gui qmake widgets buildtools_build
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/fcitx-qt5/distinfo b/textproc/fcitx-qt5/distinfo
new file mode 100644
index 000000000000..6ed052165d43
--- /dev/null
+++ b/textproc/fcitx-qt5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469521016
+SHA256 (fcitx-fcitx-qt5-1.0.5_GH0.tar.gz) = a72ffa9b5b399fd5471d7f0a74ccbdd21b98fd93c78a1f0d36f24526a1968440
+SIZE (fcitx-fcitx-qt5-1.0.5_GH0.tar.gz) = 88066
diff --git a/textproc/fcitx-qt5/files/patch-widgetsaddons_CMakeLists.txt b/textproc/fcitx-qt5/files/patch-widgetsaddons_CMakeLists.txt
new file mode 100644
index 000000000000..6e681d90aa2c
--- /dev/null
+++ b/textproc/fcitx-qt5/files/patch-widgetsaddons_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- widgetsaddons/CMakeLists.txt.orig 2016-07-26 08:42:38 UTC
++++ widgetsaddons/CMakeLists.txt
+@@ -59,7 +59,7 @@ set_target_properties(FcitxQt5WidgetsAdd
+ AUTOMOC TRUE
+ SOVERSION 1
+ COMPILE_FLAGS "-fvisibility=hidden"
+- LINK_FLAGS "-Wl,--no-undefined"
++ LINK_FLAGS "-Wl,--no-undefined -lintl"
+ EXPORT_NAME WidgetsAddons
+ )
+
diff --git a/textproc/fcitx-qt5/pkg-descr b/textproc/fcitx-qt5/pkg-descr
new file mode 100644
index 000000000000..fa9fe0c2f8e4
--- /dev/null
+++ b/textproc/fcitx-qt5/pkg-descr
@@ -0,0 +1,3 @@
+Fcitx support for Qt5
+
+WWW: https://github.com/fcitx/fcitx-qt5
diff --git a/textproc/fcitx-qt5/pkg-plist b/textproc/fcitx-qt5/pkg-plist
new file mode 100644
index 000000000000..810cef9869bc
--- /dev/null
+++ b/textproc/fcitx-qt5/pkg-plist
@@ -0,0 +1,30 @@
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtconnection.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtdbusaddons_export.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtformattedpreedit.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtinputcontextproxy.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtinputmethoditem.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtinputmethodproxy.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtkeyboardlayout.h
+include/FcitxQt5/FcitxQtDBusAddons/fcitxqtkeyboardproxy.h
+include/FcitxQt5/FcitxQtWidgetsAddons/fcitxqtconfiguifactory.h
+include/FcitxQt5/FcitxQtWidgetsAddons/fcitxqtconfiguiplugin.h
+include/FcitxQt5/FcitxQtWidgetsAddons/fcitxqtconfiguiwidget.h
+include/FcitxQt5/FcitxQtWidgetsAddons/fcitxqtkeysequencewidget.h
+include/FcitxQt5/FcitxQtWidgetsAddons/fcitxqtwidgetsaddons_export.h
+include/FcitxQt5/fcitxqtdbusaddons_version.h
+include/FcitxQt5/fcitxqtwidgetsaddons_version.h
+lib/cmake/FcitxQt5DBusAddons/FcitxQt5DBusAddonsConfig.cmake
+lib/cmake/FcitxQt5DBusAddons/FcitxQt5DBusAddonsConfigVersion.cmake
+lib/cmake/FcitxQt5DBusAddons/FcitxQt5DBusAddonsTargets-release.cmake
+lib/cmake/FcitxQt5DBusAddons/FcitxQt5DBusAddonsTargets.cmake
+lib/cmake/FcitxQt5WidgetsAddons/FcitxQt5WidgetsAddonsConfig.cmake
+lib/cmake/FcitxQt5WidgetsAddons/FcitxQt5WidgetsAddonsConfigVersion.cmake
+lib/cmake/FcitxQt5WidgetsAddons/FcitxQt5WidgetsAddonsTargets-release.cmake
+lib/cmake/FcitxQt5WidgetsAddons/FcitxQt5WidgetsAddonsTargets.cmake
+lib/libFcitxQt5DBusAddons.so
+lib/libFcitxQt5DBusAddons.so.1
+lib/libFcitxQt5DBusAddons.so.1.0
+lib/libFcitxQt5WidgetsAddons.so
+lib/libFcitxQt5WidgetsAddons.so.1
+lib/libFcitxQt5WidgetsAddons.so.1.0
+%%QT_PLUGINDIR%%/platforminputcontexts/libfcitxplatforminputcontextplugin.so