aboutsummaryrefslogtreecommitdiff
path: root/textproc/fcitx5-gtk
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
commit784693f56c9c8899036fc4aa340be19676b514c8 (patch)
tree57d3ceb2bb056eb915f7f25ff148aea78c8807cb /textproc/fcitx5-gtk
parent0109871be7f4defa811d2e308db09de0ee44b2c5 (diff)
downloadports-784693f56c9c8899036fc4aa340be19676b514c8.tar.gz
ports-784693f56c9c8899036fc4aa340be19676b514c8.zip
Add Fcitx5 IME framework and related ports
The Fcitx5 IME framework is the future version of the legacy Fcitx IME framework. Main parts of Fcitx5: - x11/xcb-imdkit - textproc/fcitx5 Application supports libraries of Fcitx5: - textproc/fcitx5-qt - textproc/fcitx5-gtk GUI configuration tool of Fcitx5: - textproc/fcitx5-configtool IME addons for Fcitx5: - chinese/fcitx5-rime - japanese/fcitx5-anthy textproc/fcitx5 and chinese/fcitx cannot be installed at the same time right now, due to development environment and runtime conflicts users could possibly run into. Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27667
Notes
Notes: svn path=/head/; revision=559587
Diffstat (limited to 'textproc/fcitx5-gtk')
-rw-r--r--textproc/fcitx5-gtk/Makefile28
-rw-r--r--textproc/fcitx5-gtk/distinfo3
-rw-r--r--textproc/fcitx5-gtk/pkg-descr3
-rw-r--r--textproc/fcitx5-gtk/pkg-plist14
4 files changed, 48 insertions, 0 deletions
diff --git a/textproc/fcitx5-gtk/Makefile b/textproc/fcitx5-gtk/Makefile
new file mode 100644
index 000000000000..4e9c539d5cd1
--- /dev/null
+++ b/textproc/fcitx5-gtk/Makefile
@@ -0,0 +1,28 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-gtk
+DISTVERSION= 5.0.1
+CATEGORIES= textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Fcitx support for GTK+ 2/3
+
+LICENSE= LGPL21+
+LICENSE_FILE= ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
+
+LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c++17-lang gettext-tools cmake gnome kde:5 pkgconfig xorg
+
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+USE_GNOME= introspection glib20 gtk20 gtk30
+USE_KDE= ecm
+USE_XORG= x11
+
+CMAKE_OFF= ENABLE_GTK4_IM_MODULE
+
+.include <bsd.port.mk>
diff --git a/textproc/fcitx5-gtk/distinfo b/textproc/fcitx5-gtk/distinfo
new file mode 100644
index 000000000000..ca706ded9a70
--- /dev/null
+++ b/textproc/fcitx5-gtk/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608282030
+SHA256 (fcitx-fcitx5-gtk-5.0.1_GH0.tar.gz) = 464645a9445e0d301b2274f4b86bcdec3a2d0ecc3ff993f59985927a39b17bb9
+SIZE (fcitx-fcitx5-gtk-5.0.1_GH0.tar.gz) = 37195
diff --git a/textproc/fcitx5-gtk/pkg-descr b/textproc/fcitx5-gtk/pkg-descr
new file mode 100644
index 000000000000..bdc9dea4d309
--- /dev/null
+++ b/textproc/fcitx5-gtk/pkg-descr
@@ -0,0 +1,3 @@
+Fcitx5 support for GTK+ applications.
+
+WWW: https://github.com/fcitx/fcitx5-gtk
diff --git a/textproc/fcitx5-gtk/pkg-plist b/textproc/fcitx5-gtk/pkg-plist
new file mode 100644
index 000000000000..4a9a3d160c34
--- /dev/null
+++ b/textproc/fcitx5-gtk/pkg-plist
@@ -0,0 +1,14 @@
+include/Fcitx5/GClient/fcitx-gclient/fcitxgclient.h
+include/Fcitx5/GClient/fcitx-gclient/fcitxgwatcher.h
+lib/cmake/Fcitx5GClient/Fcitx5GClientConfig.cmake
+lib/cmake/Fcitx5GClient/Fcitx5GClientConfigVersion.cmake
+lib/cmake/Fcitx5GClient/Fcitx5GClientTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Fcitx5GClient/Fcitx5GClientTargets.cmake
+lib/girepository-1.0/FcitxG-1.0.typelib
+lib/gtk-2.0/%%GTK2_VERSION%%/immodules/im-fcitx5.so
+lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-fcitx5.so
+lib/libFcitx5GClient.so
+lib/libFcitx5GClient.so.1
+lib/libFcitx5GClient.so.5.0.1
+libdata/pkgconfig/Fcitx5GClient.pc
+share/gir-1.0/FcitxG-1.0.gir