aboutsummaryrefslogtreecommitdiff
path: root/textproc/fcitx5-qt
diff options
context:
space:
mode:
authorGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2020-12-29 14:58:55 +0000
commit784693f56c9c8899036fc4aa340be19676b514c8 (patch)
tree57d3ceb2bb056eb915f7f25ff148aea78c8807cb /textproc/fcitx5-qt
parent0109871be7f4defa811d2e308db09de0ee44b2c5 (diff)
downloadports-784693f56c9c8899036fc4aa340be19676b514c8.tar.gz
ports-784693f56c9c8899036fc4aa340be19676b514c8.zip
Add Fcitx5 IME framework and related ports
The Fcitx5 IME framework is the future version of the legacy Fcitx IME framework. Main parts of Fcitx5: - x11/xcb-imdkit - textproc/fcitx5 Application supports libraries of Fcitx5: - textproc/fcitx5-qt - textproc/fcitx5-gtk GUI configuration tool of Fcitx5: - textproc/fcitx5-configtool IME addons for Fcitx5: - chinese/fcitx5-rime - japanese/fcitx5-anthy textproc/fcitx5 and chinese/fcitx cannot be installed at the same time right now, due to development environment and runtime conflicts users could possibly run into. Submitted by: Ka Ho Ng <khng300@gmail.com> Approved by: lwhsu Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D27667
Notes
Notes: svn path=/head/; revision=559587
Diffstat (limited to 'textproc/fcitx5-qt')
-rw-r--r--textproc/fcitx5-qt/Makefile31
-rw-r--r--textproc/fcitx5-qt/distinfo3
-rw-r--r--textproc/fcitx5-qt/pkg-descr3
-rw-r--r--textproc/fcitx5-qt/pkg-plist42
4 files changed, 79 insertions, 0 deletions
diff --git a/textproc/fcitx5-qt/Makefile b/textproc/fcitx5-qt/Makefile
new file mode 100644
index 000000000000..3239cb611e8b
--- /dev/null
+++ b/textproc/fcitx5-qt/Makefile
@@ -0,0 +1,31 @@
+# Created by: Ka Ho Ng <khng300@gmail.com>
+# $FreeBSD$
+
+PORTNAME= fcitx5-qt
+DISTVERSION= 5.0.1
+CATEGORIES= textproc
+
+MAINTAINER= khng300@gmail.com
+COMMENT= Fcitx support for Qt5
+
+LICENSE= LGPL21+ BSD3CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENSES/LGPL-2.1-or-later.txt
+LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/LICENSES/BSD-3-Clause.txt
+
+LIB_DEPENDS= libFcitx5Utils.so:textproc/fcitx5 \
+ libxkbcommon.so:x11/libxkbcommon
+
+USES= compiler:c++17-lang gettext-tools cmake kde:5 pkgconfig qt:5 xorg
+
+USE_GITHUB= yes
+GH_ACCOUNT= fcitx
+USE_KDE= ecm
+USE_QT= concurrent core dbus widgets buildtools_build qmake_build
+USE_XORG= x11 xcb
+USE_LDCONFIG= yes
+
+CMAKE_ON= ENABLE_QT5
+CMAKE_OFF= ENABLE_QT4 ENABLE_QT6
+
+.include <bsd.port.mk>
diff --git a/textproc/fcitx5-qt/distinfo b/textproc/fcitx5-qt/distinfo
new file mode 100644
index 000000000000..80388e706d7b
--- /dev/null
+++ b/textproc/fcitx5-qt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608279898
+SHA256 (fcitx-fcitx5-qt-5.0.1_GH0.tar.gz) = 15f3ea902dba2d9a1f368e3ad2efd6e7fde120e49c647452ad136fec8fd92046
+SIZE (fcitx-fcitx5-qt-5.0.1_GH0.tar.gz) = 107323
diff --git a/textproc/fcitx5-qt/pkg-descr b/textproc/fcitx5-qt/pkg-descr
new file mode 100644
index 000000000000..a7b9a1c0ecf6
--- /dev/null
+++ b/textproc/fcitx5-qt/pkg-descr
@@ -0,0 +1,3 @@
+Fcitx5 support for Qt5 applications.
+
+WWW: https://github.com/fcitx/fcitx5-qt
diff --git a/textproc/fcitx5-qt/pkg-plist b/textproc/fcitx5-qt/pkg-plist
new file mode 100644
index 000000000000..d0c3a4cb8e8e
--- /dev/null
+++ b/textproc/fcitx5-qt/pkg-plist
@@ -0,0 +1,42 @@
+include/Fcitx5Qt5/Fcitx5Qt5DBusAddons/fcitx5qt5dbusaddons_export.h
+include/Fcitx5Qt5/Fcitx5Qt5DBusAddons/fcitxqtcontrollerproxy.h
+include/Fcitx5Qt5/Fcitx5Qt5DBusAddons/fcitxqtdbustypes.h
+include/Fcitx5Qt5/Fcitx5Qt5DBusAddons/fcitxqtinputcontextproxy.h
+include/Fcitx5Qt5/Fcitx5Qt5DBusAddons/fcitxqtinputmethodproxy.h
+include/Fcitx5Qt5/Fcitx5Qt5DBusAddons/fcitxqtwatcher.h
+include/Fcitx5Qt5/Fcitx5QtWidgetsAddons/fcitx5qt5widgetsaddons_export.h
+include/Fcitx5Qt5/Fcitx5QtWidgetsAddons/fcitxqtconfiguifactory.h
+include/Fcitx5Qt5/Fcitx5QtWidgetsAddons/fcitxqtconfiguiplugin.h
+include/Fcitx5Qt5/Fcitx5QtWidgetsAddons/fcitxqtconfiguiwidget.h
+include/Fcitx5Qt5/Fcitx5QtWidgetsAddons/fcitxqti18nhelper.h
+include/Fcitx5Qt5/Fcitx5QtWidgetsAddons/fcitxqtkeysequencewidget.h
+include/Fcitx5Qt5/fcitx5qt5dbusaddons_version.h
+include/Fcitx5Qt5/fcitx5qt5widgetsaddons_version.h
+lib/cmake/Fcitx5Qt5DBusAddons/Fcitx5Qt5DBusAddonsConfig.cmake
+lib/cmake/Fcitx5Qt5DBusAddons/Fcitx5Qt5DBusAddonsConfigVersion.cmake
+lib/cmake/Fcitx5Qt5DBusAddons/Fcitx5Qt5DBusAddonsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Fcitx5Qt5DBusAddons/Fcitx5Qt5DBusAddonsTargets.cmake
+lib/cmake/Fcitx5Qt5WidgetsAddons/Fcitx5Qt5WidgetsAddonsConfig.cmake
+lib/cmake/Fcitx5Qt5WidgetsAddons/Fcitx5Qt5WidgetsAddonsConfigVersion.cmake
+lib/cmake/Fcitx5Qt5WidgetsAddons/Fcitx5Qt5WidgetsAddonsTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Fcitx5Qt5WidgetsAddons/Fcitx5Qt5WidgetsAddonsTargets.cmake
+lib/fcitx5/libexec/fcitx5-qt5-gui-wrapper
+lib/fcitx5/qt5/libfcitx-quickphrase-editor5.so
+lib/libFcitx5Qt5DBusAddons.so
+lib/libFcitx5Qt5DBusAddons.so.1
+lib/libFcitx5Qt5DBusAddons.so.5.0.1
+lib/libFcitx5Qt5WidgetsAddons.so
+lib/libFcitx5Qt5WidgetsAddons.so.2
+lib/libFcitx5Qt5WidgetsAddons.so.5.0.1
+%%QT_PLUGINDIR%%/platforminputcontexts/libfcitx5platforminputcontextplugin.so
+share/locale/ca/LC_MESSAGES/fcitx5-qt.mo
+share/locale/da/LC_MESSAGES/fcitx5-qt.mo
+share/locale/de/LC_MESSAGES/fcitx5-qt.mo
+share/locale/es/LC_MESSAGES/fcitx5-qt.mo
+share/locale/fr/LC_MESSAGES/fcitx5-qt.mo
+share/locale/he/LC_MESSAGES/fcitx5-qt.mo
+share/locale/ja/LC_MESSAGES/fcitx5-qt.mo
+share/locale/ko/LC_MESSAGES/fcitx5-qt.mo
+share/locale/ru/LC_MESSAGES/fcitx5-qt.mo
+share/locale/zh_CN/LC_MESSAGES/fcitx5-qt.mo
+share/locale/zh_TW/LC_MESSAGES/fcitx5-qt.mo