aboutsummaryrefslogtreecommitdiff
path: root/textproc/fldiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-08-08 14:58:23 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-08-08 14:58:23 +0000
commit72ec2b1931d0409a91b4d513858733fa0e5c9619 (patch)
treedcee09e19542dbf8bd337f67725d7b7973569311 /textproc/fldiff
parent160159e96cc3b151f1b50e8343349dcdef1900a7 (diff)
downloadports-72ec2b1931d0409a91b4d513858733fa0e5c9619.tar.gz
ports-72ec2b1931d0409a91b4d513858733fa0e5c9619.zip
- Pacify portlint
- Register missing LIB_DEPENDS - Register missing USE* flags
Notes
Notes: svn path=/head/; revision=419859
Diffstat (limited to 'textproc/fldiff')
-rw-r--r--textproc/fldiff/Makefile8
-rw-r--r--textproc/fldiff/files/patch-DiffWindow.cxx6
2 files changed, 9 insertions, 5 deletions
diff --git a/textproc/fldiff/Makefile b/textproc/fldiff/Makefile
index 8d633ec890a7..8547af1891fc 100644
--- a/textproc/fldiff/Makefile
+++ b/textproc/fldiff/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fldiff
PORTVERSION= 1.1
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= textproc
MASTER_SITES= LOCAL/ehaupt
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -13,9 +13,13 @@ COMMENT= Graphical diff program using FLTK
LICENSE= GPLv2
-LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
+LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libpng16.so:graphics/png
GNU_CONFIGURE= yes
+USES= jpeg
+USE_XORG= x11 xext xfixes xft
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/textproc/fldiff/files/patch-DiffWindow.cxx b/textproc/fldiff/files/patch-DiffWindow.cxx
index db526c0b7cd9..c11fcd8de1d4 100644
--- a/textproc/fldiff/files/patch-DiffWindow.cxx
+++ b/textproc/fldiff/files/patch-DiffWindow.cxx
@@ -1,6 +1,6 @@
---- ./DiffWindow.cxx.orig 2006-11-13 19:54:02.000000000 +0100
-+++ ./DiffWindow.cxx 2011-09-08 10:20:08.000000000 +0200
-@@ -1126,11 +1126,11 @@
+--- DiffWindow.cxx.orig 2006-11-13 18:54:02 UTC
++++ DiffWindow.cxx
+@@ -1126,11 +1126,11 @@ void
DiffWindow::save_prefs()
{
// Save the window prefs for the next run...