aboutsummaryrefslogtreecommitdiff
path: root/textproc/flex/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2015-11-18 08:08:43 +0000
committerJohan van Selst <johans@FreeBSD.org>2015-11-18 08:08:43 +0000
commit3bf13ac1f514a62e64afcf132f96adb0a65229e1 (patch)
tree9b3cddfde106a5b2cbf64ea5ed4e43236950f11f /textproc/flex/Makefile
parent8a7af791fcd9327e62ef5bed2f656374085b0d29 (diff)
downloadports-3bf13ac1f514a62e64afcf132f96adb0a65229e1.tar.gz
ports-3bf13ac1f514a62e64afcf132f96adb0a65229e1.zip
Notes
Diffstat (limited to 'textproc/flex/Makefile')
-rw-r--r--textproc/flex/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
index b31bc1a6ebac..e1a289ea9858 100644
--- a/textproc/flex/Makefile
+++ b/textproc/flex/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= flex
-PORTVERSION= 2.5.39
-PORTREVISION= 2
+PORTVERSION= 2.6.0
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}
@@ -21,16 +20,26 @@ CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4 MAKEINFO="makeinfo --no-split"
INSTALL_TARGET= install-strip
INFO= flex
+PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS NLS
+OPTIONS_DEFINE= DOCS EXAMPLES NLS
OPTIONS_SUB= yes
NLS_USES= gettext iconv
NLS_CONFIGURE_ENABLE= nls
+.include <bsd.port.options.mk>
+
post-patch: .SILENT
${REINPLACE_CMD} -Ee 's/tests//' \
-e '/mode=compile ..CC/s/\\$$/-fPIC -DPIC &/' \
${WRKSRC}/Makefile.in
${RM} -f ${WRKSRC}/doc/*.info*
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -r ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}/
+ ${RM} ${STAGEDIR}${EXAMPLESDIR}/Makefile.am
+.endif
+
.include <bsd.port.mk>