aboutsummaryrefslogtreecommitdiff
path: root/textproc/flex
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-05-05 15:51:04 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-05-05 15:51:04 +0000
commit4007e179a6cb2c28428cd709099b5c1ff6b65402 (patch)
treed166f7cca2e4eb6c99aefcf89423413167b39ec2 /textproc/flex
parent4991917f1be160062b7892c266409044459d8af3 (diff)
downloadports-4007e179a6cb2c28428cd709099b5c1ff6b65402.tar.gz
ports-4007e179a6cb2c28428cd709099b5c1ff6b65402.zip
Make sure static library libfl_pic.a contains position independent code.
This fixes compilation of ports that insist on linking this library into a shared object file (specifically devel/libmatheval). While here, remove unused ranlib patch lines. PR: ports/189323 Submitted by: tijl
Notes
Notes: svn path=/head/; revision=353028
Diffstat (limited to 'textproc/flex')
-rw-r--r--textproc/flex/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/textproc/flex/Makefile b/textproc/flex/Makefile
index ac6b9210d20b..e11d513720a4 100644
--- a/textproc/flex/Makefile
+++ b/textproc/flex/Makefile
@@ -2,6 +2,7 @@
PORTNAME= flex
PORTVERSION= 2.5.39
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}
@@ -16,7 +17,7 @@ USES= bison gmake tar:bzip2
GNU_CONFIGURE= yes
# install flex header to its own dir to avoid conflict with system flex.
CONFIGURE_ARGS= --includedir=${PREFIX}/include/flex --disable-shared
-CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4
+CONFIGURE_ENV= M4=${LOCALBASE}/bin/gm4 MAKEINFO="makeinfo --no-split"
INSTALL_TARGET= install-strip
INFO= flex
@@ -28,11 +29,8 @@ NLS_CONFIGURE_ENABLE= nls
post-patch: .SILENT
${REINPLACE_CMD} -Ee 's/tests//' \
- -e 's/^([[:space:]]*)\$$\(RANLIB\) ([^ ;]*)/\1chmod u+w \2;&/' \
- -e '/echo.*RANLIB/,+1d' \
+ -e '/mode=compile ..CC/s/\\$$/-fPIC -DPIC &/' \
${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e 's/@MAKEINFO@/& --no-split/g' \
- ${WRKSRC}/doc/Makefile.in
${RM} -f ${WRKSRC}/doc/*.info*
.include <bsd.port.mk>