aboutsummaryrefslogtreecommitdiff
path: root/textproc/foiltex
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-25 09:03:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-10-25 09:03:55 +0000
commit361fd3d1aead99d72030fc832ee6afe54273be52 (patch)
tree78c57b5d0d638dc3538ae9c05673cab00700ed38 /textproc/foiltex
parent7fb33dee926e6999266c2c8d5f5c4f5958e0da9d (diff)
downloadports-361fd3d1aead99d72030fc832ee6afe54273be52.tar.gz
ports-361fd3d1aead99d72030fc832ee6afe54273be52.zip
- Add NO_ARCH
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=424610
Diffstat (limited to 'textproc/foiltex')
-rw-r--r--textproc/foiltex/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/foiltex/Makefile b/textproc/foiltex/Makefile
index a8412feebc90..b6bab47f7bda 100644
--- a/textproc/foiltex/Makefile
+++ b/textproc/foiltex/Makefile
@@ -15,6 +15,7 @@ NO_CDROM= Redistribution on a not-for-profit basis only
USE_TEX= latex
NO_WRKSUBDIR= yes
+NO_ARCH= yes
LATEX_CMD= ${LOCALBASE}/bin/latex
@@ -22,12 +23,12 @@ FOIL_DIR= share/texmf/tex/latex/${PORTNAME}
FOIL_FILES= foil17.clo foil20.clo foil25.clo foil30.clo foils.cls \
foils.sty foilshrt.clo fltfonts.def
-OPTIONS_DEFINE= DOCS EXAMPLES
-
PORTDOCS= foiltex.dtx foiltex.dvi
PORTEXAMPLES= sampfoil.tex
PLIST_FILES= ${FOIL_FILES:S,^,${FOIL_DIR}/,}
+OPTIONS_DEFINE= DOCS EXAMPLES
+
do-extract:
${MKDIR} ${WRKSRC}
${CP} ${DISTDIR}/foiltex.ins ${WRKSRC}/foiltex.ins
@@ -44,10 +45,14 @@ do-install:
.for file in ${FOIL_FILES}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/${FOIL_DIR}
.endfor
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for file in ${PORTEXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${EXAMPLESDIR}