aboutsummaryrefslogtreecommitdiff
path: root/textproc/fzf
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-11-21 15:30:19 +0000
committerJohn Marino <marino@FreeBSD.org>2016-11-21 15:30:19 +0000
commita4fc1182ef4cf18ba23e03c685851eb7fb5a2257 (patch)
tree801ac1b449d3afe0f4a2556c920876c5c9c9c5c7 /textproc/fzf
parent8035720be88a66fa004921b4fb250eb78d02b3cf (diff)
downloadports-a4fc1182ef4cf18ba23e03c685851eb7fb5a2257.tar.gz
ports-a4fc1182ef4cf18ba23e03c685851eb7fb5a2257.zip
textproc/fzf: Several fixes required after last update
1. The proper variable is MAKE_ENV, not BUILD_ENV 2. The build steps must not be surpressed! Remove "@" from build step 3. The make command is contingent on the success of the cd command, so change the concatenation (";") to AND ("&&") and run the whole thing in a subshell 4. Additional CGO_ variables are required now. Define CGO_LDFLAGS so that ncurses library can be found and add another path for CGO_CFLAGS so that ncurses_dll.h can be found. Approved by: general and ncurses blankets
Notes
Notes: svn path=/head/; revision=426729
Diffstat (limited to 'textproc/fzf')
-rw-r--r--textproc/fzf/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/textproc/fzf/Makefile b/textproc/fzf/Makefile
index d155853ca082..e658694ccc7c 100644
--- a/textproc/fzf/Makefile
+++ b/textproc/fzf/Makefile
@@ -20,7 +20,8 @@ GH_SUBDIR:= src/github.com/${GH_ACCOUNT}/${PORTNAME}
GH_TUPLE= junegunn:go-runewidth:63c378b:runwidth/src/github.com/junegunn/go-runewidth \
junegunn:go-shellwords:35d512a:shellwords/src/github.com/junegunn/go-shellwords \
junegunn:go-isatty:66b8e73:isatty/src/github.com/junegunn/go-isatty
-MAKE_ENV+= CGO_CPPFLAGS="-I${NCURSESINC}"
+MAKE_ENV+= CGO_CPPFLAGS="-I${NCURSESINC} -I${NCURSESBASE}/include" \
+ CGO_LDFLAGS="-L${NCURSESLIB}"
PLIST_FILES= bin/fzf man/man1/fzf.1.gz
@@ -35,9 +36,9 @@ TMUX_RUN_DEPENDS= bash:shells/bash
TMUX_PLIST_FILES= bin/fzf-tmux man/man1/fzf-tmux.1.gz
do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/src/fzf; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} \
- go build -o bin/${PORTNAME}
+ (cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/src/fzf && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} \
+ go build -o bin/${PORTNAME})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/src/${PORTNAME}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}