aboutsummaryrefslogtreecommitdiff
path: root/textproc/gdome2
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 17:20:47 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-24 18:10:02 +0000
commit8a4ae08814823be994b752387aa5d33fba7797c8 (patch)
tree4d95f9d995b9d0e63e4059990a4b965fa13f4bca /textproc/gdome2
parent98190413142cb7dc137d5f91ae51f4d50e362605 (diff)
downloadports-8a4ae08814823be994b752387aa5d33fba7797c8.tar.gz
ports-8a4ae08814823be994b752387aa5d33fba7797c8.zip
textproc/gdome2: Fix build with llvm16
- Add LICENSE GPLv2 LGPL21 - Pet portclippy - Refresh patches - Adopt port Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'textproc/gdome2')
-rw-r--r--textproc/gdome2/Makefile28
-rw-r--r--textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c6
2 files changed, 24 insertions, 10 deletions
diff --git a/textproc/gdome2/Makefile b/textproc/gdome2/Makefile
index 2b826a739911..0f9c4a00c698 100644
--- a/textproc/gdome2/Makefile
+++ b/textproc/gdome2/Makefile
@@ -1,26 +1,40 @@
PORTNAME= gdome2
PORTVERSION= 0.8.1
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= textproc
MASTER_SITES= http://gdome2.cs.unibo.it/tarball/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Gnome DOM Engine
WWW= http://gdome2.cs.unibo.it/
-USES= gnome libtool pathfix pkgconfig
+LICENSE= GPLv2 LGPL21
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
+LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LIB
+
+USES= gnome libtool localbase pathfix pkgconfig
USE_GNOME= glib20 libxml2
+USE_LDCONFIG= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= GLIB_CONFIG="${LOCALBASE}/bin/pkg-config glib-2.0"
+
+INSTALL_TARGET= install-strip
+
CFLAGS+= -fcommon
-CPPFLAGS+= -I${LOCALBASE}/include
+
DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
+
+PORTDOCS= *
OPTIONS_DEFINE= DOCS
-PORTDOCS= *
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
post-patch:
@${FIND} ${WRKSRC} -type f -and \
diff --git a/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c b/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c
index 5b94efe8ecca..9a89320c8069 100644
--- a/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c
+++ b/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c
@@ -4,9 +4,9 @@ Patch by Harris Landgarten.
The patch was submitted on bug 448236, following the announcement on
https://mail.gnome.org/archives/xml/2012-August/msg00005.html
---- libgdome/gdomecore/gdome-xml-documentt.c.orig 2003-07-13 06:47:54.000000000 -0400
-+++ libgdome/gdomecore/gdome-xml-documentt.c 2012-12-23 08:57:23.000000000 -0500
-@@ -342,7 +342,11 @@
+--- libgdome/gdomecore/gdome-xml-documentt.c.orig 2003-07-13 10:47:54 UTC
++++ libgdome/gdomecore/gdome-xml-documentt.c
+@@ -342,7 +342,11 @@ gdome_xml_dt_internalSubset (GdomeDocumentType *self,
}
xmlNodeDumpOutput (out_buff, NULL, (xmlNode *)is, 0, 0, NULL);
xmlOutputBufferFlush(out_buff);