aboutsummaryrefslogtreecommitdiff
path: root/textproc/gdome2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-05-17 21:28:59 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-05-17 21:28:59 +0000
commit8e4282ffe63ea028c7fb47ddca3a33fb2de11b10 (patch)
tree20f89221f13a3554807c823b94c32e2ce26d93fa /textproc/gdome2
parent640e99a0f6887cb0f070643d171169e1da4f49d4 (diff)
downloadports-8e4282ffe63ea028c7fb47ddca3a33fb2de11b10.tar.gz
ports-8e4282ffe63ea028c7fb47ddca3a33fb2de11b10.zip
Catch up with libxml2 api breakage in 2.9.x
Notes
Notes: svn path=/head/; revision=354374
Diffstat (limited to 'textproc/gdome2')
-rw-r--r--textproc/gdome2/Makefile2
-rw-r--r--textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/textproc/gdome2/Makefile b/textproc/gdome2/Makefile
index 3c8df0791ad0..0acbac6ae420 100644
--- a/textproc/gdome2/Makefile
+++ b/textproc/gdome2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdome2
PORTVERSION= 0.8.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= textproc
MASTER_SITES= http://gdome2.cs.unibo.it/tarball/
diff --git a/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c b/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c
new file mode 100644
index 000000000000..5b94efe8ecca
--- /dev/null
+++ b/textproc/gdome2/files/patch-libgdome_gdomecore_gdome-xml-documentt.c
@@ -0,0 +1,20 @@
+Patch from Gentoo to fix libxml2 2.9 api change
+
+Patch by Harris Landgarten.
+
+The patch was submitted on bug 448236, following the announcement on
+https://mail.gnome.org/archives/xml/2012-August/msg00005.html
+--- libgdome/gdomecore/gdome-xml-documentt.c.orig 2003-07-13 06:47:54.000000000 -0400
++++ libgdome/gdomecore/gdome-xml-documentt.c 2012-12-23 08:57:23.000000000 -0500
+@@ -342,7 +342,11 @@
+ }
+ xmlNodeDumpOutput (out_buff, NULL, (xmlNode *)is, 0, 0, NULL);
+ xmlOutputBufferFlush(out_buff);
++#if LIBXML_VERSION < 20900
+ ret = g_strndup (out_buff->buffer->content, out_buff->buffer->use);
++#else
++ ret = g_strndup (xmlBufContent(out_buff->buffer), xmlBufUse(out_buff->buffer));
++#endif
+ (void)xmlOutputBufferClose(out_buff);
+
+ return gdome_xml_str_mkref_own (ret);